#mahara-dev Meeting

Meeting started by robertl_ at 08:05:56 UTC (full logs).

Meeting summary

    1. anitsirk is Kristina Hoeppner at Catalyst IT, Wellington, New Zealand (anitsirk, 08:06:14)
    2. robertl_ is Robert Lyon, Catalyst IT, Wellington, NZ (robertl_, 08:06:20)
    3. tobiasz is Tobias Zeuch, developer at KIT, Karlsruhe, Germany (tobiasz, 08:06:20)
    4. ghada-laptop is Ghada El-Zoghbi at Catalyst, Sydney, Australia (ghada, 08:06:31)
    5. yuliya is Yuliya Bozhko from Totara Learning Solutions, Wellington, NZ (yuliyabozhko, 08:06:40)
    6. aarowlaptop is Aaron G. Wells from Catalyst IT in Wellington NZ (aarowlaptop, 08:06:55)

  1. Items from last meeting (robertl_, 08:08:13)
    1. anzeljg is Gregor Anželj, developer and translator from Gimnazija Bežigrad, Ljubljana, Slovenia (anzeljg, 08:08:23)
    2. Item 1 from last meeting: robertl_ to look into the reviews permissions to see if the change author problem can be avoided and/or update the wiki page with more info (robertl_, 08:08:33)
    3. https://wiki.mahara.org/index.php/Developer_Area/Pushing_Git_Commits#Problems_with_pushing_patches_to_gerrit (robertl_, 08:08:57)
    4. ACTION: robertl_ to add info about sslverify (robertl_, 08:16:22)
    5. rkabalin Ruslan Kabalin, Lancaster University, UK (rkabalin, 08:17:40)
    6. ACTION: robertl_ to improve the documents about needing to sign-off a patch (robertl_, 08:21:29)
    7. Item 2 from last meeting: robertl_ to write his first mahara newsletter article on an upcoming 1.11 feature, the "artefact feedback on page" one funded by New York Institute of Technology (robertl_, 08:21:54)

  2. Mahara 1.10 release (Kristina) (robertl_, 08:22:56)
    1. We released Mahara 1.10 on Tuesday. Congrats to everyone who was involved. (anitsirk, 08:22:59)
    2. https://www.freesound.org/people/ultradust/sounds/166923/ let the champagne flow freely. (anitsirk, 08:23:00)
    3. Behat test infrastructure for automated functional testing is getting closer to being used for running tests. soon we'll be able to integrate them into mahara. (anitsirk, 08:29:41)

  3. Proposal: Change Mahara's version numbers (Kristina) (robertl_, 08:36:14)
    1. I don't think our current version numbering system is great. It doesn't give our users much insight into how far Mahara has come over the years. In contrast, it can be tricky to remember when a certain version was released and until when one is supported. (anitsirk, 08:36:20)
    2. IDEA: Therefore, I propose to change the versioning system to something more user friendly. I quite like the "date of release" numbering and in particular Ubuntu's way of having the year first and then the month in which a release was made, e.g. 15.04, 15.10. It shows you very quickly when a release was made, but doesn't judge how big or small a leap was made. (anitsirk, 08:36:20)
    3. http://en.wikipedia.org/wiki/Software_versioning for some short background reading on numbering systems. (anitsirk, 08:36:20)
    4. ACTION: kristina to update wiki with links to mahara groups (robertl_, 08:58:55)
    5. ACTION: kristina to write something to explain the release numbers (robertl_, 08:59:19)

  4. Mahara 1.11/15.04 - what's on the roadmap? (Robert) (robertl_, 09:01:48)
    1. https://wiki.mahara.org/index.php/Developer_Area/Specifications_in_Development (anitsirk, 09:02:04)
    2. the "Specifications in Development" page on the wiki contains, as robertl_ says, "a swag of things we would like to include into the next release or develop over the next few cycles - ranging from small pieces of work to some very large untertakings." (anitsirk, 09:02:49)
    3. the ideas you see in the list are a compilation of our ideas as well as ideas that we've gathered over the last months including Mahara Hui, Mahara UK, and the padlet https://mahara.org/view/view.php?id=120961 (anitsirk, 09:05:26)
    4. IDEA: anzeljg: create a database generator (for users that are on shared hosting) (anitsirk, 09:22:10)

  5. Next meeting and chair (robertl_, 09:24:16)
    1. http://www.timeanddate.com/worldclock/fixedtime.html?msg=38th+Mahara+Developer+Meeting&iso=20141127T08 (anitsirk, 09:30:06)
    2. rkabalin to chair the next mahara dev meeting on 27 November 2014 at 8:00 UTC: http://www.timeanddate.com/worldclock/fixedtime.html?msg=38th+Mahara+Developer+Meeting&iso=20141127T08 (anitsirk, 09:34:09)

  6. Any other business (robertl_, 09:34:35)


Meeting ended at 09:36:06 UTC (full logs).

Action items

  1. robertl_ to add info about sslverify
  2. robertl_ to improve the documents about needing to sign-off a patch
  3. kristina to update wiki with links to mahara groups
  4. kristina to write something to explain the release numbers


Action items, by person

  1. robertl_
    1. robertl_ to add info about sslverify
    2. robertl_ to improve the documents about needing to sign-off a patch
  2. UNASSIGNED
    1. kristina to update wiki with links to mahara groups
    2. kristina to write something to explain the release numbers


People present (lines said)

  1. anitsirk (90)
  2. robertl_ (79)
  3. ghada (65)
  4. yuliyabozhko (41)
  5. aarowlaptop (33)
  6. rkabalin (22)
  7. tobiasz (12)
  8. tonyjbutler (10)
  9. anzeljg (10)
  10. maharameet (2)
  11. anzeljg_ (1)
  12. waa_ (1)
  13. tonyjbutler_ (1)


Generated by MeetBot 0.1.4.