08:01:37 <rkabalin> #startmeeting
08:01:37 <maharameet> Meeting started Thu May 1 08:01:37 2014 UTC. The chair is rkabalin. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:37 <maharameet> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:01:43 <rkabalin> Hello and welcome to the 32nd Mahara developer meeting.
08:01:49 <rkabalin> Please introduce yourself by prefacing your introduction with the #info tag.
08:01:53 <anitsirk> #info anitsirk is Kristina Hoeppner, Catalyst IT, Wellington, New Zealand
08:01:59 <tobiasz> #info tobiasz is Tobias Zeuch, developer at the KIT, Karlsruhe, Germany
08:02:00 <anzeljg> #info anzeljg is Gregor Anželj, developer and translator from Gimnazija Bežigrad, Ljubljana, Slovenia
08:02:10 <rkabalin> #info rkabalin is Ruslan Kabalin, Lancaster University, UK
08:02:12 <aarow_> #info aarow_ is Aaron Wells in sunny Wellington New Zealand
08:02:33 <ghada> #infor ghada is Ghada El-Zoghbi, develper at Catalyst IT, Sydney, Australia
08:02:36 <ghada> #info ghada is Ghada El-Zoghbi, develper at Catalyst IT, Sydney, Australia
08:02:40 <anitsirk> seems like yuliya might have some irc issues. she was here but left again.
08:02:52 <rkabalin> ok
08:02:57 <rkabalin> #topic Items from last meeting
08:03:10 <rkabalin> #info everyone to look at list of enhancement suggestions made by the Ljubljana group
08:03:35 <rkabalin> I have to admit I did not look
08:03:38 <anitsirk> sorry, anzeljg. didn’t manage to look at the items in depth but only had a cursory look today.
08:04:05 <ghada> sorry, me too...
08:04:45 <rkabalin> shame, did anyone had chance to look?
08:04:48 <anzeljg> so postpone that untill another dev meeting? It would be nice to talk about these things then. Maybe we should add it to items list?
08:04:56 <tobiasz> One of the topics, the textbox-copy thing, is already being discussed in another thread
08:04:58 <aarow_> What was the URL?
08:05:05 <anitsirk> i’ll try to update the bug reports with my thoughts over the next couple of weeks. some need a bit more info, one or two need to be branched off as they are on an already closed bug / wishlist item.
08:05:18 <anitsirk> https://mahara.org/interaction/forum/topic.php?id=6283
08:05:26 <rkabalin> #action everyone to look at list of enhancement suggestions made by the Ljubliana group
08:05:33 <rkabalin> postponing to the next meeting
08:05:44 <anitsirk> and we are looking into the image selector within tinymce, but first want to implement tinymce 4
08:06:05 <anzeljg> #url https://mahara.org/interaction/forum/topic.php?id=6283
08:06:17 <anzeljg> anitsirk: sorry
08:06:21 <rkabalin> #link https://mahara.org/interaction/forum/topic.php?id=6283
08:06:43 <anitsirk> hi yuliyab. hope you won’t have irc troubles again like last time
08:06:53 <rkabalin> hello yuliyab
08:06:58 <yuliyab> hey
08:07:09 <yuliyab> can't connect through pidgin for some reason :(
08:07:34 <rkabalin> next item
08:07:50 <rkabalin> #info anzeljg to write forum post / forum posts letting community members know about the usability improvement suggestions made in Ljubljana
08:07:58 <anitsirk> that’s done
08:08:00 <rkabalin> that has been done I think
08:08:05 <rkabalin> #link https://mahara.org/interaction/forum/topic.php?id=6283
08:08:08 <anitsirk> that’s the link above
08:08:12 <rkabalin> ah, same link as above
08:08:14 <anzeljg> the fourth time :)
08:08:19 <rkabalin> heh
08:08:36 <anzeljg> somebody will now definitely remember to look at it :)
08:08:43 <anitsirk> :-)
08:08:47 <rkabalin> thanks anzeljg
08:08:56 <rkabalin> #info aarow_ to see how many files have a whitespace problem.
08:09:12 <anitsirk> rkabalin: shouldn’t that be #topic?
08:09:27 <rkabalin> no, it is itemd from hte last meeting
08:09:34 <anitsirk> ah right. sorry
08:10:11 <yuliyabozhko> I am all set, hope didn't miss much :)
08:10:12 <aarow_> I took a quick look at some of the biggest offenders today. There are about 2 dozen big files with a lot of whitespace in them, which cause problems for me due to the way Eclipse does end-of-line whitespace removal
08:10:32 <anitsirk> yuliyabozhko: nope. we started discussing hitespaces. nothing of importance on that before you came back
08:11:02 <ghada> aarow_ what does Eclipse do?
08:11:12 <yuliyabozhko> cool. I've beet trying to clean up whitespaces when I work in the same file area
08:11:14 <aarow_> For instance htdocs/artefact/lib.php has 116 lines with extra whitespace on the end. When I make a change to this file in Eclipse, it removes the whitespace from the end of all those lines, and then I have to pick through 116 different changes in "git add -p" to pick out my actual change for committing
08:11:22 <ghada> I use Eclipse and want to make sure I don't cause this...
08:11:49 <aarow_> ghada: The problem is that we've got a coding standard that says you can't have extraneous end-of-line whitespace
08:12:08 <aarow_> so I turn on Eclipse's setting to automatically remove end-of-line whitespace
08:12:09 <ghada> yes, Gerrit checks to make sure there are no extra spaces.
08:12:10 <yuliyabozhko> why don't we leave existing ones as they are and just clean them up as we go? just need to make sure not to introduce the new ones
08:12:20 <aarow_> but, Eclipse then does this to every line in the file instead of just the changed ones
08:12:39 <aarow_> so I change one line in lib/activity.php, and Eclipse then removes the whitespace from 116 lines of it
08:13:01 <aarow_> and then I have to carefully pick through the changes with git add -p to commit only my actually changed line
08:13:28 <yuliyabozhko> you should tell eclipse to stop doing that >.<
08:13:47 <aarow_> takes me a minute or two nearly every time I'm doing a commit, and it's really annoying. I want to just do a one-time commit to clean up these old files which were committed before we had this whitespace coding standard
08:13:49 <rkabalin> did we decid to push a change that removes every trailing whitespace in all files (excluding external libs)?
08:14:06 <aarow_> we talked about it but didn't come to a conclusion last time
08:14:07 <ghada> I use Eclipse and don't use the whitespace clean up. I turn on to view all formatting. And, can see if my changes have extra spaces or not.
08:14:12 <aarow_> which is how we came to say I'd look into it
08:14:28 <yuliyabozhko> we have a script that checks only changed code when a patch is pushed
08:14:57 <rkabalin> aarow_, why not to do the opposite, disable whitespace removal in Eclipse and make sure your change does not contain any of them when you do git diff
08:15:15 <yuliyabozhko> yes, second that
08:15:16 <aarow_> Because then I'd be wasting my time manually fixing my whitespace
08:15:32 <aarow_> which is on better than my current situation of wasting my time manually picking out my non-whitespace changes
08:15:37 <aarow_> *no
08:16:16 <yuliyabozhko> hmmm, I don't see a good solution to this problem really...
08:16:19 <aarow_> just one commit that fixes the whitespace on these old files, would make my life and the many commits that I make, a lot easier
08:16:49 <aarow_> I don't see that it would inconvenience anybody very much either, given that diff commands can ignore whitespace.
08:16:53 <rkabalin> push it then, just make sure you do not change code from external libs
08:17:44 <aarow_> sounds good to me
08:18:14 <tobiasz> I'm all in for the one time scrub
08:18:23 <yuliyabozhko> looking forward to rebase hell :)
08:18:47 <rkabalin> aarow_, alternatively you may cosider using different IDE, if that is an option.
08:18:52 <rkabalin> :)
08:19:09 <anitsirk> yuliyabozhko: it’s only 24 files or so that are big offenders. so you might not have touched them. :-)
08:19:19 <aarow_> I'll do some tests and see how much of a rebase problem such a commit would cause
08:19:40 <aarow_> and if it doesn't look too bad I'll just bite the bullet and do it
08:19:47 <yuliyabozhko> :) I am ok with that. I know how to rebase ;)
08:19:58 <rkabalin> the rebase hell will be short anyway
08:20:09 <aarow_> okay, shall we move on to the next topic then?
08:20:14 <yuliyabozhko> yep
08:20:21 <rkabalin> #action aarow_ do some tests and see how much of a rebase problem such a commit would cause
08:20:35 <rkabalin> #info rkabalin_ to update the dev documentation to reintroduce the requirement for avoiding trailing whitespaces
08:20:42 <rkabalin> that is done
08:20:44 <rkabalin> #link https://wiki.mahara.org/index.php/Developer_Area/Coding_guidelines#Whitespace
08:22:04 <rkabalin> probably require removing duplicates from recommended section
08:22:16 <rkabalin> which I missed from some reason ;/
08:22:50 <sonn1> Hi
08:22:59 <rkabalin> hello sonn1
08:23:00 <anzeljg> sonn1 hi
08:23:04 <ghada> hi sonn1
08:23:25 <sonn1> #info sonn1, Son Nguyen, Catalyst IT, Wellington, NZ
08:24:14 <rkabalin> ok, I updated https://wiki.mahara.org/index.php/Developer_Area/Coding_guidelines#Whitespace
08:24:16 <ghada> @rkabalin: much better with duplicates removed.
08:24:23 <rkabalin> #info aarow_ to update gerrit and launchpad settings to include the 3 new mahara core devs
08:24:32 <aarow_> done!
08:24:36 <rkabalin> cool
08:24:47 <rkabalin> ok, next topic
08:24:56 <rkabalin> #topic Mahara clone on github
08:24:59 <rkabalin> aarow_ chair is yours
08:25:34 <aarow_> We've had a few requests to put a clone of our repo up on github.com, so I went ahead and did that about 2 weeks back
08:25:38 <aarow_> https://github.com/maharaproject
08:25:53 <anitsirk> does that mean we should move all operations to github?
08:25:59 <aarow_> it's set up to sync to the repo on https://reviews.mahara.org using the same gerrit plugin that syncs the code to our gitorious repo
08:26:05 <rkabalin> #info Mahara repo on github.com https://github.com/maharaproject
08:26:06 <anitsirk> why were requests made to move to github?
08:26:20 <aarow_> No, I think for the time being it's okay to continue considering the gitorious repo our main repository
08:26:26 <yuliyabozhko1> it is easier to fork it there
08:26:41 <aarow_> The github repo is just a clone of it, to make it easier for github users to access Mahara
08:27:47 <rkabalin> Is the clone being automatically updated?
08:28:00 <ghada> do you want us to give you our github username here or send you an email?
08:28:06 <aarow_> yep, automatically synced using the gerrit replication plugin, which is also what we use to sync to gitorious
08:28:14 <rkabalin> I see
08:28:36 <ghada> so, there's not much of a delay?
08:28:49 <aarow_> Right, if you want to be added to the Mahara organization on github... yeah, probably easiest if you send me an email
08:28:52 <aarow_> aaronw@catalyst.net.nz
08:29:08 <yuliyabozhko1> :) with username
08:29:17 <aarow_> No, not much of a delay in the syncing. It seems to sync in 1 to 5 minutes
08:29:20 <rkabalin> #info anyone wants to be added to the Mahara organization on github send email to aarow_ aaronw@catalyst.net.nz
08:29:23 <aarow_> yes, with your github username
08:29:35 <rkabalin> #undo
08:29:35 <maharameet> Removing item from minutes: <MeetBot.items.Info object at 0x2bf3ed0>
08:29:45 <rkabalin> #info anyone wants to be added to the Mahara organization on github send email to aarow_ aaronw@catalyst.net.nz with github username
08:30:38 <rkabalin> #info github clon of mahara is being synced in 1 to 5 minutes automatically using the gerrit replication plugin
08:31:11 <aarow_> and that's everything for that topic :)
08:31:22 <rkabalin> what permissions the members of github project will have?
08:31:48 <yuliyabozhko1> we can set up dev team there, but I think it's read only repo?
08:31:53 <rkabalin> I suppose the dierect push should be disabled
08:32:07 <aarow_> Yeah, that repo is meant to be read-only. Any commits made directly there will get overwritten by the replication plugin I think
08:32:34 <aarow_> so the main reason to add other people as members of the project, would be so other people can manage it in case I get hit by a bus ;)
08:32:37 <rkabalin> ok, so what is the benefits then to be members?
08:32:49 <rkabalin> I see
08:33:18 <rkabalin> makes sense
08:33:43 <yuliyabozhko1> not that we want you to be hit by a bus :P ever
08:33:44 <rkabalin> aarow_ please be careful when you are crossing the road ;)
08:33:52 <aarow_> I guess the other thing to consider, is that there are other repositories in our gitorious project besides the main that one that holds Mahara itself. For instance, there's the mahara-scripts repository which contains associated scripts. Potentially we could have cloned these into github as well, but since we don't have any existing infrastructure set up to keep them up to sync I decided against it
08:34:33 <aarow_> Wellington does have a relatively high rate of pedestrians getting hit by buses... maybe that was a bad figure of speech to pick. ;)
08:34:44 <aarow_> But I always look both ways before crossing the street
08:34:54 <yuliyabozhko1> oh, talking about infrastructure when are we going to have tests and gerrit upgrade?
08:34:55 <rkabalin> ok, I think they may be added at the later point if required or requested by contrib maintainer
08:34:59 <anitsirk> we could move the manual over. wouldn’t make sense to keep it in two places. currently i’m pretty much the only committer.
08:35:13 <anitsirk> adding images into the separate manual image repository might make things easier
08:36:55 <rkabalin> #action aarow_ and everyone really: always look both ways before crossing the street
08:37:16 <rkabalin> ok, are we ready to move to the next topic
08:37:54 <ghada> what about the gerrit upgrade yuliyabozhko1 asked about?
08:38:01 <rkabalin> ah, sorry
08:38:09 <yuliyabozhko1> gerrit is really out of date right now
08:38:12 <rkabalin> spotted that one, sorry yuliyabozhko1
08:38:36 <yuliyabozhko1> new version has features that would make review easier
08:38:45 <aarow_> Procedurally speaking, that should probably come up in "other business" at the end since it wasn't on the agenda :)
08:38:51 <rkabalin> Who is maintaining gerrit?
08:38:56 <aarow_> that's us at Catalyst
08:39:01 <yuliyabozhko1> :) ok, I can wait
08:39:03 <aarow_> I do want to upgrade gerrit
08:39:15 <aarow_> we just need to have someone sit down and do it
08:39:50 <rkabalin> shall I add an action for you aarow_ to look into gerrit update?
08:39:59 <aarow_> sure
08:40:15 <aarow_> yuliya, you're already using the latest version of gerrit at Totara HQ, right?
08:40:23 <yuliyabozhko1> Alastair Munro does our upgrades in Totara if you need any help
08:40:27 <yuliyabozhko1> yep
08:40:36 <aarow_> ah, cool, I'll keep that in mind
08:40:37 <rkabalin> #action aarow_ look into gerrit update
08:40:39 <aarow_> although, he's in the UK, right?
08:41:02 <yuliyabozhko1> yep, but he is connected most of the time
08:41:14 <aarow_> well, I'll send him an email
08:41:38 <rkabalin> great
08:41:56 <rkabalin> thanks aarow_
08:42:05 <anitsirk> aarow_: note: he will have a totara email address. as he just switched as of today.
08:42:14 <rkabalin> next topic?
08:42:23 <ghada> yep
08:42:31 <yuliyabozhko1> yep
08:42:33 <rkabalin> #topic Next meeting and chair
08:42:41 <rkabalin> what about Thursday, 5th of June 2014 at 8 p.m. UTC (9 p.m. UK, 10 p.m. Europe)?
08:43:03 <yuliyabozhko1> what does it make in NZ?
08:43:12 <anitsirk> 8 am the next day
08:43:23 <aarow_> so June 6, 8am?
08:43:28 <ghada> which means what for Sydney?
08:43:29 <rkabalin> true, forgot NZ ))
08:43:40 <aarow_> um... 4 am Sydney I think?
08:43:41 <yuliyabozhko1> yeah, I suppose :) I am back from 1 month holiday on 3rd :)
08:43:47 <anitsirk> 6 am for sydney
08:44:03 <ghada> can we make it 8:30pm UTC?
08:44:05 <anitsirk> sydney is only 2 hours behind wellington, aarow_ :-)
08:44:20 <ghada> that extra half hour...
08:44:21 <aarow_> I think if we want to accommodate people in the UK, Aus, and NZ, we need to stick with around 8pm UTC
08:44:26 <aarow_> I mean, 8am UTC
08:44:50 <anitsirk> not to forget japan if jono finds time
08:44:56 <yuliyabozhko1> doesn't matter for me, so pick whatever suits others
08:45:08 <ghada> 8am UTC works for me.
08:45:11 <rkabalin> 8am is fine for me as well
08:45:22 <rkabalin> I just thought we are swapping am/pm each time
08:45:29 <anitsirk> either works for me.
08:45:40 <anitsirk> rkabalin: we haven’t done so lately to accommodate australia a bit better
08:45:48 <rkabalin> OK, 8am then?
08:45:51 <tobiasz> 8am UTC is fine for me
08:45:55 <sonn1> ok for me
08:45:55 <anitsirk> esp. at the time andrew in perth, but now it’s more likely that ghada will join regularly
08:46:14 <ghada> that would be great.
08:46:21 <aarow_> Yes, the last few meetings, since we've had more Australian presence, we've been sticking with one time. Of course, this makes it the middle of the night in the US, but if any Americans start wanting to attend we can go back to alternating the times. ;)
08:46:39 <yuliyabozhko1> good plan :)
08:47:06 <rkabalin> #agreed 33rd Mahara dev meeting on Thursday, 5th of June, at 8 a.m. UTC: http://www.timeanddate.com/worldclock/fixedtime.html?msg=Mahara+33rd+Developer+Meeting&iso=20140605T09&p1=1344
08:47:57 <rkabalin> #undo
08:47:57 <maharameet> Removing item from minutes: <MeetBot.items.Agreed object at 0x2a8aa50>
08:48:08 <rkabalin> #agreed 33rd Mahara dev meeting on Thursday, 5th of June, at 8 a.m. UTC: http://www.timeanddate.com/worldclock/fixedtime.html?msg=Mahara+33rd+Developer+Meeting&iso=20140605T08
08:48:14 <rkabalin> ^ in UTC
08:48:16 <anitsirk> yep. that’s the better link :-)
08:48:38 <rkabalin> who is willing to chair?
08:49:07 <anzeljg> at last meeting yulia volunteered?
08:49:24 <yuliyabozhko1> i WAS volunteered :P
08:49:28 <anzeljg> or was it tow meetings ao?
08:49:31 <anzeljg> ago?
08:49:38 <anzeljg> :)
08:49:39 <rkabalin> yuliyabozhko1 would you like to chair?
08:49:46 <yuliyabozhko1> I am leaving next week and coming back on June 3rd
08:50:09 <yuliyabozhko1> so, If you don't mind that I will be a bit out of date on everything that is happening, I can do
08:50:53 <rkabalin> I think that is fine, you will always have an agend to look at aand others to help
08:50:57 <yuliyabozhko1> and someone will have to tell me how to run meetings :)
08:51:05 <yuliyabozhko1> cool then
08:51:13 <rkabalin> #info yuliyabozhko1 to chair the 33nd Mahara dev meeting
08:51:20 <rkabalin> running meeting is easy
08:51:26 <yuliyabozhko1> :)
08:51:29 <rkabalin> https://wiki.mahara.org/index.php/Developer_Area/Developer_Meetings/Chair_Duties
08:51:34 <anzeljg> yuliabozhko1: https://wiki.mahara.org/index.php/Developer_Area/Developer_Meetings/Chair_Duties
08:51:37 <yuliyabozhko1> awesome, thanks
08:51:52 <anitsirk> the commands are pretty easy
08:52:08 <rkabalin> and you can use logs from previous meeting for reference
08:52:18 <yuliyabozhko1> yep, will have a look at that
08:52:23 <anitsirk> rotating the chair duties helps us all to learn them and then use them thus putting less pressure on the chairperson :-)
08:52:23 <yuliyabozhko1> thanks!
08:52:44 <yuliyabozhko1> :) fair enough
08:52:48 <anitsirk> it also helps to have the topic lines etc. already prepared so that you don’t have to type them up during the meeting
08:52:58 <anitsirk> but can just copy and paste.
08:53:35 <yuliyabozhko1> good to know :)
08:53:53 <rkabalin> ok, next topic
08:54:00 <anitsirk> also helps in other circumstances when you want to introduce your own topics
08:54:03 <anitsirk> and give background info
08:54:11 <rkabalin> #topic Any other business
08:54:13 <anzeljg> I have one...
08:54:31 <anitsirk> me too
08:54:50 <rkabalin> ok, anzeljg go on first
08:55:01 <anzeljg> Can we discuss it a bit more, to know what to expect or where this thing would turn?
08:55:09 <anzeljg> A proposal is here: https://bugs.launchpad.net/mahara/+bug/1314465
08:55:18 <anzeljg> Can we discuss it a bit more, to know what to expect or where this thing would turn?
08:55:19 <anzeljg> ..
08:55:39 <anzeljg> Local hook for adding custom sideblocks: I'm working on a project where I need to add custom sideblocks...
08:55:50 <rkabalin> looks useful
08:55:51 <anzeljg> sorry: wrong copy-paste :)
08:56:25 <aarow_> That's the bug for "Local hook for adding custom sideblocks", seems correct
08:56:51 <rkabalin> #info anzeljg porposes Local hook for adding custom sideblocks: https://bugs.launchpad.net/mahara/+bug/1314465
08:56:55 <anzeljg> the order of pasted lines...
08:57:04 <anzeljg> arrow had different oppinion on that?
08:57:21 <aarow_> right, well, I'm fine with adding the local hook
08:57:27 <rkabalin> I am not sure if block should be a plugin
08:57:44 <aarow_> but, I think in addition to that, if we want to really provide support for sideblocks, it'd make sense to make them a full-featured plugin type
08:58:05 <aarow_> The main thing I haven't been able to figure out is how a sideblock plugin would tell you what pages it should appear on
08:58:11 <rkabalin> it is plugin in Moodle though, but for mahara they are more like information containing section rather than course elements
08:58:36 <aarow_> For anyone who's unfamiliar with how sideblocks currently work, I wrote up a page about it on the wiki: https://wiki.mahara.org/index.php/Developer_Area/Sideblocks_API
08:59:13 <rkabalin> #info aarow_ wrote page about blocks functionality in Mahara: https://wiki.mahara.org/index.php/Developer_Area/Sideblocks_API
08:59:28 <aarow_> The way I envision it, sideblock plugins would not be something that users decide to add. Rather... they would just show up, on the relevant pages, much like the core sideblocks do
09:00:00 <aarow_> I can think of plenty of use-cases where an organization might want to add additional types of sideblocks to Mahara
09:00:02 <ghada> so, it's determined by the group - a setting there.
09:00:15 <ghada> ?
09:00:29 <aarow_> well, that's the tricky part. The way sideblocks currently work, is there are hard-coded "if" statements in the smarty() method in lib/web.php
09:00:42 <aarow_> these examine various things about the page being loaded, and decide which sideblocks are appropriate
09:00:48 <anzeljg> to explain my situation: i will have to add a sideblock which will display different links in different groups (if that helps)
09:00:52 <aarow_> like the "login" sideblock, the profile sideblock, etc
09:01:23 <aarow_> additionally, a page can request that specific sideblocks be displayed on it using a parameter to the smarty() method. This is how the user file quote sideblock shows up
09:01:46 <aarow_> so, requesting specific sideblocks on specific pages would work for, say, a sideblock that comes along with an artefact plugin, that wants to add the sideblock to pages dealing with that artefact
09:02:03 <aarow_> but in the case anzeljg is describing, you'd have to modify the /group pages in order to use the smarty() param method to load that sideblock
09:02:46 <anzeljg> I am aware of that, but the soulution should (if possible) not change core files...
09:02:59 <aarow_> I guess one possibility I was considering, is that each sideblock plugin could have its own "should I show up on this page?" method that gets called on each page load
09:03:17 <aarow_> that would look much like the sample local_sideblocks() method that anzeljg posted to that bug
09:03:17 <tobiasz> could you, maybe optionally/additionally, register sideblocks with the menu path?
09:05:12 <aarow_> yeah, examining the menu path is one way the sideblocks could decide whether they should show up or not
09:05:35 <rkabalin> I think for now hook is easier solution that will work for anzeljg problem, if someone is willing to develop a proper plugin infrastructure for blocks, they could do that when needed.
09:05:37 <anzeljg> I think that's what I did in sample method :)
09:06:00 <aarow_> rkabalin: yeah, that's what I was thinking
09:06:13 <aarow_> anzeljg's hook is a low-effort way to at least make custom sideblocks possible
09:06:26 <rkabalin> yep
09:06:33 <anzeljg> great
09:06:52 <aarow_> hm, and I think just from describing this to you all I've got some more ideas about how to handle sideblocks as a full-fledged plugin ;)
09:07:19 <anzeljg> great * 2
09:07:29 <yuliyabozhko1> power of brainstorming!
09:07:33 <tobiasz> why wouldn't you allow administrators to disable the sidblock-plugin?
09:07:37 <rkabalin> aarow_ feel free to create wiki page with feature proposal
09:07:51 <yuliyabozhko1> and implement it
09:07:52 <yuliyabozhko1> ;)
09:08:01 <rkabalin> :D
09:08:08 <aarow_> tobiasz: If we made sideblocks into a full plugin type, admins would be able to disable them using the Extensions page
09:08:22 <aarow_> hm, I think it might actually be easier for admins to disable them, in fact
09:08:42 <aarow_> currently there isn't really any way to do that, except that many of the sideblocks have their own $CFG setting to enable/disable them
09:09:14 <aarow_> and anzeljg's new local hook would also let you remove specific sideblocks, since it takes the whole $SIDEBLOCKS array as a param
09:09:45 <ghada> we'd still keep the user sideblock, etc visible. It wouldn't be disabled...
09:10:23 <ghada> or is that also up to the admin?
09:10:38 <aarow_> Yes, if I turned sideblocks into a full-fledged plugin type, then all the existing sideblocks would get turned into sideblock plugins, and we'd make sure the upgrade script displays them all the same as it currently does
09:11:05 <aarow_> the main difference would be, that if they were a plugin type, it would be easier for 3rd party devs to write new sideblock types
09:11:19 <aarow_> also, sideblocks could potentially have their own crons, configs, and all the other things that go along with being a Mahara plugin type
09:11:37 <rkabalin> shall we move sideblocks discussion to the next meeting as separate item then?
09:11:42 <ghada> would reduce core hacking...
09:12:27 <aarow_> I don't think it even needs to be on the agenda for next time
09:12:42 <aarow_> If I write up a proposal, I'll add that to the agenda. :)
09:12:50 <aarow_> otherwise, we can just leave it off
09:13:04 <rkabalin> ok, thanks
09:13:09 <yuliyabozhko1> sounds good
09:13:11 <aarow_> anzeljg's patch just needs to be verified and merged
09:13:37 <aarow_> anyway, nothing further on that topic
09:14:13 <rkabalin> thanks aarow_
09:14:41 <rkabalin> anitsirk you had another item to discuss
09:14:49 <anitsirk> i just wanted to invite everyone to raise their virtual glasses in celebration of the release of mahara 1.9. It's been almost three weeks now that we had yet another release with great features. thank you to everyone who contributed to make it possible.
09:15:23 <yuliyabozhko1> :) yay!
09:15:23 <ghada> **clinking of glasses
09:15:27 <aarow_> cheers
09:15:32 <anzeljg> cheers
09:15:33 <tobiasz> cheers
09:15:35 <tonyb> cheers
09:15:37 <aarow_> (in the toasting sense, rather than the NZ "thanks" sense ;) )
09:16:13 <rkabalin> cheers
09:16:14 <rkabalin> :D
09:16:34 <anitsirk> that’s it from me.
09:16:42 <rkabalin> thanks anitsirk
09:16:56 <rkabalin> anything else we missed?
09:17:17 <rkabalin> no?
09:17:18 <ghada> i think you got it all.
09:17:19 <yuliyabozhko1> can't think of anything
09:17:23 <rkabalin> ok
09:17:25 <rkabalin> #endmeeting