20:01:24 <aarowlaptop> #startmeeting
20:01:24 <maharameet> Meeting started Thu Oct 3 20:01:24 2013 UTC. The chair is aarowlaptop. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:24 <maharameet> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:02:01 <aarowlaptop> There doesn't seem to be anyone present at the moment, but there's also very little on the agenda this month.
20:02:52 <aarowlaptop> Hi robertl_
20:02:52 <robertl_> morning all
20:03:45 <aarowlaptop> There's not much on the agenda this month, and there aren't many people present (just you and I so far)
20:04:09 <robertl_> right
20:04:59 <aarowlaptop> So, I may wait a few minutes to see if anyone else shows up
20:05:16 <aarowlaptop> Basically all that's on the agenda is:
20:05:41 <aarowlaptop> #topic The first release candidate for 1.8 was released a few days ago
20:06:41 <aarowlaptop> #link https://mahara.org/interaction/forum/topic.php?id=5739
20:07:29 <aarowlaptop> #info Thank you to dobedobedoh for pointing out the issues with the skins strings not showing up in Launchpad
20:08:19 <aarowlaptop> and the other item on the agenda was
20:08:45 <aarowlaptop> #topic Yesterday we released a minor release with a couple of major security fixes in it
20:08:56 <aarowlaptop> #link https://mahara.org/interaction/forum/topic.php?id=5756
20:09:49 <aarowlaptop> #info Basically there was some of what OWASP calls "Access control enforced by presentation layer", in our handling of artefacts & blocks
20:09:53 <aarowlaptop> #link https://www.owasp.org/index.php/Access_control_enforced_by_presentation_layer
20:12:17 <aarowlaptop> Mahara is *very* thorough about checking the user's permission to do see or do anything with a particular View, but it was a bit lax on checking permission for other things.
20:14:04 <aarowlaptop> #info Also, because we're close to the 1.8.0 release, this was probably the final 1.5 release, in keeping with our release policy
20:15:45 <aarowlaptop> So, that's what's on the agenda.
20:16:45 <robertl_> so how has the community response been to the 1.8 release candidate?
20:17:03 <robertl_> are lots of bugs being found?
20:17:42 * robertl_ asks his questions again
20:17:44 <robertl_> so how has the community response been to the 1.8 release candidate?
20:17:46 <robertl_> are lots of bugs being found?
20:18:17 <aarowlaptop> Only 2 that I know of so far
20:18:49 <robertl_> well hopefully people test now - rather than waiting
20:18:50 <aarowlaptop> A total of 36 downloads of the release candidate via the Launchpad release page
20:23:57 <robertl_> having not been around for 1.7 release - do many test and get back to us with issues?
20:24:16 <aarowlaptop> There weren't a whole lot that time. :)
20:24:34 <aarowlaptop> although the 1.7.0 release didn't introduce very much of anything
20:24:55 <aarowlaptop> I think the only new major feature in 1.7 was the selectable licenses system
20:25:24 <robertl_> right - so we'd like more of a testing /poking about from the community this time
20:26:15 <robertl_> we should run a 'make a skin' competition to get the community playing with the site :)
20:26:37 <aarowlaptop> #topic Discussing the 1.8rc1 release again
20:26:58 <aarowlaptop> #idea Run a "make a skin" competition to encourage more testing of the features
20:27:51 <robertl_> it could generate some nice skins that people could download to use
20:30:18 <robertl_> I imagine with the skins that there will be some use cases where things break - to to css overriding that skins does
20:31:13 <robertl_> so it would be good if we could find out sooner rather than later any css issues
20:31:53 <robertl_> eg these skins will work with theme A,B,C but not D,E sort of thing
20:32:36 <aarowlaptop> Yeah
20:33:00 <aarowlaptop> We were talking about doing that in order to try to get some default skins to ship with the feature, but we put it on the backburner when we decided not to include default skins
20:33:09 <aarowlaptop> But, it's a good idea to encourage testing
20:33:24 <aarowlaptop> I'll post it up on the forum. Or I'll ask Kristina to.
20:34:10 <aarowlaptop> #action Aaron to get the "make a skin" contest up on the Mahara forum
20:38:38 <aarowlaptop> Okay, any other topics for discussion?
20:39:08 <aarowlaptop> I think we can probably call this one a wrap. Since there's no one around at the moment, I'll send out an email about when to hold the next one.
20:39:19 <robertl_> ok cool
20:39:28 <aarowlaptop> #topic Next meeting
20:39:42 <aarowlaptop> #action Aaron to send out an email to confirm the next meeting time and invite people to chair.
20:40:27 <aarowlaptop> #endmeeting