#mahara-dev Meeting

Meeting started by iarenaza at 20:10:10 UTC (full logs).

Meeting summary

    1. iarenaza is Iñaki Arenaza, Mondragon Unibertsitatea, Spain (iarenaza, 20:10:22)
    2. aqualaptop is Hugh Davenport, Catalyst IT Ltd, NZ (aqualaptop, 20:10:35)
    3. anzeljg is Gregor Anželj, Gimnazija Bežigrad, Ljubljana, Slovenia (anzeljg, 20:10:44)
    4. sonn Son Nguyen, Catalyst IT Ltd., NZ (sonn, 20:10:45)

  1. Items from last meetings (iarenaza, 20:11:02)
    1. https://wiki.mahara.org/index.php/Developer_Area/Coding_guidelines (aqualaptop, 20:15:13)
    2. https://wiki.mahara.org/index.php/Developer_Area/Coding_guidelines (aqualaptop, 20:16:55)
    3. language guidelines to have, php, js, css, tpl, sql, xml (aqualaptop, 20:17:24)
    4. If anyone can skim over the Coding guidelines, let Hugh know about changes, suggestions, etc. (iarenaza, 20:17:48)
    5. https://wiki.mahara.org/index.php/Developer_Area/Specifications_in_Development/External_media_block_extension (iarenaza, 20:19:12)
    6. IDEA: Include oEmbed in core (making use of safe iframes), and use embed.ly (as a contributed plugin) for those that can't use oEmbed (iarenaza, 20:27:57)
    7. https://wiki.mahara.org/index.php/6MonthlyCycle (aqualaptop, 20:32:19)
    8. https://wiki.mahara.org/index.php/6MonthlyCycle (aqualaptop, 20:32:24)
    9. ACTION: iarenaza to contact Laurent (via dajan) and tell him about the plan and the dates. (iarenaza, 20:34:12)

  2. Supported android versions (and iphone?) for responsive design (2.2?) (iarenaza, 20:34:51)
    1. http://en.wikipedia.org/wiki/IOS_version_history (aqualaptop, 20:39:32)
    2. AGREED: (iarenaza, 20:50:35)
    3. AGREED: support responsive design on 2.2+ for android and 4.2.1+ for ios (iarenaza, 20:51:23)

  3. Testers welcome during RC period (incl new responsive design, as well as other new features) (iarenaza, 20:51:45)
    1. UI freeze is happening today (iarenaza, 20:52:26)
    2. lots of new features in 1.6, and lots of UI changes (iarenaza, 20:53:10)
    3. when RC comes out, install it (or upgrade it), and test, and file bugs (iarenaza, 20:54:13)

  4. Next steps for the release (iarenaza, 20:57:26)
    1. https://wiki.mahara.org/index.php/6MonthlyCycle (aqualaptop, 20:57:45)
    2. RC comes out next week, then 3 weeks of testing (with only critical bugs fixed) (iarenaza, 20:59:14)
    3. 1st week of october, 1.6 is released (iarenaza, 20:59:39)

  5. Next meeting and Chair (iarenaza, 21:10:22)
    1. ACTION: aqualaptop to chair next meeting (iarenaza, 21:11:25)
    2. http://www.timeanddate.com/worldclock/fixedtime.html?iso=20121017T0730&msg=21st%20Mahara%20Developer%20Meeting (iarenaza, 21:13:53)
    3. http://www.timeanddate.com/worldclock/fixedtime.html?iso=20121017T0730&msg=21st%20Mahara%20Developer%20Meeting (aqualaptop, 21:14:59)

  6. Any other business (iarenaza, 21:15:38)
    1. https://reviews.mahara.org/#/q/status:open+project:mahara+branch:master+topic:twig,n,z (aqualaptop, 21:16:18)
    2. https://bugs.launchpad.net/mahara/+bug/966001 (aqualaptop, 21:16:26)
    3. IDEA: document PluralForms and their usage somewhere on the wiki (iarenaza, 21:22:25)
    4. http://master-mahara.catalystdemo.net.nz/ (has the responsive theme on it, current with review system) (aqualaptop, 21:26:47)
    5. ACTION: anzeljg (with help from someone at Catalyst) will document PluralForms and their usage on the wiki (iarenaza, 21:29:30)


Meeting ended at 21:42:53 UTC (full logs).

Action items

  1. iarenaza to contact Laurent (via dajan) and tell him about the plan and the dates.
  2. aqualaptop to chair next meeting
  3. anzeljg (with help from someone at Catalyst) will document PluralForms and their usage on the wiki


Action items, by person

  1. anzeljg
    1. anzeljg (with help from someone at Catalyst) will document PluralForms and their usage on the wiki
  2. aqualaptop
    1. aqualaptop to chair next meeting
  3. iarenaza
    1. iarenaza to contact Laurent (via dajan) and tell him about the plan and the dates.


People present (lines said)

  1. aqualaptop (166)
  2. iarenaza (124)
  3. anzeljg (44)
  4. sonn (8)
  5. elky (6)
  6. maharameet (3)
  7. jimcrib (1)


Generated by MeetBot 0.1.4.