07:37:42 <elky> #startmeeting
07:37:42 <maharameet> Meeting started Wed May 23 07:37:42 2012 UTC. The chair is elky. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:37:42 <maharameet> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:38:04 <anzeljg> #info anzeljg is Gregor An�elj, Gimnazija Be�igrad, Ljubljana, Slovenia
07:38:15 <anitsirk> #info anitsirk is Kristina Hoeppner, Catalyst IT, NZ
07:38:27 <sonn1> #info sonn Son Nguyen, Catalyst IT, NZ
07:38:27 <rkabalin_> #info rkabalin_ Ruslan Kabalin - Lancaster University, UK
07:38:31 <elky> #info elky is melissa draper, catalyst IT, NZ
07:38:36 <dobedobedoh> #info dobedobedoh is Andrew Nicols, Lancaster University, UK
07:38:48 <richardm> #info richardm Richard Mansfield, Catalyst IT
07:38:49 <hughdavenport`> #info hughdavenport` is Hugh Davenport, Catalyst IT, NZ
07:38:50 <alanmc> #info alanmc is Alan McNatty, Catalyst IT, NZ
07:39:22 <lamiette> #info lamiette is Stacey Walker, Catalyst IT Europe
07:39:41 <elky> is that everyone?
07:39:58 <elky> #topic Items from last meeting: anitsirk to update the roadmap
07:40:29 <anitsirk> #info the update of the roadmap files with links to the blueprints is done
07:40:50 <elky> #link Agenda: https://wiki.mahara.org/index.php/Developer_Area/Developer_Meetings/2012-05-23
07:42:14 <elky> anitsirk, next item?
07:42:34 <elky> #topic Items from last meeting: dajan to raise appropriate issues in the tracker
07:42:43 <anitsirk> BTW: for those who haven't been here for a long time, please put a ".." in a separate line if you have text that is very long and needs to stretch over multiple lines
07:43:01 <elky> dajan isn't here I don't think, anyone know if that was done?
07:43:04 <anitsirk> elky: what was that about again/
07:43:05 <anitsirk> ?
07:43:10 <anitsirk> dajan might have already finished that
07:43:32 <elky> i'm not sure, i'm just following the agenda :)
07:43:37 <elky> moving on then
07:43:48 <elky> #topic anzeljg To put together a quick wiki page with some information (possibly code too)
07:43:54 <anzeljg> Sorry, but I haven't done that yet...
07:43:58 <anzeljg> I had troubles with using/creating custom Pieform element to give users abilitiy to select files to include in page/view when they drag and drop block to it's position in view/page.
07:44:03 <anzeljg> It worked for single folder, but wanted to create filemanager of some sort, to allow navigating through filders and sub-folders.
07:44:08 <anzeljg> Finally found Datatables plugin for jQuery (http://datatables.net/), but there are License compatibility questions/issues I want to ask/raise later...
07:44:14 <anzeljg> Anyway, now I have to integrate this into custom Pieform element and test if it works, and then the plugin (initial version) should be completed. Hopefully till Mahara UK 2012 Conference as I want to present the plugin there...
07:44:15 <anzeljg> ..
07:44:30 <elky> anzeljg, is that the licence thing you were asking about earlier today?
07:44:35 <anzeljg> yep
07:44:51 <elky> cool
07:45:15 <elky> #topic Mahara reviewer applications
07:45:33 <elky> alan's up first :)
07:45:52 <anitsirk> alanmc: can you please put in the link to your wiki page?
07:45:54 <elky> I don't know how these go, never seen one happen
07:45:55 <dobedobedoh> It seems the wiki is down too by the way
07:45:59 <anitsirk> (and the others up for review as well)
07:46:06 <anitsirk> what? i just accessed it
07:46:07 <elky> dobedobedoh, i have it up
07:46:10 <alanmc> https://wiki.mahara.org/index.php/User:Alanmc
07:46:13 <dobedobedoh> wait... no it' sjust me
07:46:29 <lamiette> *snigger*
07:46:51 <anitsirk> http://meetbot.mylittleproject.co.uk/mahara-dev/2011/mahara-dev.2011-06-29-19.35.log.html#l-310 -< that's what we did last time
07:47:15 <elky> #link https://wiki.mahara.org/index.php/User:Alanmc
07:47:40 <anitsirk> #info: alanmc reviewer application
07:47:52 <anitsirk> #info: sonn1 reviewer application
07:48:00 <anitsirk> #info: elky reviewer application
07:48:16 <sonn1> #link https://wiki.mahara.org/index.php/User:Ngson2000
07:48:45 <elky> #link https://wiki.mahara.org/index.php/User:Melissadraper
07:49:28 <anitsirk> only current reviewers can vote on the applications. that are as per richardm 's extracted list: http://paste.dollyfish.net.nz/4b8f4a: richardm, lamiette, hughdavenport`, rkabalin_, dobedobedoh, bug, lordp, danp
07:50:07 <anitsirk> i'll count votes so there's no way elky sees them as chair as she is up as reviewer as well. ;-)
07:50:18 <anitsirk> and hopefully, we won't have a fire alarm again as last time.
07:50:24 <elky> darn, there goes my evil plan
07:50:30 <hughdavenport`> muhahaha
07:50:32 <alanmc> heh
07:50:41 <anitsirk> so we have 5 out of 8 present today
07:51:07 <anzeljg> that's majority
07:51:14 <anitsirk> #info: dobedobedoh said last time "consensus decision rules, with those at the meeting entitled to vote"
07:51:45 <dobedobedoh> so three votes needed
07:51:47 <anitsirk> do current reviewers have any questions for the applicatants?
07:52:25 <dobedobedoh> none from me (well nothing sensible)
07:52:32 <anitsirk> https://wiki.mahara.org/index.php/Developer_Area/Code_Review actually details the "Becoming a Reviewer"
07:52:32 <rkabalin_> How did they came accross Mahara? :)
07:52:57 <alanmc> I'll start ..
07:53:07 <rkabalin_> just in few words
07:53:17 <alanmc> Kinda looking for a problem to solve really .. kinda back-to-front ;)
07:53:17 <anitsirk> oh, alanmc is verbose today ;-)
07:53:51 <elky> I was seconded for bug squishing for 1.4, and got sucked in :)
07:54:06 <elky> It's a really nice project to work on.
07:54:10 <rkabalin_> alanmc: ok, the same way as me then
07:54:24 <sonn1> bug fixing for master
07:55:00 <alanmc> rkabalin_: yes .. I hear a lot of positive things from 2 hand but would love to be closer to the end users .. so that changes can be appreciated
07:55:38 <anitsirk> alanmc: the mobile stuff you do is very much appreciated among users. also you responding to their queries.
07:55:55 <rkabalin_> thanks, no more questions from me
07:56:01 <alanmc> anitsirk: a field trip is overdue :)
07:56:09 <anitsirk> hehe
07:56:38 <dobedobedoh> question from me: If you had to implement one new feature in mahara to improve the platform, what would it be?
07:57:05 <elky> We have to pick just one? :(
07:57:06 <richardm> nice question dobedobedoh!
07:57:08 <rkabalin_> dobedobedoh: that is a sensible one :)
07:57:20 <alanmc> dobedobedoh: my preference would be to review theming/layout to work on wider arrange of devices
07:57:27 <dobedobedoh> it can be an existing feature in development, or something fresh and new
07:57:28 <sonn1> multiple language
07:57:37 <anitsirk> sonn1: what do you mean by that?
07:57:41 <alanmc> sonn1: interesting?
07:57:56 * dobedobedoh guesses multilang
07:58:07 <sonn1> yes
07:58:17 <alanmc> | more
07:58:25 <anitsirk> in what sense? more lang packs? easier access to the interface translation? automatic translation of the portfolio?...
07:58:43 <dobedobedoh> <span class="multilang" lang="en">English</span><span class="multilang" lang="au">Australian</span>
07:58:44 <sonn1> more language packs
07:58:54 <sonn1> can display in different languages
07:58:56 <dobedobedoh> ah okay, not what I had in mind ;)
07:59:20 <sonn1> translation feature
07:59:28 <sonn1> and so on
07:59:54 <elky> I'd love to see improvements to the accessibility.
07:59:55 <richardm> sonn1 and i had a discussion about support for translations of user content
07:59:58 <richardm> we don't have that yet
08:00:15 <dobedobedoh> elky: Do you have anything specific in mind. One specific change?
08:00:31 <anitsirk> that would be interesting. also the ability to store your CV in multiple languages (idea from Klaus and team in Austria)
08:00:59 <anzeljg> richardm: it is kindda implemented for showing Europass stuff in different languages...
08:01:13 <anzeljg> maybe in that direcion?
08:01:14 <richardm> ah, nice
08:01:53 <anzeljg> not everything is translatable, but majority
08:01:58 <richardm> we were specifically thinking the first priority would be stuff like the homepage content
08:01:58 <elky> dobedobedoh, vision-impaired friendly theming and settings that help users adjust to their specific accomodations
08:02:16 <elky> eg: high-contrast theme with configurable text size
08:02:59 <elky> and i think we could do with making sure the entire site is able to be keyboard driven
08:03:14 <anitsirk> #idea from reviewer applicant alanmc for new mahara feature: review theming/layout to work on wider arrange of devices
08:03:25 <dobedobedoh> (that's all of my questions)
08:03:43 <anzeljg> back
08:03:59 <anitsirk> #idea from reviewer applicatant sonn1 (and richardm) for new mahara feature: support for translation of user content and homepage content
08:04:34 <anitsirk> #idea from reviewer applicant elky for new mahara feature: improvements to accessibility, e.g. vision-impaired friendly theming and settings that help users adjust to their specific accomodations
08:04:55 <anitsirk> any other questions? richardm, lamiette or hughdavenport`?
08:05:00 <hughdavenport`> nothing from me
08:05:04 <richardm> none from me
08:05:16 <alanmc> elky: curious about the keyboard driven .. could that be as simple as an audit of say use of accesskey etc to be able to 'make it work' .. anything tangible?
08:05:17 <lamiette> non thanks
08:05:29 <anitsirk> then let's move to the voting, shall we?
08:05:31 <dobedobedoh> (I did that a few years ago)
08:05:37 <elky> alanmc, yep. it'd make your job a lot easier too
08:05:52 <anitsirk> all of you who can vote...
08:06:23 <hughdavenport`> sounds like a plan
08:06:26 <anitsirk> please say "#agreed for [nickname of applicatant] to become Mahara reviewer" (without the quotes)
08:06:28 <alanmc> dobedobedoh: cool ... elky yeah it's always a battle with latest jQuery foo and being able to support accessibility .. I'm not super flash on that - it's easy to forget
08:07:20 <dobedobedoh> #agreed for elky to become a Mahara reviewer
08:07:27 <dobedobedoh> #agreed for alanmc to become a Mahara reviewer
08:07:37 <dobedobedoh> #agreed for sonn1 to become a Mahara reviewer
08:07:41 <rkabalin_> #agreed for alanmc to become Mahara reviewer
08:07:46 <hughdavenport`> #agreed for elky to become a Mahara reviewer
08:07:54 <rkabalin_> #agreed for elky to become Mahara reviewer
08:08:00 <hughdavenport`> #agreed for alanmc to become a Mahara reviewer
08:08:05 <rkabalin_> #agreed for sonn1 to become Mahara reviewer
08:08:10 <lamiette> #agreed for elky to become a Mahara reviewer
08:08:11 <hughdavenport`> #agreed for sonn1 to become a Mahara reviewer
08:08:15 <richardm> #agreed for alanmc to become Mahara reviewer
08:08:17 <lamiette> #agreed for alanmc to become a Mahara reviewer
08:08:22 <lamiette> #agreed for sonn1 to become a Mahara reviewer
08:08:26 <richardm> #agreed for elky to become a Mahara reviewer
08:08:31 <richardm> #agreed for sonn1 to become Mahara reviewer
08:08:41 <anitsirk> ok. i think that's all. let me count...
08:09:17 <anitsirk> #agreed: elky to become Mahara reviewer (5 out of 5 votes present)
08:09:39 <anitsirk> #agreed: alanmc to become Mahara reviewer (5 out of 5 votes present)
08:09:59 <anitsirk> #agreed: sonn1 to become Mahara reviewer (5 out of 5 votes present)
08:10:07 <anitsirk> congratulations, new reviewers
08:10:16 * alanmc is pleased he didn't get asked about how many spaces for indents and nested curly braces
08:10:36 <sonn1> thanks
08:10:41 <anitsirk> the reason behind adding having new reviewers is to lessen the load on the existing ones as - to be honest - most reviewers on the list don't review much. ;-)
08:10:57 <rkabalin_> treu
08:11:01 <anitsirk> sorry to be so blunt.
08:11:28 <alanmc> anitsirk: start the 12m counter eh
08:11:31 <anitsirk> it would be great if the workload of reviewing were spread more widely so that some people don't just do reviews, i think.
08:11:32 <elky> ok, everyone ready for the next topic?
08:11:41 <anitsirk> alanmc: he?
08:11:42 <sonn1> yes
08:12:27 <elky> #topic Discuss/decide on style guidelines for CSS https://reviews.mahara.org/#/c/1098/ Melissa/Hugh
08:12:37 <hughdavenport`> ohai
08:13:08 <hughdavenport`> So yeh, for the coding guidelines, we have guidelines for php, and a link down the bottom of the wiki page for JS
08:13:12 <hughdavenport`> but nothing for CSS
08:13:13 <elky> Ok, hugh and I had a bit of a disagreement yesterday about whether to let some inconsistant css code in :)
08:13:34 <elky> so we figured it should be brought up/discussed/mandated
08:13:39 <hughdavenport`> I submitted some code for theming that one of our designers had done
08:13:46 <hughdavenport`> and it had lots of TAB's
08:13:55 <hughdavenport`> so i replaced with spaces, as per coding guidelines
08:13:58 <elky> tabs and spaces in the same declaration :(
08:14:06 <hughdavenport`> though, in the same block, what elky said ^^
08:14:32 <alanmc> is there a csslint or equiv?
08:14:34 <elky> I'm still pretty sure i was more right.
08:14:59 <hughdavenport`> alanmc: that would only check for validity, this is about style mainly
08:15:03 <anzeljg> #link http://csslint.net/
08:15:17 <dobedobedoh> I think we should also consider running css through a cssoptimiser
08:15:24 <hughdavenport`> but it probably would be good to hook that up to the jenkins stuff :D
08:15:31 <anitsirk> #info CSS has most often tabs and was replaced with spaces as per coding guidelines. what shall be done about it in the future?
08:15:46 <anitsirk> #idea: run css through cssoptimiser (dobedobedoh)
08:15:48 <alanmc> dobedobedoh: you said what I meant
08:15:55 <alanmc> :)
08:16:01 <anitsirk> #idea: make a hook in jenkins (hughdavenport`)
08:16:04 <richardm> I'd be keen on putting it in the jenkins stuff so it only complains about new lines being added
08:16:05 <hughdavenport`> yeh, i would like that
08:16:10 <dobedobedoh> I'm more thinking about live optimisation
08:16:25 <dobedobedoh> If we only optimise on core code, there's no benefit to third-party themes
08:16:36 <elky> we also need to fix the heck out of what we have, which as francois pointed out, is quite messy
08:16:55 <dobedobedoh> Perhaps we shoudl do this as part of the skins work and get anzeljg on board
08:17:10 <alanmc> dobedobedoh: do you have ref for that?
08:17:33 <hughdavenport`> what we could do, is run an optimizer over what we have, then stick to ONE style from here on out
08:17:35 <elky> #idea make it part of skins (dobedobedoh)
08:17:56 <anitsirk> but it also needs to fit into the workflow of designers as they often design on different projects but use the same syntax etc.
08:18:01 <dobedobedoh> cant' see a blueprint for skins
08:18:12 <anzeljg> there isn't
08:18:16 <dobedobedoh> In Moodle, all CSS can be passed through cssoptimiser at request time
08:18:16 <anitsirk> i don't think anzeljg has written one yet
08:18:18 <elky> #idea run an optimizer over what we have, then stick to ONE style from here on out (hugh)
08:18:41 <richardm> yeah ideally we'd find an easy fix for the editors Evonne, etc. use
08:18:47 <elky> dobedobedoh, do you mean like a minifier?
08:18:49 <dobedobedoh> So it doesn't matter what the style looks like in the file, as it's optimised and minimized as required
08:18:52 <alanmc> dobedobedoh: 2 different ideas surely.. one is developer tidyness the other is servers
08:18:52 <dobedobedoh> yes
08:18:57 <dobedobedoh> nope
08:19:01 <dobedobedoh> cssoptimiser is a minifier ;0
08:19:16 <elky> #info cssoptimiser is a minifier
08:19:21 <alanmc> yes .. but lint / tab-spacing is prettifying
08:19:24 <alanmc> for dev
08:19:44 <dobedobedoh> yes
08:19:47 <dobedobedoh> but I think we shoudl do both
08:19:57 <alanmc> +1
08:20:00 <dobedobedoh> IMHO, we should have full and expanded CSS (with spaces)
08:20:02 <dobedobedoh> and comments
08:20:15 <dobedobedoh> but shouldn't serve the full commented version to clients unless they're debugging
08:20:16 <elky> #info lint/ tab-spacing is for readability
08:20:45 <hughdavenport`> yeh, i would like both
08:20:58 <hughdavenport`> we already ship minified js for most third party stuff
08:21:04 <hughdavenport`> don't think we do it for core iirc
08:21:05 <anzeljg> dobedobedoh: so what you're saying is that the css styles would get minimised when requested from server?
08:21:09 <dobedobedoh> We shoudl also do the same for our JS
08:21:11 <dobedobedoh> yes
08:21:24 <elky> it'd certainly cut load for sites that don't have a caching layer
08:21:38 <dobedobedoh> they can be cached on the server of course
08:21:56 <anzeljg> BRB
08:22:16 <alanmc> dobedobedoh: implementation wise (in terms of say 1.6 Mahara release) is that optimisation packaged as sample web-server config, how would you do that (or is that a discussion for some other time)
08:22:19 <elky> people using shared hosting with silly bandwidth limits don't necessarily have the resource to do their own caching though
08:22:27 <richardm> would we need to introduce some kind of build process?
08:22:28 <dobedobedoh> it's done in php, not on the web server
08:22:35 <anitsirk> #info: minified JavaScript is already shipped for most third-party code
08:22:35 <alanmc> dobedobedoh: oh ok
08:23:10 <dobedobedoh> It's not a small task either - you've got to consider how to handle changes to CSS well
08:23:18 <dobedobedoh> Moodle for example has a cssrev
08:23:26 <dobedobedoh> btw, this is all new in moodle core
08:23:34 <anitsirk> you mean for 2.3?
08:23:37 <dobedobedoh> yeah
08:24:03 <dobedobedoh> but we can (and should) continue to share in this respect
08:24:07 <anitsirk> should we then wait and see how moodle fares?
08:24:15 <dobedobedoh> possibly wise ;)
08:24:23 <elky> #info moodle has cssoptimisation at request time, and a cssrev for changes
08:24:26 <dobedobedoh> it won't be enabled by default for a bit
08:24:42 <alanmc> sounds interesting ... dynamically parsing static content ;)
08:24:42 <dobedobedoh> they've had js optimisation for some time, and perhaps we should look at that too
08:24:45 <elky> #info new in moodle 2.3, wont be on by default for a while
08:25:17 <dobedobedoh> js optimisation has some good client performance benefits
08:26:03 <alanmc> js is not 100% static for sure
08:26:09 <rkabalin_> Among those products that do both CSS and JS minifying are #link http://code.google.com/p/minify/ and #link http://developer.yahoo.com/yui/compressor/
08:26:22 <anzeljg> I'm back
08:26:43 <elky> does the bot pick up inline #link?
08:26:53 <dobedobedoh> It should do yes
08:27:00 <elky> cool
08:27:26 <elky> Ok, Shall we put this down for next meeting too and let people mull it over for a bit?
08:27:43 <dobedobedoh> good plan ;)
08:28:27 <elky> #action will continue css discussion next meeting
08:28:46 <elky> #topic License compatibility (anzeljg)
08:28:52 <anzeljg> Have had some questions/concerns regarding using third party code licensed under different licences when creating new plugins for Mahara (and I wanted to use some already implemented solutions as a part of my plugins).
08:28:56 <anzeljg> Especially wanted to know if the Modified BSD or 3-clause BSD and MIT licences are compatible with GPL v3.
08:29:01 <anzeljg> Had the discussion with anitsirk some hours ago...
08:29:06 <anzeljg> Then elky kindly provided this resource:
08:29:10 <anzeljg> #link http://fedoraproject.org/wiki/Licensing:Main#Software_License_List
08:29:14 <anzeljg> and I think we should include it (or at least the link to it) somewhere on Mahara wiki - possibly Developer documentation, writing plugins?
08:29:15 <anzeljg> ..
08:29:18 <anitsirk> btw: meetbot mahara seems to be up again
08:29:32 <anitsirk> anzeljg: that sounds great.
08:30:03 <anitsirk> so the page elky pointed to said that the BSD (3-clause) license and MIT license are compatible with GPL v3 or later
08:30:22 <anzeljg> i understand it in that manner, yes
08:30:57 <anitsirk> anzeljg: then i guess the only thing is to make sure that you ship the third-party code with the original license in your plugin (you might have done that already for other things).
08:31:07 <anzeljg> yep
08:31:11 <anitsirk> :-)
08:31:45 <hughdavenport`> there is that link, and one on the gnu and fsf pages that show a list of licenses, basically most gpl-compatible are compatible with gpl3, except gpl2 iirc
08:31:56 <hughdavenport`> and that is what we care about
08:32:15 <elky> It's worth noting that francois is a bit of a licencing nerd and would probably check things over for compliance if we emailed and asked nicely
08:32:24 <anitsirk> there is the list on the freesoftware project, but it doesn't say explicity if it is compatible with GPL3
08:32:30 <anzeljg> as i said: it would be a good thing to have thoose links somwhere handy - on wiki...
08:32:46 <elky> #info the gnu and fsf pages show a list of licenses, basically most gpl-compatible are compatible with gpl3, except gpl2 iirc
08:32:56 <elky> #info ^ said hugh.
08:33:20 <anzeljg> asking francois nicely is a great idea...
08:34:14 <anitsirk> https://www.gnu.org/licenses/license-list.html#GPLCompatibleLicenses was the link that fmarier had pointed us once in a pizza talk at catalyst
08:34:43 <elky> is his talk up anywhere public?
08:34:49 <anitsirk> nope.
08:34:53 <anitsirk> just internal
08:35:03 <anitsirk> as far as i know
08:35:10 <hughdavenport`> flick him an email, i'm sure he wouldn't mind sharing it openly (if he hasn't already)
08:35:23 <hughdavenport`> and that is the link i was thinking of
08:35:33 <anzeljg> thankx
08:35:52 <elky> ok, we're on an hour now, so lets move on.
08:36:24 <anitsirk> elky: we missed a topic, but i guess it's because Tmirante is not here. is it?
08:36:37 <elky> anitsirk, yes i left it until now in case he showed up
08:36:54 <elky> #topic Tmirante had an item: Search 2.0 engine plugin possible time schedule request
08:37:12 <elky> does anyone know anything more about this?
08:37:28 <anitsirk> no.
08:37:36 <elky> #info tmirante isn't available, will leave on agenda for next meeting.
08:38:05 <elky> #topic Next meeting and Chair
08:38:34 <elky> #info One month from now is weds 20th
08:39:00 <anitsirk> i don't think that's good because it's mahoodlemoot FR
08:39:24 <anitsirk> so dajan and potentially others will be busy (note to self: gotta start preparing the presentation at some point)
08:39:45 <anitsirk> what about the week after?
08:39:58 <anitsirk> that's still a few days away from mahara uk12
08:40:11 <elky> #info 20th clashes with moodlemoot fr
08:40:19 <rkabalin_> week after is fine
08:40:45 <anitsirk> 27th works for me
08:40:55 <sonn1> fine for me too
08:40:55 <dobedobedoh> and me
08:41:24 <sonn1> richardm: are you ok?
08:41:27 <richardm> yep
08:41:37 <anitsirk> it would be morning for us in NZ
08:42:37 <anitsirk> would it be 20:00 UTC again (21:00 Brighton, 22:00 for anzeljg)?
08:42:46 <anitsirk> 8:00 for NZ
08:42:53 <alanmc> all go
08:42:56 <alanmc> od
08:42:56 <anzeljg> i think i will not be able to attend so don't mind me
08:43:19 <elky> #info Next meeting will be 27th june 2000 UTC
08:43:20 <lamiette> 21:00 for Brighton!
08:43:35 <anitsirk> is that too late, lamiette ?
08:43:50 <lamiette> hopefully not :)
08:44:01 <alanmc> no too early .. she'll still be selling seashells on the seashore
08:44:33 <hughdavenport`> \heh
08:44:37 <anitsirk> can you say that 20 times in fast, alanmc ?
08:44:59 <anitsirk> i'm fine with the proposal
08:45:00 <alanmc> my verbosity takes time I'm afraid
08:45:09 <elky> I say we put him to the test next zoodoo
08:45:24 <hughdavenport`> by say, do you mean irc say?
08:45:28 <hughdavenport`> because that is easy
08:45:30 <rkabalin_> test zoodoo? :D
08:45:32 <hughdavenport`> copy paste ftw
08:45:59 <anitsirk> rkabalin_: zoodoo is our annual christmas party at the wellington zoo
08:46:01 <alanmc> elky: at least you're not sending me to the lions
08:46:17 <anzeljg> tigers instead?
08:46:17 <elky> #topic Any Other Business?
08:46:29 <richardm> i have one
08:46:31 <anitsirk> ehm. there was only 1 or 2 oks for that time
08:46:35 <anitsirk> i have 2 topics
08:46:36 <rkabalin_> anitsirk: I know, there was an alternative meaning
08:46:43 <rkabalin_> wait
08:46:49 <rkabalin_> have we decided on chair
08:46:56 <elky> oh no, we haven't
08:46:57 <anitsirk> nope. elky, please #undo
08:47:01 <elky> #undo
08:47:01 <maharameet> Removing item from minutes: <MeetBot.items.Topic object at 0x2a0f150>
08:47:22 <rkabalin_> I can chair next meeting
08:47:28 <anitsirk> cool.
08:47:42 <elky> #info rkabalin_ to chair
08:48:09 <anitsirk> i guess now we can move on
08:48:24 <rkabalin_> if no one objects, yes
08:48:34 <anitsirk> who objects against a volunteer? :-D
08:48:40 <elky> #topic Any Other Business?
08:48:57 <richardm> yeah i just wanted to mention for those who don't know, i'll be leaving catalyst on 30 June
08:48:58 <rkabalin_> only more proactive another volunteer :)
08:49:19 <rkabalin_> oh no
08:49:24 <elky> #info richardm is leaving catalyst on june 30 :(
08:49:30 <anitsirk> yep
08:49:30 <anzeljg> :(
08:49:33 <sonn1> :((
08:49:34 <rkabalin_> do you go to Mozilla?
08:49:38 <elky> HA
08:49:58 <richardm> rkabalin_: no, i'm going to a little place called dragonfly, still in wellington
08:49:59 <elky> I've been waiting for someone to ask that
08:50:26 <rkabalin_> :D
08:50:40 <richardm> so it's just as well we have some more reviewers :)
08:50:44 <rkabalin_> good luck richardm :)
08:50:50 <richardm> thanks rkabalin_
08:51:13 <anitsirk> you'll be sorely missed, richardm
08:51:28 <dobedobedoh> Good luck Richard
08:51:36 <richardm> thanks!
08:51:38 <dobedobedoh> Sorry that you'll be leaving
08:51:39 <anzeljg> good luck! veliko sreče!
08:52:11 <sonn1> good luck! chuc may man (Vietnamese)
08:52:28 <richardm> thanks guys
08:52:45 <sonn1> is it far from Catalyst house?
08:52:46 <elky> He still has to show up for next meeting yet :P
08:53:03 <richardm> yeah, i can definitely make it to the next meeting
08:53:34 <richardm> it's just around the corner from catalyst, about 1-2 minutes walk actually
08:53:37 <anzeljg> richardm: who will take over your place/work?
08:54:00 <richardm> anzeljg: well i hope everyone will take on a little bit
08:54:12 <rkabalin_> what you will be doing in dragonfly apart of teaching dragons to fly?
08:54:29 <anzeljg> ok I thought of you as "man in charge", who will be that from now on?
08:54:51 <elky> anzeljg, that's still undecided
08:55:00 <anzeljg> oh, ok
08:55:03 <richardm> rkabalin_: it's partly data analysis, but still mostly web development
08:55:33 <rkabalin_> php?
08:55:40 <alanmc> richardm: whats the connection again - your uni supervisor or something works there?
08:56:10 <richardm> no i'll have to learn R, and the web stuff is python/django
08:56:20 <richardm> got a lot to learn!
08:56:33 <rkabalin_> that is really great!
08:56:34 * anzeljg loves python...
08:56:37 <alanmc> R is all good ..
08:57:00 <anitsirk> and it had won a NZ Open Source Award 2 years ago
08:57:01 <richardm> yeah, i'm looking forward to it actually
08:57:05 <elky> richardm, i think alanmc just volunteered to tutor you :P
08:57:42 <anitsirk> hi iarenaza
08:57:45 <anzeljg> hi
08:58:03 <elky> anyway, not to cut things short, but anitsirk you had some items?
08:58:07 <anitsirk> yep
08:58:12 <anitsirk> number 1: newsletter
08:58:32 <anitsirk> #info the next mahara newsletter will be published on 1 July 2012. please submit your stories to newsletter@mahara.org
08:58:53 <anitsirk> as usual ^ -- ^ don't wait until the last minute, but submit early. anything that you would like that deals with mahara.
08:59:16 <anitsirk> anzeljg: did you get permission from that guy to republish part of his text in the newsletter and then link to his article?
08:59:24 <anitsirk> it would be good to include that in the july newsletter
08:59:30 <anzeljg> no answer from him, sorry
08:59:43 <anitsirk> or we could make up a short text and link to the article. that would be fine, too
08:59:44 <anzeljg> I might write something if time permits...
08:59:58 <anitsirk> just 100-150 words, anzeljg. that's enough
09:00:05 <anzeljg> ok, will try
09:00:07 <anitsirk> oh iarenaza is clining himself.
09:00:15 <anitsirk> that would be great, anzeljg
09:00:25 <anitsirk> number 2: release schedule.
09:00:39 <anitsirk> elky: did you get the info onto the wiki already?
09:00:39 <elky> Oh, i knew i was forgetting something
09:01:02 <elky> No sorry :( I'll make a post to the developer forum first thing tomorrow
09:01:14 <elky> It will probably get a better audience there anyway
09:01:18 <anitsirk> #idea from the catalyst team: switch to a 6-monthly release cycle with releases in April and October
09:01:29 <dobedobedoh> +1
09:01:32 <dobedobedoh> very much +1
09:01:32 <richardm> +1
09:01:33 <anzeljg> +1
09:01:47 <elky> #action elky to write up a post for the developer forum
09:02:09 <rkabalin_> +1
09:02:09 <anzeljg> richardm: if i merge skins stuff (without live prveiw) till june, will you be able to review it before you leave?
09:02:13 <anitsirk> that allows users who want new features to get them faster and might avoid some backporting which might be troublesome and more difficult to upgrade
09:02:19 <sonn1> +1
09:03:08 <anitsirk> so that was basically it from me. you'll be able to see the schedule that elky came up with in the dev forum tomorrow.
09:03:37 <richardm> anzeljg: no, i have way too much to do already before i leave, you'll have to work on hughdavenport` elky alanmc rkabalin_ dobedobedoh lamiette sonn1
09:03:42 <anitsirk> #info: that release cycle proposal received positive nods from meeting attendees
09:03:52 <anzeljg> thanx for the info...
09:04:15 <elky> anzeljg, we'll sort something out :)
09:04:29 <anzeljg> :)
09:04:32 <hughdavenport`> +1 as well
09:04:34 <hughdavenport`> :P
09:04:47 <elky> Ok, nobody else has business?
09:05:22 <elky> going once?
09:05:29 <anzeljg> going twice?
09:05:38 <hughdavenport`> gone?
09:05:40 <elky> sold, to the man in green.
09:05:42 <richardm> alanmc had something about mobile tokens
09:06:11 <richardm> (or not)
09:06:13 <elky> alanmc, 'sup?
09:06:17 <alanmc> richardm: yeah I did .. but it was kindof a filler .. I'm keen to get as many dev's interested in the mobile API stuff
09:06:38 <elky> alanmc, perhaps a dev forum post from you too? :)
09:06:47 <anzeljg> bye guys, have another meeting to attend
09:06:49 <alanmc> elky: yes good idea
09:06:54 <anitsirk> bye, anzeljg
09:06:55 <elky> anzeljg, thanks for coming
09:07:05 <rkabalin_> bye anzeljg
09:07:16 <sonn1> bye anzeljg
09:07:22 <elky> #info Alanmc wants more interest in the mobile api stuff
09:07:37 <elky> #action alanmc to write forum post about mobile api stuff
09:07:38 <elky> :)
09:07:56 <elky> Ok, we sold for real now?
09:07:57 <alanmc> elky: I'm keen to find out from those hosting Mahara sites if the authentication mechanism is understood and OK
09:08:06 <alanmc> done
09:08:18 <elky> #info keen to find out from those hosting Mahara sites if the authentication mechanism is understood and OK
09:08:30 <richardm> alanmc: it's dodgy as
09:08:35 <elky> anitsirk, richardm, hughdavenport, sonn all done?
09:08:39 <richardm> yep
09:08:41 <anitsirk> yep
09:08:44 <sonn1> yes
09:09:03 <hughdavenport`> :D
09:09:08 <elky> #endmeeting