#mahara-dev Meeting

Meeting started by dobedobedoh at 20:02:47 UTC (full logs).

Meeting summary

    1. Andrew Nicols, Lancaster University, UK (dobedobedoh, 20:02:54)
    2. Francois Marier (fmarier, 20:03:02)
    3. anzeljg is Gregor Anzelj, translator and developer from Ljubljana, Slovenia (anzeljg, 20:03:09)
    4. Ruslan Kabalin, Lancaster University, UK (rkabalin_, 20:03:10)
    5. Richard Mansfield, Catalyst IT, Wellington (richardm, 20:03:13)
    6. Kristina Hoeppner, Catalyst IT, Wellington (anitsirk, 20:03:26)
    7. Hugh Davenport, Catalyst IT, Wellington (hughdavenport`, 20:03:33)
    8. Dominique-Alain JAN french translator - Lausanne Switzerland (dajan, 20:04:25)

  1. Items from last meeting (dobedobedoh, 20:04:39)
    1. The minutes from the last meeting are available at http://meetbot.mahara.org/mahara-dev/2012/mahara-dev.2012-03-27-07.41.html (dobedobedoh, 20:04:41)
    2. fmarier completed his two action items during the last meeting. Check the minutes of that meeting for details (dobedobedoh, 20:04:50)
    3. anzeljg has joined the slovenian team on launchpad so that we could make it the owner of the mahara translation (dobedobedoh, 20:04:59)
    4. CIA stays in #mahara-commits and has not made it to #mahara-dev (dobedobedoh, 20:06:55)

  2. Roadmap for Mahara 1.6 (dajan) (dobedobedoh, 20:08:02)
    1. The roadmap on the wiki is vastly out of date (dobedobedoh, 20:09:40)
    2. https://wiki.mahara.org/index.php/Roadmap (dobedobedoh, 20:09:54)
    3. iarenaza Iñaki Arenaza, Mondragon Unibertsitatea, Spain (iarenaza, 20:15:08)
    4. Specs in Development are on the wiki at https://wiki.mahara.org/index.php/Developer_Area/Specifications_in_Development (dobedobedoh, 20:15:59)
    5. blueprints for mahara started at https://blueprints.launchpad.net/mahara (anitsirk, 20:16:18)
    6. IDEA: Those who have made a suggestion which is on the blueprints page should add more detail to save elky doing all of the work (dobedobedoh, 20:17:45)
    7. AGREED: The Roadmap page should link to the blueprints page (dobedobedoh, 20:18:11)
    8. ACTION: anitsirk to update the roadmap (dobedobedoh, 20:19:05)

  3. Laurent Opprecht's "Notes" plugin (University of Geneva) as a way to improve the actual "Notes" block in Mahara (dajan) (dobedobedoh, 20:21:58)
    1. Luarent Opprecht (University of Geneva) has developed a Notes artefact for Mahara which separates content creation from display (dobedobedoh, 20:28:28)
    2. IDEA: Look at integrating missing features from Laurent's Note plugin into Mahara (dobedobedoh, 20:30:56)
    3. https://mahara.org/interaction/forum/topic.php?id=4352 is where we discussed it. (anitsirk, 20:31:02)
    4. ACTION: dajan to raise appropriate issues in the tracker (dobedobedoh, 20:34:16)

  4. Laurent Opprecht's "Extresource" plugin with OEmbed protocol to improve the way of embedding "things"in Mahara (dajan) (dobedobedoh, 20:34:35)
    1. https://blueprints.launchpad.net/mahara/+spec/external-media-oembed - blueprint already exists :-) (anitsirk, 20:35:43)
    2. Laurent to submit Extresource to core (dobedobedoh, 20:35:55)
    3. IDEA: It would be nice if some of the plugins being 'replaced' in this sense would provide upgrade paths if appropriate (dobedobedoh, 20:38:21)

  5. Repository Plugins (anzeljg) (dobedobedoh, 20:43:27)
    1. anzeljg has written a proof of concept for a repository system for mahara (dobedobedoh, 20:44:34)
    2. demo available at http://screencast.com/t/wxfDwcc3UHdk (dobedobedoh, 20:44:48)
    3. suggestions/ideas on how to finalise it would be appreciated (dobedobedoh, 20:45:15)
    4. ACTION: anzeljg To put together a quick wiki page with some information (possibly code too) (dobedobedoh, 20:58:46)

  6. Update on Skins work (anzeljg) (dobedobedoh, 21:00:07)
    1. anzeljg is adding 'life preview' support to skins to give users a preview of their changes (dobedobedoh, 21:02:04)
    2. screencast available at http://screencast.com/t/CWoznCHjJG (dobedobedoh, 21:02:19)

  7. Demo site (anitsirk) (dobedobedoh, 21:16:42)
    1. http://demo.mahara.org showcases mahara 1.5 now (anitsirk, 21:17:38)

  8. Upcoming Mahara Events: (dobedobedoh, 21:17:56)
    1. First Maharamoot francophone in Nîmes, May 20-22nd. Spread the word around you (dajan) (dobedobedoh, 21:17:58)
    2. MaharaUK 2012 3rd July 2012 in Lancaster (dobedobedoh) (dobedobedoh, 21:18:20)
    3. mahoodlemoot at Purchase College (NY) in July (dobedobedoh, 21:19:48)
    4. dajan will be one of our keynote speakers at maharauk2012 :) (dobedobedoh, 21:20:03)
    5. yesterday's MUG saw showcasing of student portfolios (dobedobedoh, 21:21:25)
    6. next MUG dates to be announced when available (dobedobedoh, 21:21:33)

  9. Next meeting and Chair (dobedobedoh, 21:22:05)
    1. http://moodlemoot2012.unimes.fr/ (dajan, 21:22:45)
    2. website for french maharamoot is http://moodlemoot2012.unimes.fr/ (dobedobedoh, 21:23:00)
    3. http://www.timeanddate.com/worldclock/fixedtime.html?msg=17th+Mahara+Developer+Meeting&iso=20120523T0730 (dobedobedoh, 21:27:55)
    4. elky to chair the next developer meeting at 07:30 UTC on 23rd May 2012 (dobedobedoh, 21:32:10)

  10. Any other business (dobedobedoh, 21:32:19)
    1. Mahara 1.5 is now out (dobedobedoh, 21:34:19)
    2. Mahara has a security bug bounty program https://wiki.mahara.org/index.php/Security#Mahara_Security_Bug_Bounty_Program (anitsirk, 21:35:47)
    3. Thanks to Richard Wyles for putting up security bounties (dobedobedoh, 21:38:25)


Meeting ended at 21:39:06 UTC (full logs).

Action items

  1. anitsirk to update the roadmap
  2. dajan to raise appropriate issues in the tracker
  3. anzeljg To put together a quick wiki page with some information (possibly code too)


Action items, by person

  1. anitsirk
    1. anitsirk to update the roadmap
  2. anzeljg
    1. anzeljg To put together a quick wiki page with some information (possibly code too)
  3. dajan
    1. dajan to raise appropriate issues in the tracker


People present (lines said)

  1. dobedobedoh (154)
  2. anitsirk (68)
  3. anzeljg (59)
  4. dajan (56)
  5. richardm (17)
  6. iarenaza (14)
  7. _anzeljg_ (13)
  8. fmarier (12)
  9. rkabalin_ (7)
  10. hughdavenport` (5)
  11. maharameet (4)
  12. elky (4)
  13. lamiette (1)


Generated by MeetBot 0.1.4.