#mahara-dev Meeting

Meeting started by fmarier_ at 19:40:32 UTC (full logs).

Meeting summary

  1. Meeting attendees (fmarier_, 19:40:48)
    1. fmarier_ is Francois Marier (fmarier_, 19:40:54)
    2. anitsirk: Kristina Hoeppner, Catalyst IT, New Zealand (anitsirk, 19:40:59)
    3. rkabalin: Ruslan Kabalin, LUNS Ltd. (rkabalin, 19:41:15)
    4. richardm Richard Mansfield (richardm, 19:41:51)

  2. Meeting etiquette (fmarier_, 19:42:35)
    1. typing .. indicates that you are finished with your input (fmarier_, 19:44:33)

  3. Items from previous meetings (fmarier_, 19:45:11)
    1. rkabalin_ file a wishlist bug on the tracker with objectionable content report items (fmarier_, 19:45:41)
    2. ACTION: rkabalin to fill in more details about improving objectionable content (fmarier_, 19:51:35)
    3. https://bugs.launchpad.net/mahara/+bug/767569 (fmarier_, 19:51:39)
    4. anitsirk proceed with asciidoc trial and come up with more info (fmarier_, 19:51:52)
    5. http://wiki.mahara.org/Developer_Area/Current_Tasks (fmarier_, 19:53:03)
    6. fmarier email wiki contributors to start the relicensing process (fmarier_, 19:54:50)
    7. http://popey.com/blog/2011/03/08/ubuntu-wiki-relicensing-request-for-comments/ (fmarier_, 19:57:31)
    8. ACTION: fmarier_ to ping wiki contributors one last time and then make the license change (fmarier_, 19:58:19)

  4. Update on 1.4 [Francois] (fmarier_, 19:59:28)
    1. release is now scheduled for early May (fmarier_, 20:04:04)
    2. bugs targetted for 1.4 will be triaged again to bring the list down if possible (fmarier_, 20:04:30)
    3. everyone should fix their pet bugs soon :) (fmarier_, 20:04:46)

  5. Gerrit discussion [Francois] (fmarier_, 20:08:05)
    1. how koha handles big features with gerrit: http://bugs.koha-community.org/bugzilla3/showdependencytree.cgi?id=5575&hide_resolved=0 (anitsirk, 20:14:51)
    2. if you want to merge a big feature, break it down into lots of smaller ones (maybe dependencies first, etc.) (fmarier_, 20:17:05)
    3. When pushing patches that are related, use a Gerrit tag (fmarier_, 20:17:39)
    4. every new patch should be applied on top of the clean checked-out branch to avoid adding dependencies in error (rkabalin, 20:18:50)
    5. when reviewing a series of related patches, keep in mind that the patches after the first rejected one will need to be reviewed again (fmarier_, 20:21:12)
    6. anybody can submit new change requests (fmarier_, 20:34:21)
    7. anybody can do a code review (-1 to +1) (fmarier_, 20:34:36)
    8. only reviewers and testers can mark code as verified (-1 to +1) (fmarier_, 20:34:57)
    9. only reviewers can do a full code review (-2 to +2) and submit patches for merge (fmarier_, 20:35:23)
    10. old committers are now reviewers (fmarier_, 20:36:01)
    11. nobody is a tester yet (fmarier_, 20:36:08)
    12. once jenkins is running, it will act as a tester giving patches a -1 or a +1 (Verified) when tests pass/fail (fmarier_, 20:36:43)
    13. "Verified" v. "Code review" (verify +1 your own changes, but don't +2 them) (fmarier_, 20:42:33)
    14. if you want someone to test your code, leave it as "verified: 0" and ask for someone to test it (fmarier_, 20:42:58)
    15. as a reviewer, if you see something that looks weird or dodgy, it's your responsibility to test it (fmarier_, 20:43:17)
    16. Leave associated bugs as "in progress" until commited by Gerrit (fmarier_, 20:45:37)
    17. ACTION: fmarier_ to investigate whether gerrit could have a hook that would add a note to launchpad (with a link to the gerrit changeset) for patchsets that got merged and mentioned a bug number (fmarier_, 20:49:59)
    18. ACTION: fmarier_ investigate hook to send an email to patchset submitter once it's been merged (to remind them to update bug status in tracker) (fmarier_, 20:51:50)
    19. ACTION: fmarier write code review guidelines on the wiki (fmarier_, 20:54:44)

  6. Items from previous meetings - Episode 2 (fmarier_, 20:55:54)
    1. iarenaza: IƱaki Arenaza, Mondragon Unibertsiatea (iarenaza, 20:55:57)
    2. rangi to ask the evergreen guys if they have a test suite for their asciidoc manual (fmarier_, 20:56:08)
    3. http://www.methods.co.nz/asciidoc/testasciidoc.html (rangi, 20:59:09)
    4. evergreen run testasciidoc over their documentation: http://www.methods.co.nz/asciidoc/testasciidoc.html (fmarier_, 20:59:32)
    5. iarenaza further look at Live@edu accounts (fmarier_, 21:01:22)

  7. lang.mahara.org and AMOS roadmap and funding? [iarenaza] (fmarier_, 21:03:50)
    1. iarenaza has some funding to adapt AMOS (moodle 2.0 translation tool) for Mahara but wouldn't be able to cover the whole thing (fmarier_, 21:11:25)
    2. richardm has implemented a .po file importer/exporter to provide an additional way of translating mahara (fmarier_, 21:12:03)
    3. AMOS: http://docs.moodle.org/en/AMOS (fmarier_, 21:13:49)
    4. Moodle 2.0 translation portal: http://lang.moodle.org (fmarier_, 21:14:06)
    5. having to use git is putting people off from translating Mahara (fmarier_, 21:18:26)
    6. AGREED: first have a look at launchpad translation tool and discuss whether or not to try to find funding to port AMOS (fmarier_, 21:21:44)

  8. Next meeting (fmarier_, 21:23:03)
    1. http://www.timeanddate.com/worldclock/fixedtime.html?iso=20110525T0730 (fmarier_, 21:25:40)
    2. AGREED: Next meeting: 25 May at 7:30 UTC (fmarier_, 21:27:40)
    3. http://www.timeanddate.com/worldclock/fixedtime.html?iso=20110525T0730 (fmarier_, 21:27:48)

  9. Any other business (fmarier_, 21:28:01)


Meeting ended at 21:29:23 UTC (full logs).

Action items

  1. rkabalin to fill in more details about improving objectionable content
  2. fmarier_ to ping wiki contributors one last time and then make the license change
  3. fmarier_ to investigate whether gerrit could have a hook that would add a note to launchpad (with a link to the gerrit changeset) for patchsets that got merged and mentioned a bug number
  4. fmarier_ investigate hook to send an email to patchset submitter once it's been merged (to remind them to update bug status in tracker)
  5. fmarier write code review guidelines on the wiki


Action items, by person

  1. fmarier_
    1. fmarier_ to ping wiki contributors one last time and then make the license change
    2. fmarier_ to investigate whether gerrit could have a hook that would add a note to launchpad (with a link to the gerrit changeset) for patchsets that got merged and mentioned a bug number
    3. fmarier_ investigate hook to send an email to patchset submitter once it's been merged (to remind them to update bug status in tracker)
  2. rkabalin
    1. rkabalin to fill in more details about improving objectionable content


People present (lines said)

  1. fmarier_ (220)
  2. rkabalin (58)
  3. iarenaza (37)
  4. richardm (35)
  5. anitsirk (25)
  6. rangi (16)
  7. maharameet (2)


Generated by MeetBot 0.1.4.