#mahara-dev Meeting

Meeting started by rkabalin_ at 07:31:17 UTC (full logs).

Meeting summary

  1. Meeting attendees. (rkabalin_, 07:31:29)
    1. anitsirk: Kristina Hoeppner from Catalyst IT, Wellington, NZ (anitsirk, 07:31:53)
    2. Andrew Nicols, LUNS Ltd, UK (dobedobedoh, 07:32:01)
    3. Stacey Walker Catalyst IT Europe (lamiette, 07:32:15)
    4. rkabalin_ Ruslan Kabalin from LUNS Ltd., Lancaster, UK (rkabalin_, 07:32:22)
    5. anzeljg: Gregor Anzelj, Slovenian langpack maintainer, plugin developer (anzeljg, 07:32:26)
    6. David Drummond from Catalyst (aguri, 07:32:43)
    7. richardm: Richard Mansfield from Catalyst (richardm, 07:32:53)
    8. fmarier Francois Marier (fmarier, 07:33:39)

  2. Items from previous meetings (rkabalin_, 07:34:25)
    1. dobedobedoh to check the ubuntu code of conduct which is CC licensed for the mahara code of conduct (rkabalin_, 07:34:47)
    2. ACTION: dobedobedoh to check the ubuntu code of conduct (rkabalin_, 07:36:46)
    3. dobedobedoh and azeljg to go over skins patches to try and get them into 1.4, richardm will also take a look at them (rkabalin_, 07:37:03)
    4. ACTION: anzeljg try to rebase his skins patches with current mahara master (rkabalin_, 07:38:33)
    5. the new url of anzeljg's test server is http://mahara.ledina.org/DEV/ login and pwd stayed the same (anitsirk, 07:39:42)
    6. there you can test the skins (anitsirk, 07:39:59)
    7. ACTION: richardm dobedobedoh Go through azeljg's skins patches to try and get them into 1.4 (rkabalin_, 07:43:21)
    8. iarenaza to draft language pack release policy (rkabalin_, 07:43:37)
    9. http://wiki.mahara.org/Language_Packs/Language_Pack_Release_Policy (anitsirk, 07:44:01)
    10. Graphs in Mahara Statistics proposal (anzeljg) (rkabalin_, 07:44:27)
    11. iarenaza also writes: H31nz was in touch with me and provided some valuable feedback that (anitsirk, 07:44:33)
    12. rkabalin to summarize his ideas of notifications of objectionable content on a subpage (rkabalin_, 07:50:55)
    13. perhaps what we want is a way for a group admin to ban a user from joining the group (rkabalin_, 07:58:17)
    14. AGREED: (rkabalin_, 07:58:30)
    15. ACTION: rkabalin_ file a wishlist bug on the tracker with objectionable content report items (rkabalin_, 08:01:29)
    16. richardm checks if objectionable content notifications already go to institution admins besides site admins (rkabalin_, 08:01:43)
    17. anzeljg to further look into flickr and picasa photo block (rkabalin_, 08:05:04)
    18. ACTION: anzeljg send an e-mail with details on flickr and picasa photo block (rkabalin_, 08:07:31)
    19. iarenaza to provide anzeljg with google apps for education account(s) for further testing of the google apps plugin (rkabalin_, 08:08:00)
    20. iarenaza to provide anzeljg with google apps for education account(s) for further testing of the google apps plugin (rkabalin_, 08:12:15)
    21. from iarenaza: I have the Google Apps domain up and running already (so I can provide accounts as needed), but haven't looked anything about Live@edu yet (terms and conditions, technical requirements, etc.). I hope I'll have a bit of free time at the end of next week to have a look at it. (anitsirk, 08:12:20)
    22. ACTION: iarenaza further look at Live@edu accounts (rkabalin_, 08:15:01)
    23. richardm to add a list of plugins-in-use for the weekly stats push (rkabalin_, 08:15:53)
    24. fmarier is going to try to get in touch with Mjollnir` and get the unit test work she did merge into master (rkabalin_, 08:23:05)
    25. tasks / action items that we want to keep track of, but can't address until the next developer meeting are tracked at http://wiki.mahara.org/Developer_Area/Current_Tasks (anitsirk, 08:26:23)
    26. AGREED: (rkabalin_, 08:26:47)
    27. phpunit code is pushed here http://gitorious.org/mahara/mahara-shared/commits/phpunit-old (rkabalin_, 08:27:33)

  3. lang.mahara.org and AMOS roadmap and funding? [iarenaza] (rkabalin_, 08:32:00)
    1. ACTION: rkabalin_ move lang.mahara.org agenda item to the next meeting as iarenaza is not present (rkabalin_, 08:34:13)

  4. Forum post editing (bug #731990) [Francois] (rkabalin_, 08:34:32)
    1. having a message after the submission of the forum post saying "You have 30 min (rkabalin_, 08:38:47)

  5. Status on code reviews [Francois] (rkabalin_, 08:45:39)
    1. https://reviews.mahara.org/ (fmarier, 08:45:59)
    2. Mahara code review #link https://reviews.mahara.org/ (rkabalin_, 08:48:03)
    3. basically, we will be making this repo read-only: http://gitorious.org/mahara/mahara only the gerrit user will be pushing to it developers will instead be pushing their code to a separate gerrit repo and they'll get pushed to the real repo by gerrit once they have been reviewed (rkabalin_, 08:50:25)
    4. http://gitorious.org/mahara/mahara-shared to be used for devs collaboration (rkabalin_, 08:51:37)
    5. gerrit account instructions: http://wiki.mahara.org/Developer_Area/Git_Repository_Policy (rkabalin_, 08:53:32)
    6. https://reviews.mahara.org/1 (fmarier, 08:54:35)
    7. IDEA: the idea is to improve the mahara documentation. (anitsirk, 08:54:52)
    8. currently, the documentation sits in the wiki and is not really updated. most information is very old and often only applicable for 1.2. craig made an effort to put 1.3 things into the user guide. however, i think the current system of doing documentation does not work very well and some re-thinking is necessary. (anitsirk, 08:54:53)
    9. the way koha manages their documentation is interesting: have everything in git, use an xml editor and docbook to produce the documentation which has the output format html but can also be printed easily as pdf manual. (anitsirk, 08:54:53)
    10. http://www.methods.co.nz/asciidoc/ (anitsirk, 08:56:14)
    11. http://www.stack.nl/~dimitri/doxygen/ (anitsirk, 08:56:15)
    12. : does anyone of you have any suggestions for a tool combination because you have already worked with one or like one in particular? so far, i have not made any changes and am still in the investigation phase, but lean towards trying out asciidoc. (anitsirk, 08:56:15)
    13. http://git.koha-community.org/gitweb/?p=kohadocs.git;a=tree (rangi, 09:02:59)
    14. ACTION: anitsirk proceed with asciidoc trial and come up with more info (rkabalin_, 09:04:03)
    15. repo for mahara manual http://gitorious.org/mahara/manual (rkabalin_, 09:05:03)

  6. Proposing to license the Mahara wiki content under CC BY-SA 3.0 Unported [Francois] (rkabalin_, 09:05:52)
    1. ACTION: rangi to ask the evergreen guys if they have a test suite for their asciidoc manual (anitsirk, 09:09:04)
    2. AGREED: (rkabalin_, 09:12:53)
    3. ACTION: fmarier email 38 people to ask lisence permissions (rkabalin_, 09:17:00)

  7. Removal of httpswwwroot (bug 646713) [Francois] (rkabalin_, 09:17:32)
    1. httpswwwroot removal discussion: http://wiki.mahara.org/Release_Notes/1.4.0/Removal_of_httpswwwroot (rkabalin_, 09:29:50)

  8. Leap2A evaluation benchmark research [Kristina] (rkabalin_, 09:33:22)
    1. I was asked to participate in an interview for the VET E-portfolios Leap2A Specification Evaluation Research performed by the Australian Flexible Learning Framework (anitsirk, 09:33:25)
    2. AGREED: (rkabalin_, 09:48:23)

  9. Chair Duties wiki page [Francois] (rkabalin_, 09:49:58)
    1. ACTION: past chairs to fill in http://wiki.mahara.org/Developer_Area/Developer_Meetings/Chair_Duties (rkabalin_, 09:52:19)
    2. more info here http://meetbot.debian.net/Manual.html (rkabalin_, 09:53:29)
    3. fmarier volunteered to chair april 2011 dev meeting (anitsirk, 09:54:38)

  10. Next meeting (rkabalin_, 09:55:16)
    1. AGREED: next meeting april 20 at 7:30 p.m. GMT / april 21 at 7:30 a.m. NZ (rkabalin_, 10:01:58)
    2. ACTION: rkabalin_ create next meeting item on wiki (rkabalin_, 10:02:18)

  11. Any other business (rkabalin_, 10:02:53)
    1. IDEA: produce a quarterly online mahara newsletter that highlights achievements during that period, sites that use mahara in an exemplary way, tips for mahara, new sites that use mahara, current developments / finished developments of features etc., recent presentations -> any stories are welcome; can be in form of blog post so that the newsletter would link to them; not that they are all written by the newsletter editor ;-) (anitsirk, 10:02:58)
    2. projected first issue to be out around april 1 (anitsirk, 10:02:58)
    3. AGREED: we should produce quarterly online mahara newsletter in a form of blog (rkabalin_, 10:09:11)


Meeting ended at 10:11:58 UTC (full logs).

Action items

  1. dobedobedoh to check the ubuntu code of conduct
  2. anzeljg try to rebase his skins patches with current mahara master
  3. richardm dobedobedoh Go through azeljg's skins patches to try and get them into 1.4
  4. rkabalin_ file a wishlist bug on the tracker with objectionable content report items
  5. anzeljg send an e-mail with details on flickr and picasa photo block
  6. iarenaza further look at Live@edu accounts
  7. rkabalin_ move lang.mahara.org agenda item to the next meeting as iarenaza is not present
  8. anitsirk proceed with asciidoc trial and come up with more info
  9. rangi to ask the evergreen guys if they have a test suite for their asciidoc manual
  10. fmarier email 38 people to ask lisence permissions
  11. past chairs to fill in http://wiki.mahara.org/Developer_Area/Developer_Meetings/Chair_Duties
  12. rkabalin_ create next meeting item on wiki


Action items, by person

  1. anitsirk
    1. anitsirk proceed with asciidoc trial and come up with more info
  2. anzeljg
    1. anzeljg try to rebase his skins patches with current mahara master
    2. anzeljg send an e-mail with details on flickr and picasa photo block
  3. dobedobedoh
    1. dobedobedoh to check the ubuntu code of conduct
    2. richardm dobedobedoh Go through azeljg's skins patches to try and get them into 1.4
  4. fmarier
    1. fmarier email 38 people to ask lisence permissions
  5. rangi
    1. rangi to ask the evergreen guys if they have a test suite for their asciidoc manual
  6. richardm
    1. richardm dobedobedoh Go through azeljg's skins patches to try and get them into 1.4
  7. rkabalin_
    1. rkabalin_ file a wishlist bug on the tracker with objectionable content report items
    2. rkabalin_ move lang.mahara.org agenda item to the next meeting as iarenaza is not present
    3. rkabalin_ create next meeting item on wiki
  8. UNASSIGNED
    1. iarenaza further look at Live@edu accounts
    2. past chairs to fill in http://wiki.mahara.org/Developer_Area/Developer_Meetings/Chair_Duties


People present (lines said)

  1. rkabalin_ (149)
  2. anitsirk (146)
  3. fmarier (145)
  4. dobedobedoh (60)
  5. anzeljg (30)
  6. richardm (26)
  7. Mjollnir` (14)
  8. rangi (7)
  9. maharameet (5)
  10. lamiette (2)
  11. aguri (1)


Generated by MeetBot 0.1.4.