#mahara-dev Meeting

Meeting started by anitsirk at 07:34:31 UTC (full logs).

Meeting summary

    1. anitsirk is Kristina Hoeppner, Catalyst in Wellington, New Zealand (anitsirk, 07:34:34)
    2. robertl_ is Robert Lyon, Catalyst in Wellington, New Zealand (robertl_, 07:34:45)
    3. anzeljg is Gregor Anželj, developer and translator, Ljubljana, Slovenia (anzeljg, 07:34:47)
    4. yuliya is Yuliya Bozhko from Totara Learning Solutions (Wellington, New Zealand) (yuliyabozhko, 07:35:11)
    5. aarowlaptop is Aaron Wells, from Catalyst IT in Wgtn NZ (aarowlaptop, 07:35:12)

  1. Topics from previous meeting (anitsirk, 07:35:20)
    1. aarowlaptop to update the wiki and readme file to reflect the addition of the two mobile browsers in the supported software. (It was agreed to start smoke-testing Mahara on mobile devices in the latest Safari (iOS) and Android Chrome [Android] browsers.) (anitsirk, 07:35:21)
    2. ACTION: aarowlaptop to update the wiki and readme file to reflect the addition of the two mobile browsers in the supported software. (It was agreed to start smoke-testing Mahara on mobile devices in the latest Safari (iOS) and Android Chrome [Android] browsers.) (anitsirk, 07:36:58)
    3. aarowlaptop to ask the front-end devs to write up instructions for building a theme under windows (anitsirk, 07:37:12)
    4. ACTION: anitsirk to ask the front-end devs to write up instructions for building a theme under windows (anitsirk, 07:38:24)
    5. aarowlaptop to collate information on use of Postgres 8.3 in LTS of the top 5-7 operating systems to determine whether support can be dropped or not. also take a look at Mahara rego data to see if those using Postgres 8.3 are on unsupported Mahara versions. (anitsirk, 07:38:39)
    6. https://docs.google.com/spreadsheets/d/1LIoLFuWBOtjdVIPSRuFnFdKirr2RpIl7oTarYxlhzgY/edit?usp=sharing (anitsirk, 07:39:34)
    7. https://docs.google.com/spreadsheets/d/1MTQmnDczefBzRzGWIYtWotEeIJTavEMegNkeHqGhgvE/edit?usp=sharing (aarowlaptop, 07:42:23)
    8. https://bugs.launchpad.net/mahara/+bug/1517658 (aarowlaptop, 07:49:24)
    9. https://bugs.launchpad.net/mahara/+bug/1517658/comments/14 (aarowlaptop, 07:49:40)
    10. http://www.postgresql.org/support/versioning/ (anitsirk, 07:52:52)
    11. aarowlaptop thinks there isn't much harm in us supporting older DB versions. (anitsirk, 07:54:14)
    12. RHEL has a service called "Red Hat Software Collections", which adds Postgres 9.2 and thus a more modern version of postgres can be used on RHEL if there are issues with an older one that we don't support anymore (anitsirk, 07:54:54)
    13. as robertl said, we tend not to use the extended functionality of the databases anyway, in order to maintain compatibility across postgres & mysql (anitsirk, 07:55:41)
    14. AGREED: Lowest supported PostgreSQL version will be 9.1 starting in Mahara 16.04. (anitsirk, 08:00:29)
    15. Kristin to check with Jen and Julius and also go through the demos [of HTML5 player possibilities] and ask Brian that we can also get a UX person to go through. (anitsirk, 08:00:49)
    16. VideoJS is the replacement for Flowplayer to provide an HTML5 media player. (anitsirk, 08:01:29)
    17. son started on the implementation and put up two patches for review. https://reviews.mahara.org/5988 and the child patch linked off it. (anitsirk, 08:01:53)
    18. the html5 player is pegged for the 16.04 release. (anitsirk, 08:02:52)
    19. VideoJS requires a still image for audio files. A simple icon image can be used. (anitsirk, 08:07:14)
    20. Kristina to check with patk about the character set for Raw. (anitsirk, 08:08:15)
    21. actually, anzeljg has investigated this and came up with a solution: https://reviews.mahara.org/5977 - The custom fonts that don't display necessary characters now have them. (anitsirk, 08:08:15)
    22. mingard is Jono Mingard from Powershop, Wellington, New Zealand (mingard, 08:17:12)

  2. Support for Internet Explorer 9 and 10 (End of life support: 12 January 2016) - Kristina (anitsirk, 08:17:12)
    1. Microsoft ended the support for Internet Explorer lower than version 11 on 12 January 2016. (anitsirk, 08:17:13)
    2. https://www.microsoft.com/en-us/WindowsForBusiness/End-of-IE-support (anitsirk, 08:17:13)
    3. IDEA: We should drop official support for non-supported versions as well. Our general support info could also include: Latest 3 versions of browsers XYZ or that are still supported, whichever is the most recent (not quite sure about that wording yet). Mahara may still work on unsupported / older browsers, but you may not be able to use all functionality as designed. (anitsirk, 08:17:13)
    4. IDEA: anitsirk: think dropping official support for IE9 and 10 for 15.04 and 15.10 would be good. mahara doesn't suddenly stop working for those as they were designed to work with these browsers, but we wouldn't necessarily have to worry about issues esp. since microsoft doesn't support those browsers. we should not encourage people to stay on unsupported browser versions. (anitsirk, 08:28:17)
    5. AGREED: change the wording for 15.04 and 15.10 that mahara will work with IE9 and 10 (Mahara 15.04) and IE10 (Mahara 15.10) browser versions but we recommend to use a supported version or different browser (anitsirk, 08:36:00)
    6. ACTION: anitsirk to update the readme for 15.04 and 15.10 and master (anitsirk, 08:36:21)
    7. AGREED: Change wording for Mahara 16.04 that only Microsoft supported browsers are supported to a maximum of the three most recent ones. in this case right now it would be IE 11 and 12. (anitsirk, 08:36:59)

  3. Password policy (currently 3-30 characters long) - Kristina (anitsirk, 08:37:16)
    1. you can set a password that is only 3 characters long on your account settings page. When you set up your first password though you are already asked for a longer one. (anitsirk, 08:37:17)
    2. IDEA: We should make the minimum length consistent (I think right now it is 6 characters) and not limit the length of the password. 30 characters may not be enough anymore when people are encouraged to choose phrases rather than short passwords. (anitsirk, 08:37:17)
    3. AGREED: lift the password length limit for internal account passwords. (anitsirk, 08:41:27)
    4. ACTION: anitsirk to create a bug report for the password length (anitsirk, 08:41:50)

  4. Mochikit replacement - Kristina (anitsirk, 08:42:55)
    1. mingard started on the Mochikit replacement (anitsirk, 08:42:56)
    2. https://reviews.mahara.org/#/q/owner:reason.koan%2540gmail.com+status:open (anitsirk, 08:42:56)
    3. IDEA: There are basically two approaches: 1) Replace Mochikit with equivalent modern JS but not change the structure of PHP. 2) Remove Mochikit and all JS from the PHP files. Approach 2 takes longer and wouldn't be possible to do for Mahara 16.04. Approach 1 might still be doable for 16.04. (anitsirk, 08:42:56)
    4. we currently have both MochiKit and jQuery javascript libraries, which both do similar things. MochiKit hasn't been updated in ages so we should be removing it. a secondary problem is that Mahara's JS generally is quite hard to understand and debug because a lot is embedded in PHP, and there are a lot of different conventions used throughout the project (anitsirk, 08:49:10)
    5. removing MochiKit isn't as big as it sounds because most functions have direct jQuery equivalents (it's just going through and replacing the ~1600 instances of MochiKit functions being used, then checking nothing breaks). however, mingard discovered a lot of places where large chunks of functionality is duplicated, so it might make more sense to turn common functionality into jQuery plugins at the same time as removing MochiKit, which would be a (anitsirk, 08:49:38)
    6. TL;DR removing MochiKit is mostly straightforward, but it wouldn't make Mahara's JS significantly better or easier to understand (anitsirk, 08:49:58)
    7. IDEA: make plugins (anitsirk, 08:50:06)
    8. we will tackle the mochikit replacement for Mahara 16.10 and try to do it all in one go (separate JS from PHP) and not only convert Mochikit into jQuery. (anitsirk, 08:55:41)
    9. ACTION: mingard will work on finding and documenting duplicated sections, and maybe do a bit of a proposal on how we should restructure the scripts generally (anitsirk, 08:56:45)

  5. Sign the Contributor Covenant? - Kristina (anitsirk, 08:57:18)
    1. http://contributor-covenant.org/ (anitsirk, 08:57:19)
    2. IDEA: Chris Cormack pointed me to this document and I wanted to see if there was any interest in looking into it further. (anitsirk, 08:57:19)
    3. ACTION: anitsirk to start a discussion on mahara.org on whether to adopt the Contributor Covenant. (anitsirk, 09:05:32)

  6. Persona shutdown (Launchpad Bug #1533377) (anitsirk, 09:06:00)
    1. https://bugs.launchpad.net/mahara/+bug/1533377 (anitsirk, 09:06:00)
    2. Mozilla is shutting down Persona at the end of November 2016 (anitsirk, 09:06:26)
    3. https://wiki.mozilla.org/Identity/Persona_Shutdown_Guidelines_for_Reliers (robertl_, 09:08:25)
    4. IDEA: wait for a couple of months to see what steps other Persona users take (anitsirk, 09:08:34)
    5. we'll revisit what to move to in a few months when more information is available and some other projects also had time to think about a migration path. (anitsirk, 09:17:10)
    6. IDEA: disable persona auth by default on new mahara installations (anitsirk, 09:17:41)
    7. IDEA: show warning to admin when wanting to activate persona on a new mahara. (anitsirk, 09:19:07)
    8. ACTION: anitsirk to set up new bug report for disabling persona auth per default for 16.04 and add warning when about to enable it. (anitsirk, 09:20:40)
    9. IDEA: add to report that if no institution uses persona on an upgraded site, disable the plugin (anitsirk, 09:22:51)

  7. Next meeting and chair (anitsirk, 09:23:29)
    1. the 51st Mahara developer meeting will take place on 10 March 2016 at 8:00 UTC. anzeljg is the chair for that meeting with anitsirk as backup. (anitsirk, 09:35:55)
    2. http://www.timeanddate.com/worldclock/fixedtime.html?iso=20160310T08 (anitsirk, 09:35:56)

  8. Any other business (anitsirk, 09:36:09)
    1. Integrate embed.ly into the "external media" and troubles moving blocks possibly related to blockmoveBlock function and the javascript... (anitsirk, 09:36:58)
    2. https://reviews.mahara.org/#/c/5749/ (anzeljg, 09:37:00)
    3. ACTION: aarowlaptop to look at solution for moving blocks properly for https://reviews.mahara.org/#/c/5749/ (anitsirk, 09:38:31)
    4. feature freeze for Mahara 16.04 is at the end of next week. we are getting closer to April already! (anitsirk, 09:39:22)


Meeting ended at 09:40:14 UTC (full logs).

Action items

  1. aarowlaptop to update the wiki and readme file to reflect the addition of the two mobile browsers in the supported software. (It was agreed to start smoke-testing Mahara on mobile devices in the latest Safari (iOS) and Android Chrome [Android] browsers.)
  2. anitsirk to ask the front-end devs to write up instructions for building a theme under windows
  3. anitsirk to update the readme for 15.04 and 15.10 and master
  4. anitsirk to create a bug report for the password length
  5. mingard will work on finding and documenting duplicated sections, and maybe do a bit of a proposal on how we should restructure the scripts generally
  6. anitsirk to start a discussion on mahara.org on whether to adopt the Contributor Covenant.
  7. anitsirk to set up new bug report for disabling persona auth per default for 16.04 and add warning when about to enable it.
  8. aarowlaptop to look at solution for moving blocks properly for https://reviews.mahara.org/#/c/5749/


Action items, by person

  1. aarowlaptop
    1. aarowlaptop to update the wiki and readme file to reflect the addition of the two mobile browsers in the supported software. (It was agreed to start smoke-testing Mahara on mobile devices in the latest Safari (iOS) and Android Chrome [Android] browsers.)
    2. aarowlaptop to look at solution for moving blocks properly for https://reviews.mahara.org/#/c/5749/
  2. anitsirk
    1. anitsirk to ask the front-end devs to write up instructions for building a theme under windows
    2. anitsirk to update the readme for 15.04 and 15.10 and master
    3. anitsirk to create a bug report for the password length
    4. anitsirk to start a discussion on mahara.org on whether to adopt the Contributor Covenant.
    5. anitsirk to set up new bug report for disabling persona auth per default for 16.04 and add warning when about to enable it.
  3. mingard
    1. mingard will work on finding and documenting duplicated sections, and maybe do a bit of a proposal on how we should restructure the scripts generally


People present (lines said)

  1. anitsirk (208)
  2. aarowlaptop (103)
  3. yuliyabozhko (57)
  4. mingard (55)
  5. robertl_ (37)
  6. anzeljg (29)
  7. Gregor_ (4)
  8. maharameet (2)


Generated by MeetBot 0.1.4.