08:03:58 <anitsirk> #startmeeting
08:03:58 <maharameet> Meeting started Wed Aug 26 08:03:58 2015 UTC.  The chair is anitsirk. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:03:58 <maharameet> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:04:03 <anitsirk> Hello and welcome to the 46th Mahara developer meeting.
08:04:03 <anitsirk> Please introduce yourself using "#info" at the start so that this can be recorded for the minutes.
08:04:03 <anitsirk> #info anitsirk is Kristina Hoeppner, Catalyst in Wellington, New Zealand
08:04:03 <anitsirk> Also, please feel free to use the following commands to start your line with which will help write the minutes for this meeting:
08:04:03 <anitsirk> 1. #info: Adds that line to the minutes.
08:04:03 <anitsirk> 2. #idea: If you have an idea that you want recorded in the minutes, use this command.
08:04:04 <anitsirk> 3. #link: Follow this directly by the link and text after that. You can also simply put the full link incl. the protocol in a line and it'll appear in the minutes.
08:05:15 <ghada> #info ghada-l is Ghada El-Zoghbi, developer at Catalyst IT in Sydney, Australia.
08:05:53 <anitsirk> aarowlaptop?
08:06:02 <anitsirk> Vaughany ?
08:06:21 <aarowlaptop> #info aarowlaptop is Aaron Wells in Wellington from Catalyst IT
08:07:05 <aarowlaptop> Looks like you got disconnected for a second there anitsirk
08:07:11 <anitsirk> oops. sorry. hit the wrong key and kicked myself off irc :-(
08:07:24 <ghada> :P
08:07:26 <anitsirk> back now. hope that didn't mess up the meeting.
08:07:28 <anitsirk> #topic Items from last meeting
08:07:28 <anitsirk> #info Everyone attempt to add bugs to the HTML export blueprint https://blueprints.launchpad.net/mahara/+spec/improve-html-export
08:07:28 <anitsirk> https://blueprints.launchpad.net/mahara/+spec/improve-html-export
08:07:53 <anitsirk> I don't think anyone in Wellington had the chance to do that.
08:07:58 <anitsirk> We've been pretty busy.
08:09:15 <anitsirk> So if you find any more bugs relating to the HTML export, please file them and we can associate them with the blueprint.
08:09:43 <anitsirk> #info BTW: aarowlaptop has been fixing a bunch of Leap2A bugs lately thanks to funding from Kwantlen Polytechnic University.
08:10:11 <anitsirk> so that is improving :-)
08:10:26 <aarowlaptop> yes, and possibly a few more coming from SWITCH
08:10:40 <ghada> that's fantastic!
08:10:59 <anitsirk> i guess it's time to move on to the next topic. aarowlaptop you are up.
08:11:02 <anitsirk> #topic Data gathered so far by the new PHP-version-collecting Mahara stats
08:11:02 <anitsirk> aarowlaptop: over to you.
08:11:49 <aarowlaptop> #info Following up on a point from an earlier dev meeting, in the last round of minor releases we expanded the data gathered by the Mahara stats cron, so that it includes some environmental data
08:12:15 <aarowlaptop> #info It's been about a week since that was released, and so far we've got data from 20 sites that have responded with the new expanded info.
08:12:27 <aarowlaptop> #info I've collated the data into a Google spreadsheet: https://docs.google.com/spreadsheets/d/1MTQmnDczefBzRzGWIYtWotEeIJTavEMegNkeHqGhgvE/edit?usp=sharing
08:13:15 <aarowlaptop> Part of what we were interested in, was determining how many sites were still using PHP 5.3. And we can see that, even in these 20, there are several 15.04 sites that are still on PHP 5.3
08:14:03 <ghada> yes, that's not a good sign.
08:14:07 <aarowlaptop> lol, no
08:14:16 <aarowlaptop> There are also a couple of sites already on 5.6
08:14:40 <aarowlaptop> and I was surprised at seeing several running it in fastcgi
08:14:54 <aarowlaptop> it's about a 50/50 split on postgres & mysql
08:15:40 <anitsirk> the thing is that ubuntu 12.04 is an lts. so technically they don't have to move off it until mid 2017.
08:16:22 <aarowlaptop> Yes, the 5.3 sites that have reported in so far, are mostly on Ubuntu 12.04
08:17:23 <anitsirk> Where from here?
08:17:23 <aarowlaptop> Anyway, I'll keep an eye on these stats and try to collate them up again before the next dev meeting, by which time we'll hopefully have some more data.
08:17:38 <aarowlaptop> anitsirk: What? :)
08:17:52 <anitsirk> #action aarowlaptop to collate the stats again for the next dev meeting.
08:18:20 <ghada> this is only info collected from 1.9+, right?
08:18:28 <anitsirk> ghada: yes.
08:18:37 <aarowlaptop> Yeah, only from sites that have upgraded to the latest 1.9, 1.10, or 15.04
08:18:49 <ghada> ok
08:19:01 <aarowlaptop> and agreed to send back the expanded stats data
08:19:02 <anitsirk> since we only rolled out the updates last week, many may not have updated yet.
08:19:22 <anitsirk> they will see the registration message come up on the screen right after the update.
08:19:31 <aarowlaptop> I did not see the big cluster of Ubuntu 14.04/postgres sites I'd expect from Catalyst's own hosting, so I may want to check on what's up with that
08:19:53 <anitsirk> aarowlaptop: some of our clients may not have decided to register their sites
08:20:19 <ghada> our CI didn't pick up the release
08:20:27 <anitsirk> oh no.
08:20:31 <aarowlaptop> I'll just take a look and see if it reveals any bugs in the stats process
08:20:33 <ghada> I was going to investigate it today but got side tracked
08:20:37 <aarowlaptop> huh
08:20:50 <anitsirk> what does it look for in order to pick it up?
08:21:00 <ghada> i think the tag..
08:21:04 <ghada> but, i'm not really sure
08:21:15 <aarowlaptop> fair enough
08:21:29 <ghada> i'll check it out tomorrow.
08:21:30 <anitsirk> i did see a tag for the release.
08:21:41 <aarowlaptop> yeah, let us know if you spot any problems in the release
08:21:42 <anitsirk> please let us know if there is anything that got missed out
08:21:49 <ghada> sure
08:22:22 <anitsirk> anything else for this topic?
08:23:03 <anitsirk> ok. then let's continue with the next topic.
08:23:04 <anitsirk> #topic Release progress
08:23:04 <anitsirk> #info We are finally closing off features this week. We had extended the time frame in which to accept new features because a number of them were already on the way and close to getting finished so that we wanted them to get over the line.
08:23:14 <anitsirk> #info The Catalyst front-end team is making good progress with Bootstrap and finalizing the last major screens before the focus will be on working on some of the details.
08:23:22 <anitsirk> #info The first themes are being worked on by our designers. We are aiming to have 4 themes (besides raw, the untheme) for this release: Default, one for primary schools, a light and a dark one.
08:23:32 <anitsirk> #info There is still a good chunk of reviewing and bug fixing to be done. If you can help, please lend us a hand and feel free to review patches that are in review.
08:24:01 <aarowlaptop> Sorry, had a freeze-up on my computer for a minute there
08:24:12 <anitsirk> was i pasting too quickly, aarowlaptop?
08:24:13 <aarowlaptop> but I didn't have anything else to add
08:24:34 <aarowlaptop> lol, no, just firefox not liking when I pulled up a github page
08:24:43 <aarowlaptop> or maybe it was Google Docs
08:25:12 <anitsirk> So it's still going to be a number of intense weeks before the release around mid october
08:26:18 <anitsirk> we also have to defer a few patches to the next release as they will need more reviews.
08:28:08 <anitsirk> looks like we can continue? there aren't any comments or questions.
08:28:19 <aarowlaptop> none from me
08:28:33 <ghada> nope
08:28:37 <anitsirk> #topic Next meeting and chair
08:28:38 <anitsirk> What about 30 September at 8 a.m. UTC? It's a Wednesday again which I think worked well for most of us.
08:28:38 <anitsirk> http://www.timeanddate.com/worldclock/fixedtime.html?iso=20150930T08
08:28:38 <anitsirk> Or would 7 a.m. UTC work as well / be better?
08:29:09 <aarowlaptop> 7am UTC works better for me
08:29:27 <ghada> either is fine with me
08:29:43 <anitsirk> shall we say 30 September at 7:00 UTC then?
08:29:46 <ghada> sep 30 is also good
08:29:51 <anitsirk> that's 8 UK / 9 Europe
08:30:10 <anitsirk> and 6 p.m. Sydney and 8 p.m. NZ
08:30:13 <aarowlaptop> OK
08:30:28 <anitsirk> now to the big question that people have been dreading....
08:30:36 <anitsirk> who volunteers to chair the meeting? :-)
08:30:48 <anitsirk> not much choice today, tbh.
08:31:24 <anitsirk> i can chair again if needed.
08:31:43 <aarowlaptop> sounds good to me ;)
08:32:16 <ghada> thanks anitsirk
08:32:26 <anitsirk> #info The next Mahara developer meeting will take place on 30 September 2015, 7:00 UTC in #mahara-dev on Freenode IRC. It will be chaired by Kristina.
08:32:26 <ghada> :-D
08:32:32 <anitsirk> http://www.timeanddate.com/worldclock/fixedtime.html?iso=20150930T07
08:32:43 <anitsirk> #topic Any other business
08:32:44 <anitsirk> Does anyone have anything else that we should discuss?
08:32:58 <ghada> i think that time is wrong in the link
08:32:59 <aarowlaptop> Not me
08:33:41 <anitsirk> ghada: sorry. my mistakes. it should be correct, but sydney may not have moved to daylight savings yet
08:33:46 <ghada> no, my mistake
08:33:55 <anitsirk> we have two weeks per year where we are three hours apart
08:34:01 <anitsirk> and that must be it :-)
08:34:13 <anitsirk> does that still work for you, ghada?
08:34:14 <ghada> yes, it still works for me. np
08:34:19 <anitsirk> thank you.
08:34:36 <anitsirk> back to any other business. i have two. how many have you?
08:34:48 <ghada> none
08:34:51 <ghada> go for it.
08:34:58 <anitsirk> #info The call for proposals for Mahara Hui UK is still open until 13 September: https://maharahuiuk.org/ The hui itself will take place at Southampton Solent University on 9 and 10 November 2015. Would love to see you there.
08:35:15 <anitsirk> and
08:35:16 <anitsirk> #info If you want to share your Mahara story, please send it to newsletter@mahara.org by 25 September 2015 for inclusion in the October issue of the newsletter to be published on 1 October 2015.
08:35:42 <anitsirk> that's it. no immediate action needed for either.
08:35:54 <anitsirk> aarowlaptop: do you have any other business?
08:36:13 <anitsirk> ah. your "no" went under above.
08:36:23 <anitsirk> then i think this concludes our short meeting for today.
08:36:31 <anitsirk> thank you very much for attending, aarowlaptop and ghada.
08:36:34 <aarowlaptop> Okay, have a good evening everybody!
08:36:35 <ghada> thanks antisirk
08:36:36 <anitsirk> see you next time.
08:36:39 <anitsirk> #endmeeting