08:05:14 <mingard> #startmeeting
08:05:14 <maharameet> Meeting started Thu May 28 08:05:14 2015 UTC.  The chair is mingard. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:05:14 <maharameet> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:05:15 <anitsirk> so we won't make everybody else wait :-)
08:05:24 <mingard> #info Welcome to the 44th Mahara developer meeting. Please introduce yourself using #info at the start of the line so that we know who's attending today / tonight
08:05:30 <mingard> #info mingard is Jono Mingard, Catalyst IT in Wellington, NZ
08:05:37 <anitsirk> #info anitsirk is Kristina Hoeppner, Catalyst IT, Wellington, NZ
08:05:39 <anzeljg> #info anzeljg is Gregor Anželj, developer and translator from Ljubljana, Slovenia
08:05:53 <yuliya> #info yuliya is Yuliya Bozhko from Totara Learning, Brighton, UK
08:05:58 <rkabalin> #info rkabalin is Ruslan Kabalin, Lancaster University, UK
08:06:10 <robertl_> #info robertl_ is Robert Lyon, Catalyst IT in Wellington, NZ
08:06:13 <ghada> #info ghada is Ghada El-Zoghbi,  Catalyst IT in Sydney, AU
08:06:32 <mingard> thanks
08:06:36 <mingard> #topic Items from last meeting
08:06:45 <mingard> #info yuliyabozhko1 will try to contact Launchpad and check if there is a way to get a custom language code set up
08:06:50 <mingard> yuliya: any update on that?
08:07:32 <yuliya> well, I didn't ask directly, but looked through the existing enquiries
08:07:43 <yuliya> looks like they don't add codes that are not from ISO standard
08:07:56 <yuliya> Sonn tried to define custom language
08:08:02 <mingard> oh is that the problem? I wasn't here for the original discussion
08:08:03 <anitsirk> i can provide info on that.
08:08:13 <yuliya> but it doesn't show up in user interface for translation
08:08:30 <anitsirk> son said he could create the de_du lang pack and have it sit on Launchpad.
08:08:36 <son> sorry I am late
08:08:48 <anitsirk> however, translators can't use the online interface but would need to upload the translation file
08:08:58 <son> I pushed a po file for de_du
08:09:00 <anitsirk> it will then still be made available via langpacks.mahara.org
08:09:09 <son> ye
08:09:12 <yuliya> yep, that's right
08:09:31 <anitsirk> knowing ralf, the german translator, i'm sure he'll be happy with that as the online interface is having timeout issues.
08:09:35 <son> yes, I will update the scripts on langpacks.mahara.org for that
08:09:48 <anitsirk> so once the de_du is in langpacks.mahara.org, i'll let him know about what is possible.
08:09:51 <yuliya> how will they be adding their po files?
08:10:15 <yuliya> will they just have to push them to bazaar code repo?
08:10:18 <son> they will manually update their po
08:10:37 <yuliya> ah wait, there is import tool, right?
08:10:43 <son> by import interface or bzr
08:10:54 <son> right
08:10:58 <yuliya> cool :)
08:11:18 <mingard> ok, so this is basically as solved as we can make it?
08:11:19 <anitsirk> #info Launchpad does not allow for custom language packs that don't conform to ISO to be translated online. However, we can still upload the po files and make them available via langpacks.mahara.org
08:11:30 <mingard> thanks anitsirk :)
08:11:44 <anitsirk> #info langpacks.mahara.org will be updated asap with the de_du langpack.
08:12:07 <mingard> ok, next up
08:12:13 <mingard> #info robertl_ to create bugs / wishlist items for improving the HTML export
08:12:22 <mingard> robertl_: how's that going?
08:12:39 <robertl_> I've still been to busy to get any more done for that
08:12:49 <son> #info, translators need to manually push their de_du po file for each branch to launchpad
08:12:50 <robertl_> I need it to makemy day to day list :)
08:13:37 <robertl_> I will try and do more in this asap
08:13:49 <mingard> hmm, I feel like those #infos should be the other way round
08:13:54 <son> #info son, Son Nguyen, Catalyst IT, Wellington, NZ
08:14:10 <mingard> ok robertl_, we'll give you another extension ;)
08:14:20 <mingard> is a blueprint or something being created for html export as well?
08:14:24 <robertl_> thank you sir
08:14:27 <yuliya> :)
08:14:30 <yuliya> lucky!
08:14:31 <son> :)
08:15:14 <mahara-jenkins> Project mahara-gerrit build #1846: SUCCESS in 1 hr 17 min: http://test.mahara.org/job/mahara-gerrit/1846/
08:15:14 <mahara-jenkins> robertl: Adding paginator to 'My pages' block (Bug #634689)
08:15:15 <mahara-jenkins> Starting build #1847 for job mahara-gerrit (previous build: SUCCESS)
08:15:23 <mingard> hello mahara-jenkins ...
08:15:31 <yuliya> lol
08:15:54 <mingard> #action robertl_ to finish creating bugs for HTML export before the next meeting
08:16:31 <robertl_> !jenkins botsnack
08:16:31 <mahara-jenkins> robertl_: you're so kind to me!
08:16:59 <mingard> oi, don't encourage it
08:17:13 <mingard> anyway, next up
08:17:16 <mingard> #info anitsirk to get GitLab ball rolling
08:17:23 <mingard> as far as I know, we've finished migrating to NZOSS's gitlab instance at https://git.nzoss.org.nz/mahara/mahara
08:17:26 <mingard> is that right?
08:17:43 <anitsirk> #info The official Mahara repositories are now at https://git.mahara.org
08:17:54 <robertl_> yep and moved on from there too :)
08:18:09 <anitsirk> #info the repositories are mirrored to Github and to https://git.nzoss.org in case one of the others goes down.
08:18:09 <mingard> haha OK, I haven't been keeping up obviously
08:18:19 <mingard> thanks for the update
08:18:29 <anitsirk> #info aarow is going to update the wiki so that we have the new links there.
08:18:37 <yuliya> awesome
08:19:00 <robertl_> yeah we now have more mirrors than  the palace of Versailles
08:19:06 <anitsirk> #info since nobody is pushing to the repositories directly (at least the mahara codebase), account creation is only upon request. all code for Mahara goes through Gerrit.
08:19:32 <anitsirk> And Gerrit is yet another repository :-)
08:19:38 <mingard> does it say that on the site anywhere?
08:19:46 <anitsirk> not yet
08:20:00 <anitsirk> the wiki has been out of read-only mode only for a short while
08:20:06 <ghada> i think it only says something about github.
08:20:06 <anitsirk> aarow is going to make the changes soon.
08:20:14 <anitsirk> gotta get the security releases out first ;-)
08:20:39 <anitsirk> now that the wiki is editable again, things can move.
08:20:41 <son> I can update the wiki page
08:20:49 <anitsirk> son: aarow is going to make the changes
08:20:56 <son> ok
08:21:03 <robertl_> releases should be in the morning I believe
08:21:07 <anitsirk> yes.
08:21:36 <anitsirk> that's all.
08:21:38 <mingard> ok. action that or is it not worth it?
08:21:51 <anitsirk> not worth it i think.
08:21:59 <mingard> alrighty, moving on
08:22:05 <mingard> #info aarowlaptop to upgrade reviews gerrit soon
08:22:14 <anitsirk> Aarow has done that
08:22:18 <mingard> yup
08:22:22 <anitsirk> Gerrit is now running 2.11
08:22:38 <mingard> hashtag done
08:22:38 <anitsirk> it looks pretty neat. some new nice features. but also totally different interface. takes getting used to.
08:22:46 <yuliya> yep, brand new and shiny :)
08:22:51 <anitsirk> #info Gerrit is upgraded.
08:22:51 <robertl_> the new gerrit takes a bit to get used to
08:23:04 <mingard> especially finding the links to checkout (at least for me)
08:23:05 <robertl_> things are all in strange places
08:23:12 <yuliya> it has inline editing now too!
08:23:14 <yuliya> :D
08:23:17 <mingard> yeah :D
08:23:26 <robertl_> but once you 'get it' it's much more useful
08:23:36 <anitsirk> will that become your new dev environment then? ;-)
08:23:53 <robertl_> I particularly like the ease of backporting
08:24:04 <mingard> can you actually create patches in gerrit or just edit existing ones?
08:24:39 <yuliya> no, edit existing only
08:24:45 <son> just edit existing patch as far as I know
08:24:54 <mingard> ah well ... one day it'll be a real dev environment ;)
08:25:07 <yuliya> I hope not :P
08:25:26 <mingard> haha anyways
08:25:30 <mingard> #info add php version to mahara.org/stats to see what versions people are using (a mahara dev)
08:25:35 <mingard> aarow has been making progress on this - see https://bugs.launchpad.net/mahara/+bug/1447865
08:26:26 <anitsirk> #info aarow has been making progress on this - see https://bugs.launchpad.net/mahara/+bug/1447865
08:26:55 <mingard> any comments? questions? or shall we wait for aarow to explain himself
08:26:57 <robertl_> there has been some debate about if/how we ask existing sites
08:27:11 <robertl_> to re-confirm their giving the new info
08:27:18 <mingard> yeah, I notice it's linked to a couple of other bugs related to that
08:28:27 <anitsirk> hi tonyjbutler
08:28:42 <robertl_> whether it be a flag on upgrade where it asks the site to re-confirm or have something so that only new sites get the full treatment
08:28:43 <tonyjbutler> Hi, sorry I'm late
08:28:51 <robertl_> or something else
08:28:59 <robertl_> hi tonyjbutler
08:29:19 <mingard> hiya tonyjbutler
08:29:19 <anitsirk> robertl_ i like the former version better because otherwise the majority of our known sites will never be asked.
08:29:37 <anitsirk> it could be something in addition to display on the admin homepage similar to the plugins that need to be installed.
08:29:57 <robertl_> true that would be a good way to alert them
08:30:02 <anitsirk> besides: older mahara sites may be on older php versions wheras newer sites most likely aren't
08:30:17 <anitsirk> so we actually wouldn't catch those that we should be worrying about ;-)
08:30:44 <robertl_> then there is the question of what we do with all this extra data we collect - what (if any) can be displayed to the public in form of usage metrics/graphs
08:31:09 <ghada> Would you  push it out in one of the security releases - for older sites?
08:31:44 <ghada> 1.9+
08:31:50 <robertl_> if we did backport it - it'll only go to the latest 3 versions
08:32:28 <robertl_> which would mean we miss out on the data about real old sites :(
08:32:45 <anitsirk> for what to make public, i think we looked at registered users, location of the server to put them onto a map
08:32:54 <anitsirk> real old sites: should update anyway for security ;-)
08:33:02 <ghada> yes.
08:33:17 <mingard> we only want to know about *relevant* sites ;)
08:33:26 <robertl_> true - but it would be cool to know how many on't
08:33:30 <robertl_> don't
08:33:32 <robertl_> that is
08:34:03 <mingard> true, would be interesting to know. would we have data about php versions etc public as well? at least to all devs?
08:34:18 <anitsirk> well, we would still know that they are old sites and thus more likely to be on old infrastructure
08:34:42 <ghada> well, i don't think there's any real way we're going to get that information (php versions that is).
08:34:53 <ghada> for really old sites
08:35:19 <mingard> yeah, and getting some data on some sites would still be much better than having no idea
08:35:34 <yuliya> I agree with that too
08:35:36 <ghada> but this change will help a lot in the future - for PHP 7 !
08:36:10 <mingard> huh, didn't know that was a thing
08:36:42 <ghada> https://wiki.php.net/rfc/php7timeline
08:37:28 <mingard> interesting
08:37:52 <ghada> 6 was a bit of a failure and they've decided to skip it all together
08:37:58 <ghada> because of the bad name it got
08:38:28 <ghada> anyway, we're off topic - sorry
08:38:55 <mingard> yeah, sorry about that. do we have enough to go on re statistics?
08:39:56 <robertl_> yep - I think so - hard to get the full picture without aarow's input
08:40:12 <mingard> true. ok, nothing else particular was posted on the wiki, so is there anything to discuss or should we just move on to deciding the next meeting time/date?
08:40:27 <ghada> do we want to backport it to 1.9, 1.10 and 15.04?
08:40:31 <anitsirk> i have a few things
08:40:42 <anitsirk> but they could wait until "Other business"
08:40:51 <anitsirk> ghada: we haven't decided yet
08:40:56 <ghada> ok
08:41:28 <mingard> #info whether to backport this to 1.9, 1.10 and 15.04 is yet to be decided
08:41:28 <ghada> ok, i think we're done with this then.
08:41:34 <mingard> cool
08:41:54 <mingard> #topic Next meeting and chair
08:42:10 <mingard> how does the 25th of June sound? and does this time work for everyone? anyone prefer it earlier/later?
08:42:22 <anitsirk> works date and time wise for me
08:42:35 <ghada> 25th is good
08:42:39 <yuliya> yep, should be ok for me too
08:42:42 <rkabalin> works for me
08:42:49 <son> fine for me too
08:43:14 <mingard> great. so ... who to chair?
08:43:39 <rkabalin> long pause :)
08:43:46 <mingard> no volunteers? I am shocked
08:43:50 <rkabalin> I can
08:43:57 <anitsirk> thank you, rkabalin
08:44:03 <rkabalin> no problem
08:44:08 <mingard> awesome, thanks rkabalin :)
08:44:16 <mingard> #info rkabalin is going to chair the 45th Mahara developer meeting on 23 April 2015 at 8:00 UTC
08:44:20 <mingard> oops
08:44:22 <mingard> wrong date
08:44:25 <mingard> #undo
08:44:25 <maharameet> Removing item from minutes: <MeetBot.items.Info object at 0x18b5610>
08:44:38 <mingard> #info rkabalin is going to chair the 45th Mahara developer meeting on 25 June 2015 at 8:00 UTC
08:44:53 <mingard> http://www.timeanddate.com/worldclock/fixedtime.html?msg=45th+Mahara+developer+meeting&iso=20150625T08&p1=1440
08:45:39 <mingard> ok, moving on to anitsirk's things (and any others)
08:45:40 <mingard> #topic Any other business
08:46:02 <anitsirk> #info The Mahara wiki was upgraded to a newer version
08:46:13 <mingard> so I see - looks great :)
08:46:37 <anitsirk> #info the Mahara user manual was upgraded to a newer version of Sphinx. Unfortunately, we could not yet resolve a bunch of PDF generation errors that may have been caused by a translation.
08:47:22 <anitsirk> #info Therefore, we suspended the PDF generation for the time being until we can find the apostrophe or other little thing that's causing it. Since the translation export only happens once a day, it's a long process and the error messages are a bit cryptic.
08:47:33 <ghada> i'd love it if it had the 'cookie crumb' option on.
08:47:49 <anitsirk> The good thing for the translators: more strings should now be translatable. that's why we wanted to move to sphinx 1.2
08:48:04 <anitsirk> ghada: huh? where? wiki or manual?
08:48:10 <ghada> wiki
08:48:18 <anitsirk> what's that function?
08:48:19 <ghada> you can see the page you came from
08:48:32 <anitsirk> if it can be turned on on the interface, aarow might be able to do that.
08:48:48 <ghada> we've got it on for our internal syd wiki
08:48:59 <ghada> actually catalyst wiki
08:49:15 <anitsirk> ah. then the mahara one should be able to do that as well.
08:49:27 <mingard> looks like there are extensions to do it but nothing built in
08:49:34 <mingard> eg http://www.mediawiki.org/wiki/Extension:BreadCrumbs2
08:49:37 <anitsirk> george did the upgrade and he upgraded the catalyst wiki. if you remember, could you please ask him tomorrow, ghada?
08:50:15 <ghada> george - i don't know him. can you send me his last name?
08:50:15 <anitsirk> And number 3
08:50:54 <anitsirk> #info Submissions for the next Mahara newsletter are due by 26 June 2015.
08:51:16 <anitsirk> That's it from me.
08:51:18 <mingard> thanks anitsirk. anyone else?
08:52:50 <rkabalin> does not seems anyone else has soemthing to discuss
08:52:50 <robertl_> nothing from me - except I'm looking forward to php 7 and declaring return types -> https://wiki.php.net/rfc/return_types
08:53:02 <yuliya> :)
08:53:09 <yuliya> I have nothing either
08:53:21 <mingard> yay :)
08:53:21 <ghada> nothing...
08:53:24 <mingard> ok, I guess that's all. thanks for coming everyone and have a nice evening/day/night :)
08:53:26 <anitsirk> thank you very much for chairing.
08:53:34 <mingard> no problem
08:53:36 <robertl_> thanks mingard
08:53:36 <mingard> #endmeeting