08:01:52 <anitsirk> #startmeeting
08:01:52 <maharameet> Meeting started Thu Dec 18 08:01:52 2014 UTC.  The chair is anitsirk. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:52 <maharameet> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:01:56 <anitsirk> #info Welcome to the 39th Mahara developer meeting.
08:01:56 <anitsirk> This is going to be the last one for 2014.
08:01:56 <anitsirk> Please introduce yourself starting a new line with "#info" and then your name and where you are from.
08:01:56 <anitsirk> #info anitsirk is Kristina Hoeppner, Catalyst IT, Wellington
08:02:10 <yuliyabozhko> #info yuliya is Yuliya Bozhko from Totara Learning Solutions in Wellington, NZ
08:02:12 <tobiasz_> #info tobiasz_ is Tobias Zeuch, developer at KIT, Karlsruhe, Germany
08:02:18 <robertl> #info robertl is Robert Lyon, Catalyst IT, Wellington, NZ
08:02:22 <aarowlaptop> #info aarowlaptop, Aaron G. Wells at Catalyst IT in sunny Wellington New Zealand
08:02:30 <yuliyabozhko> :D
08:02:32 <anitsirk> To get us into the mood for Christmas... Today was not as cold as a European winter in Wellington, but sure enough dark enough for winter. So, if you want to get into winter mood, why not have a crackling fire in the background? http://www.youtube.com/watch?v=ifGkCN93Fxg Or if you prefer, some Christmas carols http://www.youtube.com/watch?v=KOTuFLUiY4Y
08:02:56 <anitsirk> i guess today's meeting should be shorter than those videos ;-)
08:03:03 <anitsirk> so let's get started.
08:03:07 <anitsirk> #topic Items from last meeting
08:03:07 <anitsirk> All four items are for aarowlaptop
08:03:07 <anitsirk> #info aarowlaptop update the wiki with "Signed-off" line necessity changes
08:03:18 <aarowlaptop> yes, apparently...
08:03:39 <aarowlaptop> As we discussed at the last meeting, we've agreed to make the Signed-off-by line optional in git commit messages rather than required
08:03:45 <ghada> #info ghada-l is Ghada El-Zoghbi at Catalyst IT, Sydney
08:03:49 <anitsirk> hi ghada.
08:04:04 <aarowlaptop> I've updated the documentation in the wiki to reflect this. If you notice any spots that I missed, feel free to update them also, or let me know.
08:04:48 <yuliyabozhko> sounds good
08:04:50 <anitsirk> #info aarowlaptop updated the documentation on the wiki so that the signed-off-by line is not needed in git commit messages anymore.
08:04:55 <anitsirk> aarowlaptop: do you have the link?
08:05:00 <aarowlaptop> #info I've also updated gerrit to no longer require the Signed-off-by line. This seems to have had the unintentional side effect that now, if you *do* use a Signed-off-by line, and it's below the Change-Id line, gerrit gets upset.
08:05:19 <aarowlaptop> hm, do I have a link, let me see...
08:05:31 <yuliyabozhko> ah, that's what it was with Nigel's commits today?
08:05:53 <aarowlaptop> This is the main page that I edited: https://wiki.mahara.org/index.php/Developer_Area/Contributing_Code
08:06:10 <robertl> no, that was nigel trying to commit to wrong repo I think
08:06:10 <aarowlaptop> yuliyabozhko: That was one of the issues with Nigel's commits
08:06:16 <aarowlaptop> oh
08:06:31 <aarowlaptop> then maybe what I said isn't true. :)
08:06:33 <yuliyabozhko> :)
08:06:34 <aarowlaptop> I'll test it now...
08:06:51 <yuliyabozhko> was working for me yesterday definitely, after your change
08:06:52 <anitsirk> https://wiki.mahara.org/index.php/Developer_Area/Contributing_Code for the changes in documentation
08:07:48 <aarowlaptop> okay, yeah, never mind, you *can* have a Signed-off-by line below the Change-ID still.
08:07:59 <aarowlaptop> I guess Nigel was having a different problem
08:08:07 <aarowlaptop> https://reviews.mahara.org/#/c/4106/
08:08:26 <yuliyabozhko> oh well, yep, looks like it's working
08:08:38 <anitsirk> #info You can have a signed-off-by line below the Change-ID. aarowlaptop double-checked.
08:08:53 <aarowlaptop> So I guess that's item 2 on the agenda. :)
08:09:02 <yuliyabozhko> that was easy :)
08:09:04 <anitsirk> yep. you already mentioned that. straight onto 3
08:09:05 <anitsirk> #info aarowlaptop will compare all aspects of Smarty and Twig and write wiki on this change proposal
08:09:30 <yuliyabozhko> this is a serious one now ;)
08:09:51 <aarowlaptop> I have not done that yet. But we did discuss the template change with the Catalyst front-end development team, and we decided to go with Twig
08:10:33 <yuliyabozhko> I think there was a patch in review ages ago. any chance to revive it?
08:10:41 <aarowlaptop> Yep, that's on the plate
08:10:42 <anitsirk> #info in discussions with Catalyst front-end developers, we decided to go with Twig. this change will not be implemented for 15.04, but we are looking into doing it for the 15.10 release.
08:11:02 <anitsirk> yuliyabozhko: it'll definitely be looked at, but things have also evolved since then...
08:11:09 <aarowlaptop> https://reviews.mahara.org/#/q/message:Twig+status:abandoned,n,z
08:11:15 <yuliyabozhko> https://reviews.mahara.org/#/q/status:abandoned+project:mahara+branch:master+topic:twig,n,z
08:11:20 <yuliyabozhko> yep, just found too :)
08:11:24 <aarowlaptop> there are the three patches that Chris T developed for us
08:11:31 <aarowlaptop> oh, topic: twig
08:11:33 <aarowlaptop> that's better
08:11:36 <yuliyabozhko> why was it dropped in the first place?
08:11:51 <anitsirk> he didn't finish it and we then didn't have time to continue working on it
08:12:01 <aarowlaptop> Yeah, it didn't fit our strategy at the time
08:12:11 <anitsirk> at the time it was more of a "would be nice to have", but not essential
08:12:11 <yuliyabozhko> right
08:12:30 <robertl> things will have changed a lot since it was written both in mahara and twig I imagine
08:12:35 <aarowlaptop> Because it is kind of a lot of work, without much to show for it on the front-end
08:12:39 <anitsirk> anything else on this topic? objections to going with twig?
08:13:00 <tobiasz_> can you sum up a little about what let you to decide on Twig?
08:13:02 <aarowlaptop> I believed we discussed it at the last meeting and no one had any strong feelings towards Twig or Smarty. :)
08:13:24 <aarowlaptop> sure
08:13:33 <anitsirk> tobiasz_: in essence: Twig is more modern than Smarty. And large projects such as Drupal also use it.
08:13:40 <aarowlaptop> Those were the main selling points
08:13:51 <aarowlaptop> and both Smarty and Twig have similar features and active dev communities
08:14:29 <tobiasz_> ok, thanks :)
08:14:36 <aarowlaptop> Twig is integrated into Symfony, and it's the template system for Drupal 8
08:15:02 <anitsirk> since Twig is more modern, it is more attractive for front-end devs to work on - more potential of them wanting to get involved
08:15:09 <aarowlaptop> ah yeah, that too. :)
08:15:46 <anitsirk> any more questions or shall we move to the next front-end topic?
08:15:51 <yuliyabozhko> I guess it is something to look at after 15.04 release?
08:16:00 <ghada> so if we're going to introduce it in 15.10, are we still considering backward compatability?
08:16:01 <anitsirk> yuliyabozhko: yes.
08:16:16 <yuliyabozhko> ghada: that's a good point
08:16:22 <ghada> or, do we just tell the community this is going to happen and please prepare
08:16:52 <robertl> might be easier to create a help system to upgrade templates to twig
08:16:55 <yuliyabozhko> brace yourselves :D
08:17:11 <robertl> semi-automatic with lots of help instructions :)
08:17:14 <aarowlaptop> Part of Chris T's patch was a set of scripts to mostly automatically convert Dwoo templates to Twig templates
08:17:33 <anitsirk> #idea introduce new templates and CSS framework in 15.10. since providing two different ways of doing things (css and templates) could be very difficult to maintain, we were pondering a long-term support release for 15.04
08:17:45 <anitsirk> that's what we discussed with our front-end devs.
08:18:00 <aarowlaptop> Backwards compatibility would be possible
08:18:17 <anitsirk> that way, those who want to move can move and we don't maintain two different systems. while others, who can't move immediately can stay on that version longer (timeframe yet to be decided).
08:18:30 <aarowlaptop> but I was leaning towards not doing it unless we get a specific commission to implement backwards compatibility
08:18:59 <ghada> yeah, i was concerned about it last time because we were thinking of introducing it in 15.04.
08:19:06 <aarowlaptop> if we did a BC system, we'd only want to do it for 1 or 2 releases so that we don't have to maintain both systems
08:19:12 <ghada> i think now we're giving the community time
08:19:19 <tobiasz_> how would backwards compatibility work, with a different naming theme for twig templates?
08:19:45 <yuliyabozhko> I think templates are quite similar, but not too sure
08:20:01 <son> Hi
08:20:05 <ghada> hi son.
08:20:12 <son> Sorry, I am late
08:20:21 <anitsirk> #info part of the patches for Twig that already exist included functionality to convert Dwoo templates to Twig ones mostly automatically.
08:21:14 <aarowlaptop> yeah, most of the time you call the wrapper method smarty()
08:21:35 <aarowlaptop> and then it looks at your theme and such, to determine which actual template file to parse
08:21:37 <ghada> we should look into modifying that script to auto convert.  Would be a really great tool.
08:21:52 <anitsirk> #info Backwards compatibility is a possibility, but would only be considered if it is commissioned work as it can be quite tricky to maintain 2 systems at once.
08:21:55 <robertl> compatibility could be having a legacy renderer/parser that reads dwoo templates and understands them twig maybe
08:22:00 <aarowlaptop> it *probably* would be possible to make that function look for and handle a Twig template, and fall back to a Dwoo template
08:22:22 <aarowlaptop> if it finds no Twig template
08:23:21 <aarowlaptop> Similarly for the CSS framework, we were discussing how it would be possible to have an alternate parent theme instead of "raw", for backwards-compatibility of older themes
08:23:33 <anitsirk> shall we move to the css framework things?
08:23:37 <aarowlaptop> yeah
08:23:42 <anitsirk> #info leave CSS framework proposal up to the front-end experts to hash it out with aarowlaptop
08:23:51 <aarowlaptop> So, we discussed that with the front-end devs as well
08:23:52 <anitsirk> please continue
08:24:20 <aarowlaptop> They said that either Gumby or Bootstrap would do. They have a slight preference for Gumby because it's a newer, more exciting framework for them.
08:24:58 <aarowlaptop> I said I'd take a closer look at both frameworks and try them out myself, to see if either one is particularly harder for a PHP dev to handle
08:25:04 <aarowlaptop> I have not gotten around to that yet ;)
08:25:09 <anitsirk> there were no new arguments for or against either from what we discussed last time
08:25:10 <yuliyabozhko> haha, sorry, googled Gumby and came up with "Gumby is a green clay humanoid character"
08:25:16 <aarowlaptop> Gumby is that too
08:25:35 <anitsirk> we'll leave that as action item for next time then, aarowlaptop
08:25:35 <aarowlaptop> http://www.gumbyworld.com/wp-content/themes/duotive-three/images/home-large-gumby.png
08:25:41 <aarowlaptop> I have to imagine the framework is named after him
08:25:59 <aarowlaptop> Yeah
08:26:04 <yuliyabozhko> :)
08:26:11 <anitsirk> #action aarowlaptop to investigate Gumby and Bootstrap a bit to make a final decision which CSS framework to choose.
08:26:40 <aarowlaptop> As mentioned, we also floated the idea of having a "1.10 compatibility" theme available, to make theme updates easier
08:26:47 <anitsirk> ideally, we'll be starting the process at the beginning of january and would be able to involve our front-end intern. since it's quite a bit of work though, it'll not go into 15.04
08:27:30 <anitsirk> but we said that this would be quite tricky and we were going with the longer-term support release ;-)
08:28:50 <aarowlaptop> Yeah, that would achieve much the same end goal
08:29:02 <ghada> aarowlaptop: better you than me.  I'm terrible when it comes to css!
08:29:04 <aarowlaptop> of making things easier for institutions that don't want to do a major theme overhaul so shortly
08:29:22 <aarowlaptop> Yeah... I'm not great with it either
08:29:39 <aarowlaptop> apparently these CSS frameworks, you tend to write stuff in a CSS meta-language that compiles to CSS
08:29:43 <yuliyabozhko> that's why front-end devs exist :)
08:29:45 <ghada> please have pity on us poor devs when considering the framework.
08:29:46 <aarowlaptop> LESS and SASS being the two main ones
08:29:51 <anitsirk> ghada: our front-end devs will be heavily invested in that project with the added bonus that they'll get to know mahara well and can then also support us in the future. :-)
08:30:19 <ghada> sneaky plan!  I love it!
08:30:56 <aarowlaptop> We did discuss some concerns about whether going to a framework like that, would discourage community theme developers by making the development process harder
08:31:26 <aarowlaptop> As in, rather than just writing CSS, you write LESS and then compile it into CSS, which requires running some ruby code
08:31:52 <yuliyabozhko> yep, that's what Moodle does right now
08:31:56 <tobiasz_> can that be done automatically from within Mahara at execution time?
08:32:08 <yuliyabozhko> don't think so...
08:32:11 <aarowlaptop> It'll be done before deployment
08:32:12 <anitsirk> #info We did discuss some concerns about whether going to a framework like that, would discourage community theme developers by making the development process harder.
08:32:34 <aarowlaptop> So for the zipped version of Mahara that you download from Launchpad, it would contain the compiled CSS files
08:32:38 <anitsirk> but then everyone wants "Bootstrap" these days so they'll be more or less used to SASS / the idea of it.
08:32:39 <aarowlaptop> rather than the LESS "source code"
08:33:03 <anitsirk> And there are a number of tools around our front-end devs assured us that would come in handy
08:33:17 <aarowlaptop> if you download Mahara from git... I believe we were still deciding whether the git repo would also contain the compiled CSS, or just the LESS/SASS
08:33:25 <aarowlaptop> there are pluses and minuses to both ways of doing it
08:33:36 <anitsirk> yes. that wasn't decided on yet.
08:33:51 <anitsirk> both Gumby and Bootstrap do SASS these days (Gumby natively).
08:34:01 <anitsirk> and Bootstrap switched to it
08:34:08 <aarowlaptop> so anyway, I did want to try out the process of compiling to CSS with both of them, to see if one is more persnickety than the other. Sadly there is no all-PHP system for compiling these frameworks... yet ;)
08:34:09 <anitsirk> and apparently SASS is better than LESS.
08:34:16 <aarowlaptop> ah right, SASS
08:35:22 <aarowlaptop> It's all just /\b..SS\b/ to me
08:35:36 <aarowlaptop> (regular expression joke)
08:35:45 <anitsirk> #info Switching to a css framework that needs compiling such as Gumby / Bootstrap means that you write SASS and then compile it into CSS. There are tools available to assist with that process.
08:36:07 <anitsirk> #info Decision still needs to be made whether pre-compiled CSS is being shipped in git or not.
08:36:17 <anitsirk> any other questions?
08:36:45 <ghada> nope.
08:36:55 <yuliyabozhko> nope
08:37:06 <anitsirk> Alright then. robertl, you are up next.
08:37:07 <anitsirk> #topic Put a "Copy" button on a copyable page (robertl)
08:37:21 <robertl> ok, One of the small things we plan to add to mahara is a 'copy page' button directly onto the page itself to make copying of pages easier.
08:37:29 <robertl> Has anyone in the community already done suh a thing and if so can they supply their code so that we don't re-invent the wheel.
08:37:35 <robertl> If not do people have any suggestions/thoughts about how the button should work? If so can you please add your thoughts either here or to bug 745418 https://bugs.launchpad.net/mahara/+bug/745418
08:37:46 <anitsirk> #idea One of the small things we plan to add to mahara is a 'copy page' button directly onto the page itself to make copying of pages easier.
08:37:57 <anitsirk> https://bugs.launchpad.net/mahara/+bug/745418 for the idea
08:38:56 <anitsirk> a small change but a major improvement as it will reduce heaps of clicks at once. :-)
08:39:22 <robertl> that's really about it at the moment - want new button - what do people think :)
08:40:25 <anitsirk> robertl did you already create a forum post about it for the people who don't get launchpad mails automatically?
08:40:30 <anitsirk> i'd post it in the open forum
08:40:33 <anitsirk> not the dev one
08:40:47 <robertl> not yet - was planning to do after meeting
08:41:05 <robertl> in case there were ideas from here to add to it
08:41:26 <anitsirk> #action robertl to make forum post in the open discussion forum about the copy button on pages to see if people have other / additional ideas that should be kept in mind.
08:42:05 <robertl> not sure if the copy button should go in footer of page near feedback link or top right near edit page link
08:42:31 <aarowlaptop> I think on the bottom with feedback & report links would make the most sense
08:42:33 <ghada> my opinion: at the top.
08:42:36 <aarowlaptop> lol
08:42:39 <robertl> or somewhere else on the view
08:42:40 <yuliyabozhko> the problem is that if you accidentally click it it will create a page
08:42:41 <anitsirk> so basically i guess: should it be displayed very prominently or less prominently?
08:42:43 <ghada> :)
08:43:10 <ghada> i guess we need to consider how it will look on mobile devices
08:43:23 <aarowlaptop> Ah, and most of the time, you'll see it when the page is in "Display" mode, not "Edit" mode
08:43:24 <ghada> as there's less screen real estate
08:43:38 <anitsirk> and we don't want to clutter the main page for when people view it and it just happens to be copyable
08:43:50 <aarowlaptop> or at least, you will need to be able to see it in Display mode, because you can copy other people's pages
08:43:57 <robertl> so would 'create page' need a confirm? or would that add more clicks back in?
08:43:58 <anitsirk> yes, correct
08:44:05 <aarowlaptop> Yeah, needs a confirm of some kind
08:44:34 <anitsirk> good idea. and we'll need a confirm anyway for when the page is in a collection
08:44:35 <tobiasz_> or a "cancel" button only for the newly created page, that directly deletes it
08:44:50 <aarowlaptop> I think there's already a confirm step when you copy a page the old way?
08:44:58 <anitsirk> but that would have already created artefacts, tobiasz_, i think.
08:45:11 <yuliyabozhko> cancel might not work is a user just closes new page
08:45:24 <anitsirk> aarowlaptop: don't think so. i think you can cancel out of it and it still creates it. but am not sure right now.
08:45:34 <ghada> good point yuliyabozhko
08:45:39 <robertl> there does not appear to be a confirm step at the moment
08:46:13 <robertl> only a step to pick which you want to copy
08:46:42 <aarowlaptop> oh, okay
08:46:46 <ghada> ah, so that's where you would cancel.
08:46:51 <anitsirk> aarowlaptop: there is no cancel button and the page is created even if you don't click "Save". just checked it on 15.04.
08:47:12 <ghada> so, you can't really cancel...
08:47:21 <aarowlaptop> So when you copy it takes you right to the "Edit page" screen?
08:47:23 <yuliyabozhko> no you can't, because page is copied at that point already
08:47:31 <anitsirk> #idea a user should need to confirm the copying of a page / collection so that they don't accidentally copy the pages as they will then also have all the artefacts and would need to delete those manually.
08:47:41 <aarowlaptop> at which point the "cancel" means "Don't make any changes to the page" rather than "don't copy it"
08:48:00 <anitsirk> aarowlaptop: pretty much. you edit title and description first and click save to continue
08:48:17 <aarowlaptop> I suspect once we add the "copy page" link, it will become the main method by which people copy pages
08:48:18 <anitsirk> it's like when creating a page from scratch. there is no cancel button either.
08:49:21 <anitsirk> yes. i suspect though. though you'll still need the standard copy page / collection button i think in case you are looking for a page. unless we show whether a page is copyable on the Shared with me screen.
08:49:38 <aarowlaptop> I'm thinking that going through the old-school "copy a page" screen, or clicking on the new link/button, should trigger the same workflow
08:49:44 <anitsirk> but the "copy page" page is useful as you can preview the collection / page which you can't on "Shared with me"
08:50:07 <aarowlaptop> so I guess it should take you to a page where you confirm/cancel, and you also at that time choose whether to copy the page or the whole collection
08:50:49 <anitsirk> why would you need to go to a new page instead of a dialogue? in contrast to the current "Copy a page" page, you already see the page and thus know what you are copying.
08:51:43 <aarowlaptop> eh, sure, it could be a dialogue
08:52:01 <aarowlaptop> a snazzy wee pop-up JS thing would be better than a confirmation page
08:52:26 <anitsirk> and robertl is good with snazzy wee JS things. :-)
08:52:27 <yuliyabozhko> are pop-ups ok for mobile devices?
08:52:34 <yuliyabozhko> I don't have one :)
08:52:42 <anitsirk> yuliyabozhko: it would need to be one that is compatible
08:52:45 <aarowlaptop> they can be
08:52:57 <anitsirk> and that is also accessible...
08:53:04 <robertl> i'd go with some sweet js thing that works with mobile also
08:53:40 <aarowlaptop> okay
08:53:53 <aarowlaptop> and just leave the old "copy pages" screen as-is for now
08:54:05 <anitsirk> yep.
08:54:20 <yuliyabozhko> yeah, sounds good
08:55:01 <robertl> cool, thanks for your thoughts on this
08:55:31 <anitsirk> i think the bottom would be a good place for it so that it is not too prominent, but still there. and since it's a button, it should be possible for people to move elsewhere on the page and trial a different position in their institution and then feedback.
08:56:57 <anitsirk> shall we move on?
08:57:06 <robertl> lets
08:57:08 <ghada> yep
08:57:11 <anitsirk> #topic Next meeting and chair
08:57:26 <anitsirk> What about 22 January same time?
08:57:28 <anitsirk> It's a thursday?
08:57:51 <anitsirk> about two weeks away from the feature freeze
08:57:57 <yuliyabozhko> yep, that would be good. a week earlier is too close to Wellington Anniversary
08:58:14 <anitsirk> which will be on 19
08:58:32 <ghada> 22nd is good.
08:58:34 <yuliyabozhko> yep :) but someone starts celebrating on Thursday
08:59:01 <anitsirk> tobiasz_: does the 22nd work for you?
08:59:08 <anitsirk> and son?
08:59:11 <anitsirk> and robertl?
08:59:14 <son> good for me too
08:59:21 <tobiasz_> I can't promise for any date beyond the 18th if we stay with the same time. Starting a new job on the 19th of January, but I'll try to join
08:59:22 <robertl> 22nd sounds fine with me
08:59:39 <aarowlaptop> sure
08:59:42 <anitsirk> i guess congratulations, tobiasz_
08:59:51 <tobiasz_> thanks anitsirk :)
08:59:56 <anitsirk> and who wants to chair?
09:00:15 <anitsirk> #info The next mahara dev meeting will take place on 22 January 2015 at 8:00 UTC.
09:00:16 <anitsirk> http://www.timeanddate.com/worldclock/fixedtime.html?msg=40th+Mahara+Developer+Meeting&iso=20150122T08
09:00:41 <robertl> I can chair again
09:01:03 <anitsirk> we've got a winner! thank you very much, robertl
09:01:12 <ghada> thanks robertl.
09:01:20 <anitsirk> #info robertl will chair the 40th Mahara dev meeting on 22 January 2015.
09:01:28 <anitsirk> #topic  Any other business
09:01:37 <anitsirk> anybody? i have a one liner.
09:01:42 <yuliyabozhko> I don't have any
09:01:47 <tobiasz_> me neither
09:01:55 <ghada> me too
09:02:01 <yuliyabozhko> maybe just "have a good X-mas" :D
09:02:10 <anitsirk> thanks, yuliyabozhko
09:02:26 <anitsirk> so here it goes:
09:02:26 <anitsirk> #info Tomorrow is the last day to send through any items for the January newsletter.
09:02:44 <anitsirk> #info Send articles to newsletter@mahara.org
09:03:19 <anitsirk> i don't think robertl had anything else. we had his item as proper sole agenda item.
09:03:32 <robertl> nothing more from me
09:04:01 <anitsirk> then i guess it's happy holidays und einen guten Rutsch ins Jahr 2015!
09:04:18 <yuliyabozhko> thanks for chairing, anitsirk :)
09:04:18 <ghada> thanks for chairing anitsirk.
09:04:25 <anitsirk> sorry, son and ghada. don't know the greetings that you would use
09:04:35 <son> thank anitsirk
09:04:38 <anitsirk> and yuliyabozhko: would need to look them up ;-)
09:04:40 <ghada> happy holidays everyone.
09:04:55 <yuliyabozhko> :)
09:05:00 <anitsirk> #endmeeting