08:05:56 <robertl_> #startmeeting
08:05:56 <maharameet> Meeting started Thu Oct 23 08:05:56 2014 UTC.  The chair is robertl_. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:05:56 <maharameet> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:06:11 <robertl_> Please introduce yourselves
08:06:14 <anitsirk> #info anitsirk is Kristina Hoeppner at Catalyst IT, Wellington, New Zealand
08:06:20 <robertl_> #info robertl_ is Robert Lyon, Catalyst IT, Wellington, NZ
08:06:20 <tobiasz> #info tobiasz is Tobias Zeuch, developer at KIT, Karlsruhe, Germany
08:06:31 <ghada> #info ghada-laptop is Ghada El-Zoghbi at Catalyst, Sydney, Australia
08:06:40 <yuliyabozhko> #info yuliya is Yuliya Bozhko from Totara Learning Solutions, Wellington, NZ
08:06:55 <aarowlaptop> #info aarowlaptop is Aaron G. Wells from Catalyst IT in Wellington NZ
08:07:32 <anitsirk> anzeljg: ?
08:08:08 <anitsirk> robertl_ continue. i think he may have needed to step out into another meeting
08:08:12 <robertl_> Right first topic
08:08:13 <robertl_> #topic Items from last meeting
08:08:23 <anzeljg> #info anzeljg is Gregor Anželj, developer and translator from Gimnazija Bežigrad, Ljubljana, Slovenia
08:08:33 <robertl_> #info Item 1 from last meeting: robertl_ to look into the reviews permissions to see if the change author problem can be avoided and/or update the wiki page with more info
08:08:52 <robertl_> I've updated the info to be (hopefully) a bit clearer about when one should rename the author or what other options one has with regards to the 'invalid author' error.
08:08:57 <robertl_> https://wiki.mahara.org/index.php/Developer_Area/Pushing_Git_Commits#Problems_with_pushing_patches_to_gerrit
08:09:38 <robertl_> if anything needs rewording let me know
08:10:09 <anitsirk> with "maintainer" do you mean someone who has +2 privileges?
08:10:33 <anitsirk> or the person who pushed the patch initially?
08:11:43 <anitsirk> robertl_ ^
08:12:07 <robertl_> ah maintainer is wrong - should read core team - bad copy/paste
08:12:14 <robertl_> I'll fix up
08:12:35 <yuliyabozhko> also, not sure if related, is there still a problem with certificates on Ubuntu where you have to set git sslverify to false?
08:12:56 <yuliyabozhko> I remember that being one of the problems, but it's not permission one
08:14:10 <robertl_> I've not come across a problem after setting git sslverify to false
08:14:29 <aarowlaptop> https still doesn't work with our gerrit
08:14:36 <aarowlaptop> I don't think we ever determined what the exact cause was
08:14:43 <yuliyabozhko> yep, that's true. just wondering if it is mentioned somewhere
08:15:01 <aarowlaptop> We're in the process of upgrading it, but it turns out we need to upgrade the underlying server's OS as well, because it's too old to get the right version of Java
08:15:10 <yuliyabozhko> if it is not necessary, then ignore me :)
08:15:16 <aarowlaptop> ah, gotcha
08:15:34 <robertl_> It will be worth documenting it as a potential issue for pushing patches
08:16:02 <robertl_> I'll add that to the page as well
08:16:17 <tobiasz> I didn't recognize problems with the certificate when pushing, only for fetching patches
08:16:19 <yuliyabozhko> there is a specific error that you get with that issue, but I don't remember which one
08:16:22 <robertl_> #action robertl_ to add info about sslverify
08:17:13 <ghada> I had that issue as well but it's been over a year now so I don't remember the exact details.
08:17:26 <yuliyabozhko> :) everyone fixes it once and then forgets
08:17:36 <robertl_> I'm sure google will help with that :)
08:17:40 <rkabalin> #info  rkabalin Ruslan Kabalin, Lancaster University, UK
08:17:46 <anitsirk> hi rkabalin
08:17:51 <rkabalin> Hello
08:18:01 <robertl_> ok, anymore git/gerrit problems we need to document
08:18:10 <robertl_> hi rkabalin
08:18:25 <yuliyabozhko> not that I am aware of
08:18:32 <robertl_> ok moving on...
08:18:37 <ghada> just a sec...
08:18:38 <tobiasz> robertl_: I think can reproduce that, if you have questions
08:18:51 <ghada> i did have one issue with the sign off not being the last line
08:19:07 <ghada> you do mention it there. but, does it need its own area?
08:19:08 <robertl_> the Invalid Change-Id one?
08:19:46 <ghada> you mention it there but it was quite an obscure error and the problem was that there was no sign-off
08:20:28 <anitsirk> hi tonyjbutler
08:20:29 <robertl_> ah yep, you mean the commit was done without -s
08:20:37 <waa_> people are talking to me
08:20:40 <ghada> yes, that's it robertl_
08:20:46 <tonyjbutler> hi everyone, sorry I'm late.
08:20:48 <anitsirk> hi waa_ yep. :-)
08:21:02 <ghada> hi tonyjbutler, waa_
08:21:04 <robertl_> ok will update the info about that as well
08:21:12 <ghada> ok. thanks.
08:21:29 <robertl_> #action robertl_ to improve the documents about needing to sign-off a patch
08:21:52 <robertl_> ok next item is
08:21:54 <robertl_> #info Item 2 from last meeting: robertl_ to write his first mahara newsletter article on an upcoming 1.11 feature, the "artefact feedback on page" one funded by New York Institute of Technology
08:22:05 <robertl_> I did write a small article titled "Artefact feedback display on a page" -> https://mahara.org/newsletter so that's done
08:22:11 <anitsirk> :-)
08:22:33 <robertl_> hopefully every read the newsletter and were happy :)
08:22:54 <robertl_> so onto the next topic
08:22:56 <robertl_> #topic Mahara 1.10 release (Kristina)
08:22:59 <anitsirk> #info We released Mahara 1.10 on Tuesday. Congrats to everyone who was involved.
08:23:00 <anitsirk> https://www.freesound.org/people/ultradust/sounds/166923/ let the champagne flow freely.
08:23:25 <robertl_> yay for 1.10!
08:23:43 <yuliyabozhko> :D
08:23:59 <ghada> good effort everyone!
08:24:22 <rkabalin> Did you actually had a champagne in the office on release day? ;)
08:24:50 <anitsirk> rkabalin: nope. it turned out to be uneventful with prepping for the releases of 1.7 to 1.9
08:24:53 <aarowlaptop> We'll have some tequila in its honor tomorrow
08:24:58 <rkabalin> :D
08:25:32 <aarowlaptop> usually we keep the booze out of the office until after 4pm on Friday ;)
08:25:42 <yuliyabozhko> damn, and I am not drinking till Nov 2nd >.<
08:25:45 <yuliyabozhko> so not fair
08:26:32 <anitsirk> BTW: big thanks to waa_ for fixing the chanops in #mahara so that aarow and robertl are ops now as well.
08:26:33 <ghada> i'm sure they'll drink for you yuliyabozhko.
08:26:44 <rkabalin> 1.10 is a great job anyway, thanks guys
08:27:38 <robertl_> If you notice anything broken/regressed please let us know
08:28:08 <aarowlaptop> I've noticed a couple of things. ;)
08:28:14 <aarowlaptop> But they're filed in the bug tracker
08:28:15 <ghada> anitsirk: are the tester going to keep testing?
08:28:17 * robertl_ too
08:28:31 <anitsirk> ghada: we are getting closer to running our first behat tests.
08:28:44 <ghada> that's great news.
08:28:49 <anitsirk> once a bit more work has been done, they can start cranking out behat tests. :-)
08:28:55 <yuliyabozhko> yeah, I heard that too. that's awesome!
08:29:34 <rkabalin> yep, behat sounds good
08:29:41 <anitsirk> #info Behat test infrastructure for automated functional testing is getting closer to being used for running tests. soon we'll be able to integrate them into mahara.
08:30:11 <anitsirk> probably more on that next time
08:30:20 <robertl_> we had a wonderful discussion about links vs buttons today due to behat
08:30:45 <ghada> "wonderful" in quotes? ;-)
08:31:17 <robertl_> interesting about what a link vs a button "means" to the end user
08:31:40 <anitsirk> i.e. a technical end user who may distinguish between them ;-)
08:31:43 <aarowlaptop> We have a lot of buttons that we style as links and vice versa
08:31:56 <robertl_> about destructive vs non-destructive results on clicking them
08:32:39 <ghada> and the conclusion  - which is the way to go?
08:33:09 <yuliyabozhko> I don't think there is a definite right way...
08:33:09 <robertl_> I'm not sure there was a conclusion
08:33:14 <yuliyabozhko> :)
08:33:24 <aarowlaptop> Yeah
08:33:26 <anitsirk> The Behat coding will be changed to account for both without having the testers needing to know whether it's a button or a link.
08:33:50 <aarowlaptop> Well, Aaron Barnes said he'd look into writing a Behat verb that will auto-detect whether the desired element is a button or a link
08:33:57 <aarowlaptop> currently there are separate verbs for each
08:34:16 <aarowlaptop> which can be tricky for less-technical testers when our buttons look like links
08:34:26 <aarowlaptop> er, links look like buttons, I mean
08:35:01 <ghada> if it's confused you aarowlaptop, there's no hope for the others!:)
08:35:18 <aarowlaptop> to me it's all just hypertext ;)
08:35:58 <robertl_> shall we move on?
08:36:07 <ghada> yep.
08:36:14 <robertl_> #topic Proposal: Change Mahara's version numbers (Kristina)
08:36:15 <yuliyabozhko> yeah
08:36:20 <anitsirk> We've been discussing Mahara's versioning at Catalyst. I find that we've been on Mahara 1 for a very long time though we've made some huge changes over the years. Some even say we should have moved to version 2 latest last year.
08:36:20 <anitsirk> #info I don't think our current version numbering system is great. It doesn't give our users much insight into how far Mahara has come over the years. In contrast, it can be tricky to remember when a certain version was released and until when one is supported.
08:36:20 <anitsirk> #idea Therefore, I propose to change the versioning system to something more user friendly. I quite like the "date of release" numbering and in particular Ubuntu's way of having the year first and then the month in which a release was made, e.g. 15.04, 15.10. It shows you very quickly when a release was made, but doesn't judge how big or small a leap was made.
08:36:20 <anitsirk> Since we know that new releases always contain new features and that you may not be able to upgrade without difficulty, we could go over to something that may make more sense to users rather than developers. Since we haven't been using our numbering system strictly, e.g. in the sense that SemVer does, it doesn't actually mean anything.
08:36:20 <anitsirk> #link http://en.wikipedia.org/wiki/Software_versioning for some short background reading on numbering systems.
08:36:20 <anitsirk> There is no one way of expressing release versions of a software, and I don't think that we do ourselves any good with continuing to stay on version 1. Instead of just dropping the 1 or going to 2 which may be confusing as users might expect a huge change, I suggest we go over to something that suggests less quantity, but rather contains some qualities that'll help us to easily determine when we made a specific release.
08:36:20 <anitsirk> Security patches for supported version would still be the third number, e.g. 15.04.1 etc.
08:36:21 <anitsirk> ..
08:38:11 <yuliyabozhko> offtopic, it reminds me that Moodle has plans for Moodle 3 already :)
08:38:51 <rkabalin> To be honest, I have never seen a piece of software that would use year as the major version number
08:38:53 <aarowlaptop> Yeah, Moodle's just decided to go from 2.9 to 3.0
08:39:18 <anitsirk> rkabalin: ubuntu and apparently wine
08:39:31 <aarowlaptop> Ubuntu's the big one I'm aware of
08:39:49 <aarowlaptop> (We're very Ubuntu-centric at Catalyst)
08:39:49 <yuliyabozhko> should embrace Windows' approach 1,2,3....8,10 :D
08:39:50 <ghada> anitsirk: i think the year.month is fine.  I do think that we should have jumped from 1.9 to 2.0.
08:40:07 <tonyjbutler> I think it makes perfect sense
08:40:30 <rkabalin> I think version should be sequential thing, there might be jumps in major number, e.g. from 1.12 to 2, but not from 10.01 to 12.01
08:40:38 <anitsirk> ghada: i think we discussed right after 1.6 that we might have jumped but definitely right around 1.8. 1.9 to 1.10 wasn't such a huge change in many ways compared to earlier releases.
08:41:57 <ghada> yes, not about the huge change.  It's just odd to 2 digits after the major release - when it's only version 1.
08:42:03 <anitsirk> but why jump from 1.12 to 2? when do you decide that or do you just continue with 1.13? it's very arbitrary for mahara at the moment for not having already jumped to 2. i think it's best to avoid all that with a different approach that is more user friendly.
08:42:40 <ghada> i think that's a good idea going forward.
08:42:58 <ghada> it makes it easy to calculate how much longer you will have support on a particular version.
08:43:22 <tonyjbutler> I don't really understand the Moodle logic of going to 3.0 without a major change.
08:43:27 <anitsirk> that for one and it also tells us when we released a specific version
08:43:36 <aarowlaptop> yeah, and since we do major releases based on 6-months, rather than on reaching a certain amount of change, having a date-based version number seems more honest as well
08:43:38 <ghada> yes.
08:44:11 <ghada> I'm for it.
08:44:13 <yuliyabozhko> agree
08:44:17 <rkabalin> -1
08:44:18 <ghada> +1
08:44:24 <anitsirk> everyone understands something different for the "typical" numbering system of 1.1 to 1.2 to 2.0 etc. but in fact, everyone interprets it differently so that there is no easy consensus when using that scheme
08:44:55 <tonyjbutler> +1
08:45:35 * rkabalin too conservative about version number
08:45:46 <anitsirk> ;-)
08:45:52 <robertl_> I can imagine there will be some pain switching numbering systems - but I feel a switch is needed
08:46:04 <robertl_> and the date based one sounds good to me
08:46:06 <robertl_> +1
08:46:10 <ghada> tonyjbutler: I think Moodle may be looking at it from the maturity of the product.  It's been around for a while and should be greater than "2".
08:46:28 <tonyjbutler> ghada: fair point
08:47:29 <ghada> anitsirk: are we going to make a decision tonight about the version numbering?  Or, will this go out to the community for feedback?
08:48:05 <yuliyabozhko> that would be a good idea, actually
08:48:53 <anitsirk> i don't know if it's such a big deal to ask everyone.
08:48:58 <robertl_> I wonder if it would be worth having the version number in a mahara instance be a link to a mahara wiki page explaining our thought on the numbering
08:49:30 <tonyjbutler> Good idea
08:49:36 <ghada> This type of change can divide a community...
08:49:44 <ghada> :)
08:49:46 <anitsirk> the numbering of releases is decided by the release team who could change a version number at the last minute (if going by SemVer etc.).
08:49:47 <anzeljg> I would expect additional info about particular release when clicking upon version number
08:49:53 <robertl_> cause if we go from 1.10 -> 15.04 in one jump it'll be confusing for people
08:50:20 <anitsirk> i'm happy to make a bunch of announcements and say we are switching and then see if there is a big confusion or not.
08:50:25 <rkabalin> it could be 15.04 (1.11)
08:50:50 <ghada> anitsirk: yes, I agree. I would prefer to make the decision and go forward.
08:50:51 <anitsirk> since aarow already set up the 1.11 branch, we could leave it at that for the time being but see how people feel with calling it 15.04.
08:50:56 <rkabalin> to make it more confusing ))
08:51:13 <anitsirk> i don't think we should keep a second (internal) version number. that would really confuse things.
08:51:31 <anitsirk> we will still have the build number to identify things down to a tea as for DB changes.
08:51:33 <rkabalin> for the first release only may be
08:51:35 <tonyjbutler> How about a code name too ;-)
08:51:49 <anitsirk> tonyjbutler: you must have been talking to aarowlaptop :-D
08:51:49 <aarowlaptop> actually there's not a 1.11 branch yet
08:51:51 <aarowlaptop> 1.11 is on master
08:52:12 <anzeljg> +1 for code name :)
08:52:21 <anitsirk> ha. even easier. i thought you had said today that there is already a branch. or maybe i just misunderstood that you meant the milestone in launchpad
08:52:26 <ghada> oh no! Not code names!!!
08:52:48 <anzeljg> the first code name should be "kiwi"
08:52:51 <anzeljg> :)
08:52:54 <aarowlaptop> I was just saying, the branch names will be slightly longer. 15.04_STABLE instead of 1.11_STABLE :)
08:53:01 <anzeljg> k is eleventh letter... so 1.11
08:53:24 <aarowlaptop> I personally don't like code names because I can never remember what version number they relate to...
08:53:38 <tonyjbutler> anzeljg is really running with this :-)
08:53:39 <ghada> aarowlaptop: me too.
08:54:15 <anitsirk> I think Mahara had code names way back in the very beginning.
08:54:34 <yuliyabozhko> we have them in Totara, but they are only for devs to have fun :P
08:54:38 <anitsirk> but yeah, I find them too confusing as well. I know my ubuntu by version number, but can never remember its code name.
08:54:50 <aarowlaptop> Some people like nicknames. I'm sure Evonne would appreciate the chance to draw up more mascot images. ;)
08:55:19 <robertl_> I'm sure she would -  in all that downtime she has
08:55:24 <ghada> of fruit - just not apples.
08:55:29 <anitsirk> lol
08:55:33 <aarowlaptop> but yeah, I find them confusing
08:56:09 <tobiasz> I think, a 6month cycle is too short for code names, they would change too often
08:56:10 <ghada> ok, have we come to a decision?
08:56:33 <ghada> tobiasz: agree.
08:56:35 <anitsirk> Ok. I'll write something up to explain the change in the numbering scheme and then post it wherever i find (please feel free to repost etc.). usually, i get most user responses on Facebook. :-)
08:56:59 <yuliyabozhko> there is Mahara group on FB? =-O
08:57:09 <anitsirk> yuliyabozhko: heaps
08:57:31 <yuliyabozhko> ha, good to know :)
08:57:39 <tobiasz> are they about mahara the eportfolio system? ;)
08:57:41 <anitsirk> the mug group, the japanes group, moodle-mahara-meetup, the german group, the czech group, maharamoot de, and then those that i'm not even a member of
08:57:48 <anitsirk> tobiasz: yep
08:58:11 <anitsirk> i guess, robertl_, a second action item for me is to update our wiki with all the links to these groups.
08:58:25 <anitsirk> and there is a linkedin group, a google+ group, a facebook page...
08:58:36 <ghada> no twitter!!
08:58:36 <anitsirk> robertl_: can you please action my two items?
08:58:39 <yuliyabozhko> I am on linkedin one
08:58:45 <anitsirk> ghada: twitter goes without saying ;-)
08:58:45 <ghada> ??
08:58:50 <anzeljg> twitter hastag #mahara
08:58:53 <ghada> of course!
08:58:55 <robertl_> #action kristina to update wiki with links to mahara groups
08:58:56 <anitsirk> and @maharaproject
08:59:13 <anitsirk> robertl_ and the other one about the release numbers
08:59:19 <robertl_> #action kristina to write something to explain the release numbers
08:59:39 <anitsirk> ghada: i couldn't post links on twitter for the second day now. it thinks i may be a bot. :-(
08:59:55 <ghada> lol
08:59:58 <anzeljg> lol
09:00:06 <anitsirk> note to self: don't send too many release tweets
09:00:22 <anitsirk> with the same url. i think that was the problem.
09:00:24 <ghada> anitsirk: you really made me laugh out loud here...
09:00:48 <anitsirk> mhh. was the image good or bad? ;-)
09:01:00 <ghada> it was GREAT!
09:01:26 <robertl_> ok, we good to move on?
09:01:32 <anitsirk> ghada: i'll ask you about it tomorrow if i don't forget. ;-)
09:01:37 <anitsirk> yep, robertl_ fine by me
09:01:39 <ghada> yes please.
09:01:48 <robertl_> #topic Mahara 1.11/15.04 - what's on the roadmap? (Robert)
09:01:56 <robertl_> Looking at https://wiki.mahara.org/index.php/Developer_Area/Specifications_in_Development
09:02:04 <anitsirk> https://wiki.mahara.org/index.php/Developer_Area/Specifications_in_Development
09:02:09 <robertl_> There is a swag of things we would like to include into the next release or develop over the next few cycles - ranging from small pieces of work to some very large untertakings.
09:02:25 <robertl_> This list came from a brainstorm we had here at Catalyst and is in no way a complete list nor does it meant all things have to be built but rather a list of things that we felt were needed in Mahara.
09:02:39 <robertl_> If anyone has built/begin development for any of these features and would like to give back to core they will be most appreciated.
09:02:49 <anitsirk> #info the "Specifications in Development" page on the wiki contains, as robertl_ says, "a swag of things we would like to include into the next release or develop over the next few cycles - ranging from small pieces of work to some very large untertakings."
09:02:49 <robertl_> If you have ideas of what could also be added to the list - now is a good time to discuss it.
09:04:13 <anitsirk> some of the larger things would most likely need to be split up over several releases. but we need to start somewhere with the specs so we know where we'll be heading.
09:05:09 <anzeljg> will we support html5 placeholder attribute in pieform elements?
09:05:26 <anitsirk> #info the ideas you see in the list are a compilation of our ideas as well as ideas that we've gathered over the last months including Mahara Hui, Mahara UK, and the padlet https://mahara.org/view/view.php?id=120961
09:06:07 <anitsirk> we haven't listed everything as Launchpad is for that. so we'll also add the items not in the table to Launchpad as wishlist items so we have them all in a central space.
09:06:52 <yuliyabozhko> if there are bugs open in Launchpad, would be good to add links to the table?
09:06:56 <robertl_> placeholder is not supported by IE9 I think
09:07:04 <tobiasz> would you link the wiki entries to the launchpad entries?
09:07:15 <anitsirk> #and BTW, these items are just from the Catalyst team (plus community). everyone is welcome to propose other things as well to get into the April release.
09:07:16 <ghada> are we going to drop support for some browser versions - older ones?
09:07:38 <yuliyabozhko> well, IE9 is not that old
09:07:43 <robertl_> we tend to do latest 3 IE versions
09:07:43 <anitsirk> tobiasz: yes, if we have specs on the wiki, they'll be posted on launchpad as well and vice versa
09:07:46 <ghada> no but 6
09:07:58 <robertl_> which IE9 is one of them
09:08:05 <yuliyabozhko> I think at this point IE6 exists only in China :P
09:08:07 <ghada> ok.
09:08:07 <tobiasz> anitsirk: ok, great
09:08:10 <anitsirk> IE6 is long out of support for us (in contrast to some other projects that still need to support it)
09:08:31 <anitsirk> yuliyabozhko: and some gov departments apparently
09:08:33 <robertl_> we have only contempt for IE6
09:09:10 <ghada> robertl_: agreed.
09:09:20 <ghada> good to know it's no longer supported.
09:09:30 <rkabalin> IE6 is quite popular in the UK ))
09:09:33 <ghada> what about php versions?
09:09:46 <ghada> are we doing namespaces?
09:10:19 <ghada> i know elasticsearch is using namespaces.  Do we want to head in that direction?
09:10:31 <yuliyabozhko> php 5.3 supports them
09:11:01 <aarowlaptop> at the moment we were planning to stick with PHP 5.3+ support, and not adding namespaces
09:11:11 <ghada> rkabalin: that's disturbing news.
09:11:30 <ghada> arrowlaptop: ok. just wanted to know the direction.
09:12:37 <tonyjbutler> @rkabalin: are you sure?
09:13:32 <rkabalin> It is a government thing, NHS is iusing it if I am not mistaken, that is more than 1M PCs
09:14:07 <tobiasz> are they using mahara in governmental context?
09:14:29 <rkabalin> Not in Mahara context, I do not think so
09:14:31 <tonyjbutler> @rkabalin: Wow! That certainly is disturbing.
09:14:38 <yuliyabozhko> NHS constantly reporting SCORM bugs on IE7 to us >.<
09:14:40 <rkabalin> but we had issues with Moodle themes
09:14:50 <ghada> arrowlaptop:  since we're changing the version numbers, might be interesting to make some coding changes?
09:15:17 <yuliyabozhko> like what?
09:15:25 <yuliyabozhko> if else brackets!!!! :D
09:15:50 <yuliyabozhko> I failed some Moodle patches because I changed my style to Mahara accidentally :-X
09:15:52 <robertl_> no more mochikit!!! please, please
09:16:05 <tobiasz> replace pieforms? ^^
09:16:07 <yuliyabozhko> +1 robertl
09:16:42 <yuliyabozhko> we were looking for replacement of pieforms too. but couldn't come up with a good alternative that can be switched to painlessly
09:16:43 <ghada> don't know, just something to think about.
09:17:20 <tobiasz> yuliyabozhko: they are like everywhere
09:17:29 <anzeljg> Going through "Specifications in development" is it possible in terms of easier Mahara setup to not only create a config file generator but also the database generator for the users that are on shared hosting?
09:18:00 <aarowlaptop> I'm game for big code changes. Although our main goal with this release is to make dramatic improvements to the front-end rather than the back-end
09:18:05 <rkabalin> well, my knowledge might be a bit outdated regarding NHS and IE6, it clearly was an issue two years ago, but they are still the oldest version users anyway, perhaps IE7
09:18:18 <ghada> anzeljg: that's a good idea.
09:18:27 <anitsirk> bitnami actually just released their 1.10 version as easy installer of mahara. have to check if they already posted the links.
09:18:50 <aarowlaptop> Yeah, I'd like to do a config generator for this release
09:18:53 <robertl_> aarowlaptop: true, it's more important to make frontend more usable
09:19:00 <aarowlaptop> I guess it could create the DB as well
09:20:17 <ghada> well,  that's a good list to start with.
09:20:37 <ghada> it's good to have a list/target.
09:20:53 <robertl_> sure is
09:20:55 <ghada> we can all work towards
09:21:01 <anitsirk> a couple of them are dead easy. so maybe even something for robertl_ and aquaman to look into with the open source academy in january :-)
09:21:26 <robertl_> true - get the kids to do it for us :)
09:21:32 <yuliyabozhko> haha
09:22:09 <robertl_> so yeah - please don't rush off and do the low hanging fruit ones
09:22:10 <anitsirk> #idea anzeljg: create a database generator (for users that are on shared hosting)
09:22:31 <anitsirk> i.e. the site logo and the drop-down navigation in particulat i would think
09:23:35 <anitsirk> and we'll also circulate this list in the forums.
09:23:54 <anitsirk> shall we move on?
09:24:01 <robertl_> lets
09:24:14 <robertl_> now the fun part ...
09:24:16 <robertl_> #topic Next meeting and chair
09:24:43 <yuliyabozhko> maybe date first?
09:24:58 <robertl_> yep
09:25:41 <robertl_> say a date in last week of nov?
09:26:11 <anitsirk> yep. would work for me
09:26:19 <robertl_> maybe thursday again, 27th?
09:26:19 <anitsirk> shall we stick to thursday, i.e. 27 november?
09:26:26 <anzeljg_> last week of nov would work
09:26:44 <yuliyabozhko> I might not be able to make to that one :( doing Queen Charlotte Track I think
09:26:47 <ghada> yes, that works.
09:26:50 <yuliyabozhko> but I will have a look
09:27:15 <robertl_> how about the others? 27th ok?
09:27:15 <tobiasz> 27th of november is fine with me
09:28:24 <yuliyabozhko> it's fine for everyone, so I guess so :)
09:28:53 <robertl_> kristina - how do you do the worldclock link magic?
09:29:14 <anitsirk> robertl_ : sure. when you give me a time?
09:29:19 <anitsirk> 8:00 UTC?
09:29:38 <robertl_> that sounds good to me - seems to get a good crowd in
09:30:06 <anitsirk> http://www.timeanddate.com/worldclock/fixedtime.html?msg=38th+Mahara+Developer+Meeting&iso=20141127T08
09:30:15 <yuliyabozhko> December meeting might be under a Christmas tree ;)
09:30:41 <robertl_> we'll work that out next meeting ;)
09:30:42 <anitsirk> with jandals as tree ornaments ;-)
09:30:45 <rkabalin> yuliyabozhko in the forest ))
09:30:46 <ghada> that's Thanksgiving
09:31:03 <ghada> Nov 27.
09:31:05 <anitsirk> ghada: bugger. aarowlaptop: are you going to be eating turkey that day?
09:31:35 <aarowlaptop> probably not
09:31:54 <aarowlaptop> it's so hard to find turkey in New Zealand
09:32:21 <yuliyabozhko> hard to find *cheap* turkey
09:32:31 <robertl_> I was in a car accident once - hit  a turkey
09:32:32 <anitsirk> ghada: do you want to take off that day?
09:32:44 <ghada> antisirk: no, it's ok.
09:33:04 <ghada> i was just thought it was an interesting coincidence.
09:33:15 <anitsirk> so who wants to be the chair then?
09:33:24 <ghada> anyway, we celebrate it on the weekend. too hard during the week.
09:33:33 <anitsirk> good choice :-)
09:33:40 <rkabalin> I can chair
09:33:54 <ghada> rkabalin: woohoo!!
09:34:05 <robertl_> chair sold to rkabalin
09:34:09 <anitsirk> #info rkabalin to chair the next mahara dev meeting on 27 November 2014 at 8:00 UTC: http://www.timeanddate.com/worldclock/fixedtime.html?msg=38th+Mahara+Developer+Meeting&iso=20141127T08
09:34:14 <anitsirk> thank you, rkabalin
09:34:21 <rkabalin> you guys did it last few times
09:34:34 <robertl_> so that brings it onto ...
09:34:35 <robertl_> #topic Any other business
09:34:54 <yuliyabozhko> I don't have any
09:35:00 <anitsirk> nope
09:35:01 <rkabalin> no
09:35:04 <ghada> no
09:35:08 <robertl_> none for me
09:35:33 <anitsirk> tobiasz, tonyjbutler and aarowlaptop: any other business from you?
09:35:44 <tonyjbutler_> No
09:35:44 <tobiasz> nope, thanks
09:35:58 <aarowlaptop> nope
09:36:05 <robertl_> ... bringing the hammer down ...
09:36:06 <robertl_> #endmeeting