#mahara-dev Meeting

Meeting started by rkabalin at 20:03:47 UTC (full logs).

Meeting summary

    1. anitsirk is Kristina Hoeppner, Catalyst IT, Wellington, NZ (anitsirk, 20:04:12)
    2. Andrew Nicols, Lancaster University, UK (dobedobedoh, 20:04:28)
    3. Ruslan Kabalin - Lancaster University, UK (rkabalin, 20:04:33)
    4. richardm Richard Mansfield, Catalyst IT (richardm, 20:04:37)
    5. is Melissa Draper, Catalyst IT (elky, 20:04:48)

  1. Items from last meeting (rkabalin, 20:05:29)
    1. 3. melissa/elky to publish a dev forum post about the 6 monthly release cycle (rkabalin, 20:06:55)
    2. https://mahara.org/interaction/forum/topic.php?id=4547 (anitsirk, 20:08:12)
    3. AGREED: Mahara release cycle is set to fixed period of 6 month (rkabalin, 20:24:25)
    4. the first release in the new shedule will be in October (rkabalin, 20:25:12)
    5. AGREED: minor point release after security fix or major bug (rkabalin, 20:32:43)

  2. Discuss/decide on style guidelines for CSS https://reviews.mahara.org/#/c/1098/ Melissa/Hugh (rkabalin, 20:35:09)
  3. Google Apps block in Mahara 1.6? cf. https://mahara.org/interaction/forum/topic.php?id=4641 (Kristina) (rkabalin, 20:37:31)
    1. : the gist: i was wondering if we still need the google apps block in 1.6 now that we have the safeiframe feature and the admin interface to easily add any iframe base url (1.6 feature). (anitsirk, 20:38:35)
    2. is Hugh Davenport, Catalyst IT Ltd (hughdavenport, 20:49:26)
    3. ACTION: elky look into removing google apps block from the core (rkabalin, 20:51:21)
    4. https://developers.google.com/safe-browsing/ (elky, 20:57:50)
    5. ACTION: safeiframe xss vulnerabilities discussion move to next meeting (rkabalin, 21:00:05)

  4. Continued: Discuss/decide on style guidelines for CSS https://reviews.mahara.org/#/c/1098/ Melissa/Hugh (rkabalin, 21:00:51)
    1. we need volunteers to edit the code guidelines wiki page for other langs (rkabalin, 21:05:54)
    2. http://en.wikipedia.org/wiki/Rules_lawyer (elky, 21:07:48)
    3. ACTION: elky/hughdavenport update code guidelines and extend it to other than php (rkabalin, 21:09:56)

  5. hughdavenport: Discuss how long we support releases for and/or the posibility of a LTS release (rkabalin, 21:10:47)
    1. discussing possibility to support release for 2 years, will be phased in from next release. Re. existing, we drop 1.4 when 1.6 comes, 1.5 stays 2 years, 1.6 2 years, etc, optinally 1.5 can stay for 18 months (rkabalin, 21:21:44)
    2. AGREED: support 3 versions back, 1.4 will go with 1.6, 1.5 will go with 1.8, 16 with 1.9 (rkabalin, 21:30:30)

  6. next meeting / Chair (rkabalin, 21:30:52)
    1. AGREED: next dev meeting Tuesday, July 31st, 7:30 UTC (rkabalin, 21:41:11)
    2. http://www.timeanddate.com/worldclock/fixedtime.html?iso=20120731T0730 (hughdavenport, 21:42:52)
    3. AGREED: elky chair the next meeting (to be safe) (rkabalin, 21:46:09)

  7. any other business (rkabalin, 21:46:28)


Meeting ended at 21:53:18 UTC (full logs).

Action items

  1. elky look into removing google apps block from the core
  2. safeiframe xss vulnerabilities discussion move to next meeting
  3. elky/hughdavenport update code guidelines and extend it to other than php


Action items, by person

  1. elky
    1. elky look into removing google apps block from the core
    2. elky/hughdavenport update code guidelines and extend it to other than php
  2. hughdavenport
    1. elky/hughdavenport update code guidelines and extend it to other than php


People present (lines said)

  1. elky (126)
  2. rkabalin (109)
  3. anitsirk (79)
  4. hughdavenport (68)
  5. dobedobedoh (37)
  6. richardm (12)
  7. maharameet (3)


Generated by MeetBot 0.1.4.