#mahara-dev Meeting

Meeting started by elky at 07:37:42 UTC (full logs).

Meeting summary

    1. anzeljg is Gregor An�elj, Gimnazija Be�igrad, Ljubljana, Slovenia (anzeljg, 07:38:04)
    2. anitsirk is Kristina Hoeppner, Catalyst IT, NZ (anitsirk, 07:38:15)
    3. sonn Son Nguyen, Catalyst IT, NZ (sonn1, 07:38:27)
    4. rkabalin_ Ruslan Kabalin - Lancaster University, UK (rkabalin_, 07:38:27)
    5. elky is melissa draper, catalyst IT, NZ (elky, 07:38:31)
    6. dobedobedoh is Andrew Nicols, Lancaster University, UK (dobedobedoh, 07:38:36)
    7. richardm Richard Mansfield, Catalyst IT (richardm, 07:38:48)
    8. hughdavenport` is Hugh Davenport, Catalyst IT, NZ (hughdavenport`, 07:38:49)
    9. alanmc is Alan McNatty, Catalyst IT, NZ (alanmc, 07:38:50)
    10. lamiette is Stacey Walker, Catalyst IT Europe (lamiette, 07:39:22)

  1. Items from last meeting: anitsirk to update the roadmap (elky, 07:39:58)
    1. the update of the roadmap files with links to the blueprints is done (anitsirk, 07:40:29)
    2. Agenda: https://wiki.mahara.org/index.php/Developer_Area/Developer_Meetings/2012-05-23 (elky, 07:40:50)

  2. Items from last meeting: dajan to raise appropriate issues in the tracker (elky, 07:42:34)
  3. anzeljg To put together a quick wiki page with some information (possibly code too) (elky, 07:43:48)
  4. Mahara reviewer applications (elky, 07:45:15)
    1. https://wiki.mahara.org/index.php/User:Alanmc (alanmc, 07:46:10)
    2. http://meetbot.mylittleproject.co.uk/mahara-dev/2011/mahara-dev.2011-06-29-19.35.log.html#l-310 -< that's what we did last time (anitsirk, 07:46:51)
    3. https://wiki.mahara.org/index.php/User:Alanmc (elky, 07:47:15)
    4. : alanmc reviewer application (anitsirk, 07:47:40)
    5. : sonn1 reviewer application (anitsirk, 07:47:52)
    6. : elky reviewer application (anitsirk, 07:48:00)
    7. https://wiki.mahara.org/index.php/User:Ngson2000 (sonn1, 07:48:16)
    8. https://wiki.mahara.org/index.php/User:Melissadraper (elky, 07:48:45)
    9. : dobedobedoh said last time "consensus decision rules, with those at the meeting entitled to vote" (anitsirk, 07:51:14)
    10. https://wiki.mahara.org/index.php/Developer_Area/Code_Review actually details the "Becoming a Reviewer" (anitsirk, 07:52:32)
    11. IDEA: from reviewer applicant alanmc for new mahara feature: review theming/layout to work on wider arrange of devices (anitsirk, 08:03:14)
    12. IDEA: from reviewer applicatant sonn1 (and richardm) for new mahara feature: support for translation of user content and homepage content (anitsirk, 08:03:59)
    13. IDEA: from reviewer applicant elky for new mahara feature: improvements to accessibility, e.g. vision-impaired friendly theming and settings that help users adjust to their specific accomodations (anitsirk, 08:04:34)

  5. Discuss/decide on style guidelines for CSS https://reviews.mahara.org/#/c/1098/ Melissa/Hugh (elky, 08:12:27)
    1. http://csslint.net/ (anzeljg, 08:15:03)
    2. CSS has most often tabs and was replaced with spaces as per coding guidelines. what shall be done about it in the future? (anitsirk, 08:15:31)
    3. IDEA: : run css through cssoptimiser (dobedobedoh) (anitsirk, 08:15:46)
    4. IDEA: : make a hook in jenkins (hughdavenport`) (anitsirk, 08:16:01)
    5. IDEA: make it part of skins (dobedobedoh) (elky, 08:17:35)
    6. IDEA: run an optimizer over what we have, then stick to ONE style from here on out (hugh) (elky, 08:18:18)
    7. cssoptimiser is a minifier (elky, 08:19:16)
    8. lint/ tab-spacing is for readability (elky, 08:20:16)
    9. : minified JavaScript is already shipped for most third-party code (anitsirk, 08:22:35)
    10. moodle has cssoptimisation at request time, and a cssrev for changes (elky, 08:24:23)
    11. new in moodle 2.3, wont be on by default for a while (elky, 08:24:45)
    12. ACTION: will continue css discussion next meeting (elky, 08:28:27)

  6. License compatibility (anzeljg) (elky, 08:28:46)
    1. http://fedoraproject.org/wiki/Licensing:Main#Software_License_List (anzeljg, 08:29:10)
    2. the gnu and fsf pages show a list of licenses, basically most gpl-compatible are compatible with gpl3, except gpl2 iirc (elky, 08:32:46)
    3. ^ said hugh. (elky, 08:32:56)
    4. https://www.gnu.org/licenses/license-list.html#GPLCompatibleLicenses was the link that fmarier had pointed us once in a pizza talk at catalyst (anitsirk, 08:34:14)

  7. Tmirante had an item: Search 2.0 engine plugin possible time schedule request (elky, 08:36:54)
    1. tmirante isn't available, will leave on agenda for next meeting. (elky, 08:37:36)

  8. Next meeting and Chair (elky, 08:38:05)
    1. One month from now is weds 20th (elky, 08:38:34)
    2. 20th clashes with moodlemoot fr (elky, 08:40:11)
    3. Next meeting will be 27th june 2000 UTC (elky, 08:43:19)
    4. rkabalin_ to chair (elky, 08:47:42)

  9. Any Other Business? (elky, 08:48:40)
    1. richardm is leaving catalyst on june 30 :( (elky, 08:49:24)
    2. the next mahara newsletter will be published on 1 July 2012. please submit your stories to newsletter@mahara.org (anitsirk, 08:58:32)
    3. IDEA: from the catalyst team: switch to a 6-monthly release cycle with releases in April and October (anitsirk, 09:01:18)
    4. ACTION: elky to write up a post for the developer forum (elky, 09:01:47)
    5. : that release cycle proposal received positive nods from meeting attendees (anitsirk, 09:03:42)
    6. Alanmc wants more interest in the mobile api stuff (elky, 09:07:22)
    7. ACTION: alanmc to write forum post about mobile api stuff (elky, 09:07:37)
    8. keen to find out from those hosting Mahara sites if the authentication mechanism is understood and OK (elky, 09:08:18)


Meeting ended at 09:09:08 UTC (full logs).

Action items

  1. will continue css discussion next meeting
  2. elky to write up a post for the developer forum
  3. alanmc to write forum post about mobile api stuff


Action items, by person

  1. alanmc
    1. alanmc to write forum post about mobile api stuff
  2. elky
    1. elky to write up a post for the developer forum


People present (lines said)

  1. anitsirk (102)
  2. elky (93)
  3. dobedobedoh (51)
  4. anzeljg (48)
  5. alanmc (37)
  6. richardm (34)
  7. hughdavenport` (33)
  8. rkabalin_ (28)
  9. sonn1 (19)
  10. lamiette (8)
  11. maharameet (3)


Generated by MeetBot 0.1.4.