#mahara-dev Meeting

Meeting started by anitsirk at 07:41:27 UTC (full logs).

Meeting summary

    1. anitsirk = Kristina Hoeppner, Catalyst IT, Wellington, NZ (anitsirk, 07:41:49)
    2. anzeljg is Gregor Anzelj, translator and developer, Ljubljana, Slovenia (anzeljg, 07:41:51)
    3. Andrew Nicols - Lancaster University (dobedobedoh, 07:41:52)
    4. fmarier is Francois Marier (fmarier, 07:41:58)
    5. richardm is Richard Mansfield, Catalyst IT, Wellington, New Zealand (richardm, 07:42:04)
    6. Ruslan Kabalin - Lancaster University, UK (rkabalin_, 07:42:09)
    7. elky is melissa draper, Catalyst IT (elky, 07:42:24)

  1. Items from last meeting (anitsirk, 07:42:44)
    1. all action items were related to checking bugs before freezing mahara 1.5. thus nothing to report. (anitsirk, 07:43:08)

  2. Triggers in Mahara (Richard) (anitsirk, 07:43:20)
    1. mahara has a function to create db triggers if needed (anitsirk, 07:45:22)
    2. If a trigger needs to be changed, you drop and recreate (anitsirk, 07:50:15)
    3. the db_drop_trigger function would need to be used for that (anitsirk, 07:50:48)

  3. Upstream status of Dwoo (Francois) (anitsirk, 07:51:56)
    1. https://twitter.com/#!/seldaek/status/167546484865241088 triggered the topic (anitsirk, 07:51:57)
    2. https://twitter.com/#!/seldaek/status/167546484865241088 (anitsirk, 07:51:58)
    3. Mjollnir` was looking for a new maintainer for the dwoo debian package (anitsirk, 07:53:41)
    4. HELP: : if dwoo is not going to be maintained much in the future, should we keep using it or should we look at switching to something else? (anitsirk, 07:54:27)
    5. IDEA: we could switch but that could be expensive to rewrite customizations (anitsirk, 07:56:04)
    6. HELP: are there any big templating systems for php or is it just homebrewed things from various developers? (anitsirk, 07:57:00)
    7. IDEA: from rkabalin_ : I think we should keep Dwoo, as it entirely meets our requirements at the moment and maintain it as a part of Mahara. (anitsirk, 07:57:57)
    8. http://twig.sensiolabs.org/ (anzeljg, 08:01:27)
    9. http://twig.sensiolabs.org/ (fmarier, 08:01:27)
    10. ACTION: fmarier to create a wishlist bug for twig as templating system (anitsirk, 08:03:15)
    11. https://bugs.launchpad.net/mahara/+bug/966001 (fmarier, 08:04:33)
    12. http://fabien.potencier.org/article/34/templating-engines-in-php (Mjollnir`, 08:08:42)
    13. http://fabien.potencier.org/article/34/templating-engines-in-php (fmarier, 08:09:10)
    14. http://wiki.cmsmadesimple.org/index.php/FAQ2#Who.27s_that_Smarty_guy.3F (anzeljg, 08:10:29)

  4. Should CIA commit go on #mahara-dev? (Francois) (anitsirk, 08:10:44)
    1. http://feeding.cloud.geek.nz/2012/03/watching-gerrit-merges-on-irc-using.html for background reading on the topic (anitsirk, 08:10:44)
    2. http://feeding.cloud.geek.nz/2012/03/watching-gerrit-merges-on-irc-using.html (anitsirk, 08:10:45)
    3. #mahara-commits currently has notices whenever something is merged from gerrit (anitsirk, 08:12:01)
    4. AGREED: CIA commits currently on #mahara-cmmits move to #mahara-dev (anitsirk, 08:13:07)
    5. ACTION: fmarier to move CIA commits from #mahara-commits to #mahara-dev (anitsirk, 08:13:22)

  5. Update on how we give access to new translators (Francois & Richard) (anitsirk, 08:13:56)
    1. https://launchpad.net/~launchpad-translators (fmarier, 08:20:10)
    2. IDEA: make the translation group either open or assign it to the respective Launchpad Translators group (anitsirk, 08:21:51)
    3. IDEA: ideally the owners of the mahara langpacks should be the teams in this list: https://translations.launchpad.net/+groups/launchpad-translators/ because they are the most active translation groups (anitsirk, 08:22:51)
    4. in some cases, the mahara translators prefer to have their own group. (anitsirk, 08:23:49)
    5. ACTION: anzeljg joins the slovenian team on launchpad so that we could make it the owner of the mahara translation (anitsirk, 08:27:59)
    6. https://launchpad.net/~lp-l10n-sl (fmarier, 08:28:21)
    7. HELP: who would approve lang strings marked for review in a translation if we assign the launchpad translators group as the owner of the mahara translation? (anitsirk, 08:31:52)
    8. anyone from a translation team can approve strings that need reviewing (anitsirk, 08:32:43)
    9. if a translation maintainer notices that a translation team has lead to inconsistency and a lower quality of the translation, then we can always change it back to a Mahara-specific translation team (anitsirk, 08:33:34)
    10. https://translations.launchpad.net/+groups/mahara-translation-group (fmarier, 08:34:16)
    11. https://translations.launchpad.net/mahara-lang/trunk/+pots/mahara/sl/+details (fmarier, 08:37:28)
    12. https://translations.launchpad.net/mahara-lang/trunk/+pots/mahara/sl/+filter?person=gregor-anzelj (elky, 08:39:03)
    13. the general launchpad russian translator team is now used for the russian mahara translation https://launchpad.net/~lp-l10n-ru (anitsirk, 08:39:54)
    14. AGREED: we'll use the most active launchpad teams for each language unless there's a reason for using a different one for a given mahara translation (anitsirk, 08:45:52)

  6. Next meeting and Chair (anitsirk, 08:52:39)
    1. IDEA: http://www.timeanddate.com/worldclock/fixedtime.html?msg=16th+Mahara+Developer+Meeting&iso=20120424T20 (anitsirk, 08:58:49)
    2. AGREED: : next meeting will be on April 24, 2012 at 20:00 UTC http://www.timeanddate.com/worldclock/fixedtime.html?msg=16th+Mahara+Developer+Meeting&iso=20120424T20 (anitsirk, 09:00:06)
    3. HELP: who wants to be chair? (anitsirk, 09:00:16)
    4. AGREED: : dobedobedoh is going to chair the 16th Mahara Developer Meeting. (anitsirk, 09:07:35)

  7. Any other business (anitsirk, 09:07:41)
    1. The 5th Newsletter will be out on April 1. I still take submissions for dev stories, new plugins etc. until the end of today UTC or tomorrow if I receive a quick message that about 150 words are on its way. (anitsirk, 09:08:06)
    2. it's the last mahara dev meeting for fmarier als catalyst employee (anitsirk, 09:13:02)


Meeting ended at 09:22:28 UTC (full logs).

Action items

  1. fmarier to create a wishlist bug for twig as templating system
  2. fmarier to move CIA commits from #mahara-commits to #mahara-dev
  3. anzeljg joins the slovenian team on launchpad so that we could make it the owner of the mahara translation


Action items, by person

  1. anzeljg
    1. anzeljg joins the slovenian team on launchpad so that we could make it the owner of the mahara translation
  2. fmarier
    1. fmarier to create a wishlist bug for twig as templating system
    2. fmarier to move CIA commits from #mahara-commits to #mahara-dev


People present (lines said)

  1. anitsirk (114)
  2. fmarier (100)
  3. anzeljg (50)
  4. elky (45)
  5. richardm (35)
  6. rkabalin_ (33)
  7. dobedobedoh (31)
  8. Mjollnir` (16)
  9. maharameet (2)
  10. maharabug (1)
  11. dan_p (1)


Generated by MeetBot 0.1.4.